You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "Kostas Kloudas (JIRA)" <ji...@apache.org> on 2019/08/07 07:51:01 UTC
[jira] [Closed] (FLINK-13428) StreamingFileSink allow part file
name to be configurable
[ https://issues.apache.org/jira/browse/FLINK-13428?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Kostas Kloudas closed FLINK-13428.
----------------------------------
Resolution: Fixed
Merged on master with e9d3d58eff5c9a3727b1d5b2b3dfaec136267951
> StreamingFileSink allow part file name to be configurable
> ---------------------------------------------------------
>
> Key: FLINK-13428
> URL: https://issues.apache.org/jira/browse/FLINK-13428
> Project: Flink
> Issue Type: Improvement
> Components: Connectors / FileSystem
> Reporter: Joao Boto
> Assignee: Joao Boto
> Priority: Major
> Labels: pull-request-available
> Fix For: 1.10.0
>
> Time Spent: 10m
> Remaining Estimate: 0h
>
> Allow that part file name could be configurable:
> * partPrefix and partSuffix can be passed
>
> the part prefix allow to set a better name to file
> the part suffix (if used as extension) allow system like Athena or Presto to automatic detect the type of file and the compression if applied
--
This message was sent by Atlassian JIRA
(v7.6.14#76016)