You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@mesos.apache.org by Benjamin Hindman <be...@berkeley.edu> on 2014/10/12 00:13:37 UTC

Review Request 26610: Consolidated "launch" code paths in Docker containerizer.

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/26610/
-----------------------------------------------------------

Review request for mesos and Timothy Chen.


Repository: mesos-git


Description
-------

This is a flattened review of the refactorings to the Docker containerizer to consolidate the "launch" code paths. Please add comments to the broken up indepedent reviews at https://reviews.apache.org/r/26611 https://reviews.apache.org/r/26612 https://reviews.apache.org/r/26613 https://reviews.apache.org/r/26614 https://reviews.apache.org/r/26615 https://reviews.apache.org/r/26616 https://reviews.apache.org/r/26617 https://reviews.apache.org/r/26618.


Diffs
-----

  src/slave/containerizer/docker.cpp 9a2948951f57f3ab16291df51cd9f33e5e96add4 

Diff: https://reviews.apache.org/r/26610/diff/


Testing
-------

make check


Thanks,

Benjamin Hindman


Re: Review Request 26610: Consolidated "launch" code paths in Docker containerizer.

Posted by Mesos ReviewBot <de...@mesos.apache.org>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/26610/#review56308
-----------------------------------------------------------


Bad patch!

Reviews applied: [26610]

Failed command: ./support/mesos-style.py

Error:
 Checking 519 files using filter --filter=-,+build/class,+build/deprecated,+build/endif_comment,+readability/todo,+readability/namespace,+runtime/vlog,+whitespace/blank_line,+whitespace/comma,+whitespace/end_of_line,+whitespace/ending_newline,+whitespace/forcolon,+whitespace/indent,+whitespace/line_length,+whitespace/tab,+whitespace/todo
src/slave/containerizer/docker.cpp:214:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:215:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:216:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:217:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:218:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:219:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:220:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:221:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:222:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:228:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:229:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:230:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:231:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:232:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:233:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:234:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:235:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:237:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:238:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:239:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:240:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:241:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:242:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:243:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:244:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:245:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:248:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:250:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:262:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:271:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:280:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:290:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:291:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:295:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:296:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:297:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:298:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:299:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:300:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:304:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:305:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:577:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:578:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:579:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:580:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:581:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:993:  Tab found; better to use spaces  [whitespace/tab] [1]
src/slave/containerizer/docker.cpp:1107:  Tab found; better to use spaces  [whitespace/tab] [1]
Total errors found: 48

- Mesos ReviewBot


On Oct. 11, 2014, 10:13 p.m., Benjamin Hindman wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/26610/
> -----------------------------------------------------------
> 
> (Updated Oct. 11, 2014, 10:13 p.m.)
> 
> 
> Review request for mesos and Timothy Chen.
> 
> 
> Repository: mesos-git
> 
> 
> Description
> -------
> 
> This is a flattened review of the refactorings to the Docker containerizer to consolidate the "launch" code paths. Please add comments to the broken up indepedent reviews at https://reviews.apache.org/r/26611 https://reviews.apache.org/r/26612 https://reviews.apache.org/r/26613 https://reviews.apache.org/r/26614 https://reviews.apache.org/r/26615 https://reviews.apache.org/r/26616 https://reviews.apache.org/r/26617 https://reviews.apache.org/r/26618.
> 
> 
> Diffs
> -----
> 
>   src/slave/containerizer/docker.cpp 9a2948951f57f3ab16291df51cd9f33e5e96add4 
> 
> Diff: https://reviews.apache.org/r/26610/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Benjamin Hindman
> 
>


Re: Review Request 26610: Consolidated "launch" code paths in Docker containerizer.

Posted by Mesos ReviewBot <de...@mesos.apache.org>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/26610/#review56453
-----------------------------------------------------------


Patch looks great!

Reviews applied: [26610]

All tests passed.

- Mesos ReviewBot


On Oct. 13, 2014, 9:16 p.m., Benjamin Hindman wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/26610/
> -----------------------------------------------------------
> 
> (Updated Oct. 13, 2014, 9:16 p.m.)
> 
> 
> Review request for mesos and Timothy Chen.
> 
> 
> Repository: mesos-git
> 
> 
> Description
> -------
> 
> This is a flattened review of the refactorings to the Docker containerizer to consolidate the "launch" code paths. Please add comments to the broken up indepedent reviews at https://reviews.apache.org/r/26611 https://reviews.apache.org/r/26612 https://reviews.apache.org/r/26613 https://reviews.apache.org/r/26614 https://reviews.apache.org/r/26615 https://reviews.apache.org/r/26616 https://reviews.apache.org/r/26617 https://reviews.apache.org/r/26618.
> 
> 
> Diffs
> -----
> 
>   src/slave/containerizer/docker.cpp 9a2948951f57f3ab16291df51cd9f33e5e96add4 
>   src/tests/docker_containerizer_tests.cpp 67d60a885d65edbcbbf702bce83a54d1a5c0411f 
> 
> Diff: https://reviews.apache.org/r/26610/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Benjamin Hindman
> 
>


Re: Review Request 26610: Consolidated "launch" code paths in Docker containerizer.

Posted by Benjamin Hindman <be...@berkeley.edu>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/26610/
-----------------------------------------------------------

(Updated Oct. 13, 2014, 9:16 p.m.)


Review request for mesos and Timothy Chen.


Repository: mesos-git


Description
-------

This is a flattened review of the refactorings to the Docker containerizer to consolidate the "launch" code paths. Please add comments to the broken up indepedent reviews at https://reviews.apache.org/r/26611 https://reviews.apache.org/r/26612 https://reviews.apache.org/r/26613 https://reviews.apache.org/r/26614 https://reviews.apache.org/r/26615 https://reviews.apache.org/r/26616 https://reviews.apache.org/r/26617 https://reviews.apache.org/r/26618.


Diffs (updated)
-----

  src/slave/containerizer/docker.cpp 9a2948951f57f3ab16291df51cd9f33e5e96add4 
  src/tests/docker_containerizer_tests.cpp 67d60a885d65edbcbbf702bce83a54d1a5c0411f 

Diff: https://reviews.apache.org/r/26610/diff/


Testing
-------

make check


Thanks,

Benjamin Hindman


Re: Review Request 26610: Consolidated "launch" code paths in Docker containerizer.

Posted by Benjamin Hindman <be...@berkeley.edu>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/26610/
-----------------------------------------------------------

(Updated Oct. 13, 2014, 9:15 p.m.)


Review request for mesos and Timothy Chen.


Repository: mesos-git


Description
-------

This is a flattened review of the refactorings to the Docker containerizer to consolidate the "launch" code paths. Please add comments to the broken up indepedent reviews at https://reviews.apache.org/r/26611 https://reviews.apache.org/r/26612 https://reviews.apache.org/r/26613 https://reviews.apache.org/r/26614 https://reviews.apache.org/r/26615 https://reviews.apache.org/r/26616 https://reviews.apache.org/r/26617 https://reviews.apache.org/r/26618.


Diffs (updated)
-----

  docs/mesos-c++-style-guide.md f50354c4cd0278d26efded3756bd90413c58c7b6 
  src/docker/docker.hpp 9656f15547a522f9866c28c78d431508771c795a 
  src/docker/docker.cpp e09b51c4f5101c3a8e77caf12b208c88f47fbcb2 
  src/slave/containerizer/docker.cpp 9a2948951f57f3ab16291df51cd9f33e5e96add4 
  src/tests/docker_containerizer_tests.cpp 67d60a885d65edbcbbf702bce83a54d1a5c0411f 

Diff: https://reviews.apache.org/r/26610/diff/


Testing
-------

make check


Thanks,

Benjamin Hindman