You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@tajo.apache.org by "Hyunsik Choi (JIRA)" <ji...@apache.org> on 2015/09/23 08:59:04 UTC
[jira] [Updated] (TAJO-1882) Clean up
GreedyHeuristicJoinOrderAlgorithm::getCost APIs
[ https://issues.apache.org/jira/browse/TAJO-1882?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Hyunsik Choi updated TAJO-1882:
-------------------------------
Labels: newbie (was: )
> Clean up GreedyHeuristicJoinOrderAlgorithm::getCost APIs
> --------------------------------------------------------
>
> Key: TAJO-1882
> URL: https://issues.apache.org/jira/browse/TAJO-1882
> Project: Tajo
> Issue Type: Improvement
> Reporter: Hyunsik Choi
> Priority: Trivial
> Labels: newbie
>
> See the title. The definition of {{GreedyHeuristicJoinOrderAlgorithm::getCost}} is somewhat ambiguous. In Java 8, it requires explicitly type casting. We can clean up its APIs by renaming them to be different.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)