You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@zookeeper.apache.org by "Hadoop QA (JIRA)" <ji...@apache.org> on 2015/10/28 15:40:27 UTC

[jira] [Commented] (ZOOKEEPER-2306) Remove file delete duplicate code from test code

    [ https://issues.apache.org/jira/browse/ZOOKEEPER-2306?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14978520#comment-14978520 ] 

Hadoop QA commented on ZOOKEEPER-2306:
--------------------------------------

-1 overall.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12769240/ZOOKEEPER-2306-01.patch
  against trunk revision 1709293.

    +1 @author.  The patch does not contain any @author tags.

    +1 tests included.  The patch appears to include 14 new or modified tests.

    +1 javadoc.  The javadoc tool did not generate any warning messages.

    +1 javac.  The applied patch does not increase the total number of javac compiler warnings.

    +1 findbugs.  The patch does not introduce any new Findbugs (version 2.0.3) warnings.

    +1 release audit.  The applied patch does not increase the total number of release audit warnings.

    -1 core tests.  The patch failed core unit tests.

    +1 contrib tests.  The patch passed contrib unit tests.

Test results: https://builds.apache.org/job/PreCommit-ZOOKEEPER-Build/2933//testReport/
Findbugs warnings: https://builds.apache.org/job/PreCommit-ZOOKEEPER-Build/2933//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
Console output: https://builds.apache.org/job/PreCommit-ZOOKEEPER-Build/2933//console

This message is automatically generated.

> Remove file delete duplicate  code from test code
> -------------------------------------------------
>
>                 Key: ZOOKEEPER-2306
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-2306
>             Project: ZooKeeper
>          Issue Type: Improvement
>          Components: tests
>            Reporter: Arshad Mohammad
>            Assignee: Arshad Mohammad
>             Fix For: 3.5.2
>
>         Attachments: ZOOKEEPER-2306-01.patch
>
>
> Code to delete a folder recursive is written in multiple test files. Following are the files containing the same piece of code.
> {code}
> src/java/systest/org/apache/zookeeper/test/system/QuorumPeerInstance.java
> src/java/test/org/apache/zookeeper/test/ClientBase.java
> src/java/test/org/apache/zookeeper/server/quorum/LearnerTest.java
> src/java/test/org/apache/zookeeper/server/quorum/Zab1_0Test.java
> {code}
> Remove duplicate code from these files



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)