You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@ofbiz.apache.org by jl...@apache.org on 2009/01/23 12:08:55 UTC
svn commit: r737003 [2/11] - in /ofbiz/trunk: ./
applications/accounting/entitydef/
applications/accounting/script/org/ofbiz/accounting/invoice/
applications/accounting/script/org/ofbiz/accounting/ledger/
applications/accounting/servicedef/ application...
Modified: ofbiz/trunk/applications/content/config/ContentEntityLabels.xml
URL: http://svn.apache.org/viewvc/ofbiz/trunk/applications/content/config/ContentEntityLabels.xml?rev=737003&r1=737002&r2=737003&view=diff
==============================================================================
--- ofbiz/trunk/applications/content/config/ContentEntityLabels.xml (original)
+++ ofbiz/trunk/applications/content/config/ContentEntityLabels.xml Fri Jan 23 03:08:47 2009
@@ -24,7 +24,7 @@
<value xml:lang="en">ISO-8859-1</value>
<value xml:lang="es">ISO-8859-1 Inglés</value>
<value xml:lang="fr">ISO-8859-1</value>
- <value xml:lang="it">ISO-8859-1</value>
+ <value xml:lang="it">ISO-8859-1</value>
<value xml:lang="th">ISO-8859-1</value>
</property>
<property key="CharacterSet.description.ISO-8859-10">
@@ -32,7 +32,7 @@
<value xml:lang="en">ISO-8859-10</value>
<value xml:lang="es">ISO-8859-10 ?</value>
<value xml:lang="fr">ISO-8859-10</value>
- <value xml:lang="it">ISO-8859-10</value>
+ <value xml:lang="it">ISO-8859-10</value>
<value xml:lang="th">ISO-8859-10</value>
</property>
<property key="CharacterSet.description.ISO-8859-2">
@@ -40,7 +40,7 @@
<value xml:lang="en">ISO-8859-2</value>
<value xml:lang="es">ISO-8859-2 ?</value>
<value xml:lang="fr">ISO-8859-2</value>
- <value xml:lang="it">ISO-8859-2</value>
+ <value xml:lang="it">ISO-8859-2</value>
<value xml:lang="th">ISO-8859-2</value>
</property>
<property key="CharacterSet.description.ISO-8859-3">
@@ -48,7 +48,7 @@
<value xml:lang="en">ISO-8859-3</value>
<value xml:lang="es">ISO-8859-3 ?</value>
<value xml:lang="fr">ISO-8859-3</value>
- <value xml:lang="it">ISO-8859-3</value>
+ <value xml:lang="it">ISO-8859-3</value>
<value xml:lang="th">ISO-8859-3</value>
</property>
<property key="CharacterSet.description.ISO-8859-4">
@@ -56,7 +56,7 @@
<value xml:lang="en">ISO-8859-4</value>
<value xml:lang="es">ISO-8859-4 ?</value>
<value xml:lang="fr">ISO-8859-4</value>
- <value xml:lang="it">ISO-8859-4</value>
+ <value xml:lang="it">ISO-8859-4</value>
<value xml:lang="th">ISO-8859-4</value>
</property>
<property key="CharacterSet.description.ISO-8859-5">
@@ -64,7 +64,7 @@
<value xml:lang="en">ISO-8859-5</value>
<value xml:lang="es">ISO-8859-5 ?</value>
<value xml:lang="fr">ISO-8859-5</value>
- <value xml:lang="it">ISO-8859-5</value>
+ <value xml:lang="it">ISO-8859-5</value>
<value xml:lang="th">ISO-8859-5</value>
</property>
<property key="CharacterSet.description.ISO-8859-6">
@@ -72,7 +72,7 @@
<value xml:lang="en">ISO-8859-6</value>
<value xml:lang="es">ISO-8859-6 Latino/árabe</value>
<value xml:lang="fr">ISO-8859-6</value>
- <value xml:lang="it">ISO-8859-6</value>
+ <value xml:lang="it">ISO-8859-6</value>
<value xml:lang="th">ISO-8859-6</value>
</property>
<property key="CharacterSet.description.ISO-8859-7">
@@ -80,7 +80,7 @@
<value xml:lang="en">ISO-8859-7</value>
<value xml:lang="es">ISO-8859-7 ?</value>
<value xml:lang="fr">ISO-8859-7</value>
- <value xml:lang="it">ISO-8859-7</value>
+ <value xml:lang="it">ISO-8859-7</value>
<value xml:lang="th">ISO-8859-7</value>
</property>
<property key="CharacterSet.description.ISO-8859-8">
@@ -88,7 +88,7 @@
<value xml:lang="en">ISO-8859-8</value>
<value xml:lang="es">ISO-8859-8 Latino/Hebreo</value>
<value xml:lang="fr">ISO-8859-8</value>
- <value xml:lang="it">ISO-8859-8</value>
+ <value xml:lang="it">ISO-8859-8</value>
<value xml:lang="th">ISO-8859-8</value>
</property>
<property key="CharacterSet.description.ISO-8859-9">
@@ -96,7 +96,7 @@
<value xml:lang="en">ISO-8859-9</value>
<value xml:lang="es">ISO-8859-9 ?</value>
<value xml:lang="fr">ISO-8859-9</value>
- <value xml:lang="it">ISO-8859-9</value>
+ <value xml:lang="it">ISO-8859-9</value>
<value xml:lang="th">ISO-8859-9</value>
</property>
<property key="CharacterSet.description.US-ASCII">
@@ -104,7 +104,7 @@
<value xml:lang="en">US-ASCII</value>
<value xml:lang="es">US-ASCII</value>
<value xml:lang="fr">US-ASCII</value>
- <value xml:lang="it">US-ASCII</value>
+ <value xml:lang="it">US-ASCII</value>
<value xml:lang="th">US-ASCII</value>
</property>
<property key="CharacterSet.description.UTF-16">
@@ -112,7 +112,7 @@
<value xml:lang="en">UTF-16</value>
<value xml:lang="es">Unicode 16 bit</value>
<value xml:lang="fr">UTF-16</value>
- <value xml:lang="it">UTF-16</value>
+ <value xml:lang="it">UTF-16</value>
<value xml:lang="th">UTF-16</value>
</property>
<property key="CharacterSet.description.UTF-8">
@@ -120,7 +120,7 @@
<value xml:lang="en">UTF-8</value>
<value xml:lang="es">Unicode 8 bit</value>
<value xml:lang="fr">UTF-8</value>
- <value xml:lang="it">UTF-8</value>
+ <value xml:lang="it">UTF-8</value>
<value xml:lang="th">UTF-8</value>
</property>
<property key="Content.contentName.LEFTBAR">
@@ -128,7 +128,7 @@
<value xml:lang="en">LEFTBAR</value>
<value xml:lang="es">Barra izquierda</value>
<value xml:lang="fr">Barre gauche</value>
- <value xml:lang="it">Barra sinistra</value>
+ <value xml:lang="it">Barra sinistra</value>
<value xml:lang="th">à¹à¸à¸à¸à¸²à¸à¸à¹à¸²à¸¢</value>
</property>
<property key="Content.contentName.OWNER_BLOG_CONTENT">
@@ -136,7 +136,7 @@
<value xml:lang="en">OWNER_BLOG_CONTENT</value>
<value xml:lang="es">Administrador del contenido del blog</value>
<value xml:lang="fr">Propriétaire du contenu du Blog</value>
- <value xml:lang="it">Propritario del contenuto del blog</value>
+ <value xml:lang="it">Propritario del contenuto del blog</value>
<value xml:lang="th">à¹à¸à¹à¸²à¸à¸à¸à¸«à¸±à¸§à¸à¹à¸</value>
</property>
<property key="Content.contentName.TEMPLATE_IMAGE_LEFT">
@@ -144,7 +144,7 @@
<value xml:lang="en">TEMPLATE_IMAGE_LEFT</value>
<value xml:lang="es">Imagen izquierda</value>
<value xml:lang="fr">Gabarit d'image gauche</value>
- <value xml:lang="it">Template immagine di sinistra</value>
+ <value xml:lang="it">Template immagine di sinistra</value>
<value xml:lang="th">รูà¸à¸ าà¸à¸à¸²à¸à¸à¹à¸²à¸¢</value>
</property>
<property key="Content.contentName.TMPLT_IMG_CENTER">
@@ -152,14 +152,14 @@
<value xml:lang="en">TMPLT_IMG_CENTER</value>
<value xml:lang="es">Imagen centrada</value>
<value xml:lang="fr">Gabarit d'image centre</value>
- <value xml:lang="it">Template immagine di centro</value>
+ <value xml:lang="it">Template immagine di centro</value>
<value xml:lang="th">รูà¸à¸ าà¸à¸à¸£à¸à¸à¸¥à¸²à¸</value>
</property>
<property key="Content.description.10000">
<value xml:lang="de">10000</value>
<value xml:lang="en">10000</value>
<value xml:lang="fr">10000</value>
- <value xml:lang="it">10000</value>
+ <value xml:lang="it">10000</value>
<value xml:lang="th">10000</value>
</property>
<property key="Content.description.NOCONTENTFOUND">
@@ -167,7 +167,7 @@
<value xml:lang="en">NO CONTENT FOUND</value>
<value xml:lang="es">No se encontró contenido</value>
<value xml:lang="fr">Aucun contenu trouvé</value>
- <value xml:lang="it">Nessun contenuto trovato</value>
+ <value xml:lang="it">Nessun contenuto trovato</value>
<value xml:lang="th">à¹à¸¡à¹à¸à¸à¸«à¸±à¸§à¸à¹à¸</value>
</property>
<property key="Content.description.NOTEXTFOUND">
@@ -175,7 +175,7 @@
<value xml:lang="en">NO TEXT FOUND</value>
<value xml:lang="es">No se encontró texto</value>
<value xml:lang="fr">Aucun texte trouvé</value>
- <value xml:lang="it">Nessun testo trovato</value>
+ <value xml:lang="it">Nessun testo trovato</value>
<value xml:lang="th">à¹à¸¡à¹à¸à¸à¸à¸±à¸§à¸à¸±à¸à¸©à¸£</value>
</property>
<property key="Content.description.TEMPLATE_MASTER">
@@ -183,7 +183,7 @@
<value xml:lang="en">TEMPLATE_MASTER</value>
<value xml:lang="es">Plantilla maestra</value>
<value xml:lang="fr">Gabarit principal</value>
- <value xml:lang="it">Template primario</value>
+ <value xml:lang="it">Template primario</value>
<value xml:lang="th">TEMPLATE à¸à¹à¸à¸à¸à¸±à¸</value>
</property>
<property key="Content.description.TP_BUSINESS">
@@ -191,7 +191,7 @@
<value xml:lang="en">TP_BUSINESS</value>
<value xml:lang="es">Negocio</value>
<value xml:lang="fr">Gabarit "business"</value>
- <value xml:lang="it">Template di business</value>
+ <value xml:lang="it">Template di business</value>
<value xml:lang="th">TEMPLATE à¸à¸£à¸´à¸©à¸±à¸</value>
</property>
<property key="Content.description.TP_LEGAL">
@@ -199,7 +199,7 @@
<value xml:lang="en">TP_LEGAL</value>
<value xml:lang="es">Legal</value>
<value xml:lang="fr">Gabarit légal</value>
- <value xml:lang="it">Template legale</value>
+ <value xml:lang="it">Template legale</value>
<value xml:lang="th">TEMPLATE à¸à¸µà¹à¸à¸¹à¸à¸à¹à¸à¸à¸à¸²à¸¡à¸à¸à¸«à¸¡à¸²à¸¢</value>
</property>
<property key="Content.description.TP_TECHNICAL">
@@ -207,7 +207,7 @@
<value xml:lang="en">TP_TECHNICAL</value>
<value xml:lang="es">Técnico</value>
<value xml:lang="fr">Gabarit technique</value>
- <value xml:lang="it">Template tecnico</value>
+ <value xml:lang="it">Template tecnico</value>
<value xml:lang="th">TEMPLATE à¹à¸à¸µà¹à¸¢à¸§à¸à¸±à¸à¸§à¸´à¸à¸²à¸à¹à¸²à¸</value>
</property>
<property key="ContentAssocPredicate.description.categorizes">
@@ -215,7 +215,7 @@
<value xml:lang="en">categorizes</value>
<value xml:lang="es">Clasifica</value>
<value xml:lang="fr">Classifie</value>
- <value xml:lang="it">Categorie</value>
+ <value xml:lang="it">Categorie</value>
<value xml:lang="th">à¸à¸±à¸à¸«à¸¡à¸§à¸à¸«à¸¡à¸¹à¹</value>
</property>
<property key="ContentAssocPredicate.description.defines">
@@ -223,7 +223,7 @@
<value xml:lang="en">defines</value>
<value xml:lang="es">Define</value>
<value xml:lang="fr">Définit</value>
- <value xml:lang="it">Definizione</value>
+ <value xml:lang="it">Definizione</value>
<value xml:lang="th">à¸à¸³à¸«à¸à¸</value>
</property>
<property key="ContentAssocPredicate.description.extends">
@@ -231,7 +231,7 @@
<value xml:lang="en">extends</value>
<value xml:lang="es">amplÃa</value>
<value xml:lang="fr">Etend</value>
- <value xml:lang="it">Estendi</value>
+ <value xml:lang="it">Estendi</value>
<value xml:lang="th">ยืà¸à¹à¸§à¸¥à¸²à¸à¸à¸à¹à¸</value>
</property>
<property key="ContentAssocPredicate.description.member-of">
@@ -239,7 +239,7 @@
<value xml:lang="en">member-of</value>
<value xml:lang="es">es miembro de</value>
<value xml:lang="fr">Est membre de</value>
- <value xml:lang="it">Mrembro-di</value>
+ <value xml:lang="it">Mrembro-di</value>
<value xml:lang="th">สมาà¸à¸´à¸à¸à¸à¸</value>
</property>
<property key="ContentAssocPredicate.description.references">
@@ -247,7 +247,7 @@
<value xml:lang="en">references</value>
<value xml:lang="es">referencia</value>
<value xml:lang="fr">Référence</value>
- <value xml:lang="it">Riferimenti</value>
+ <value xml:lang="it">Riferimenti</value>
<value xml:lang="th">à¸à¹à¸²à¸à¸à¸´à¸</value>
</property>
<property key="ContentAssocPredicate.description.related-to">
@@ -255,7 +255,7 @@
<value xml:lang="en">related-to</value>
<value xml:lang="es">se relaciona con</value>
<value xml:lang="fr">Apparenté à </value>
- <value xml:lang="it">Relativo-a</value>
+ <value xml:lang="it">Relativo-a</value>
<value xml:lang="th">à¹à¸à¸µà¹à¸¢à¸§à¸à¹à¸à¸à¸à¸±à¸</value>
</property>
<property key="ContentAssocPredicate.description.topifies">
@@ -263,7 +263,7 @@
<value xml:lang="en">topifies</value>
<value xml:lang="es">Archivos principales</value>
<value xml:lang="fr">Transforme en sujet</value>
- <value xml:lang="it">File principale</value>
+ <value xml:lang="it">File principale</value>
<value xml:lang="th">topifies</value>
</property>
<property key="ContentAssocType.description.ALTERNATE_LOCALE">
@@ -1145,7 +1145,7 @@
<value xml:lang="de">Basis</value>
<value xml:lang="en">ROOT</value>
<value xml:lang="fr">Racine</value>
- <value xml:lang="it">Radice</value>
+ <value xml:lang="it">Radice</value>
<value xml:lang="th">à¸à¹à¸à¸à¸³à¹à¸à¸´à¸</value>
</property>
<property key="DataCategory.categoryName.TECHNOLOGY">
@@ -1396,7 +1396,7 @@
<value xml:lang="en">BILL_OF_LADING</value>
<value xml:lang="es">Cuenta de carga</value>
<value xml:lang="fr">Connaissement</value>
- <value xml:lang="it">Polizza di carico</value>
+ <value xml:lang="it">Polizza di carico</value>
<value xml:lang="th">รายà¸à¸²à¸£à¸à¸à¸à¸ªà¸´à¸à¸à¹à¸²</value>
</property>
<property key="DocumentType.description.EXPORT_DOCUMENTATION">
@@ -1404,7 +1404,7 @@
<value xml:lang="en">EXPORT_DOCUMENTATION</value>
<value xml:lang="es">Documentación de exportación</value>
<value xml:lang="fr">Documentation d'export</value>
- <value xml:lang="it">Documentazione esportata</value>
+ <value xml:lang="it">Documentazione esportata</value>
<value xml:lang="th">à¸à¸²à¸£à¹à¸à¸£à¸µà¸¢à¸¡à¹à¸à¸à¸ªà¸²à¸£à¸ªà¹à¸à¸à¸à¸</value>
</property>
<property key="DocumentType.description.MANIFEST">
@@ -1412,7 +1412,7 @@
<value xml:lang="en">MANIFEST</value>
<value xml:lang="es">Manifiesto</value>
<value xml:lang="fr">Manifeste</value>
- <value xml:lang="it">Manifesto</value>
+ <value xml:lang="it">Manifesto</value>
<value xml:lang="th">รายà¸à¸²à¸£à¸ªà¸´à¸à¸à¹à¸²</value>
</property>
<property key="DocumentType.description.OTHER_SHIP_DOCUMENT">
@@ -1420,7 +1420,7 @@
<value xml:lang="en">OTHER_SHIP_DOCUMENT</value>
<value xml:lang="es">Otros documentos de envÃos</value>
<value xml:lang="fr">Autre document expédié</value>
- <value xml:lang="it">Altro documento di spedizione</value>
+ <value xml:lang="it">Altro documento di spedizione</value>
<value xml:lang="zh">à¹à¸à¸à¸ªà¸²à¸£à¸à¸²à¸£à¸à¸à¸ªà¹à¸à¸à¸·à¹à¸ à¹</value>
</property>
<property key="DocumentType.description.PACKAGING_SLIP">
@@ -1428,7 +1428,7 @@
<value xml:lang="en">PACKAGING_SLIP</value>
<value xml:lang="es">Embalaje</value>
<value xml:lang="fr">Fiche de conditionnement</value>
- <value xml:lang="it">Lista di imballo</value>
+ <value xml:lang="it">Lista di imballo</value>
<value xml:lang="th">สลิà¸à¸à¸²à¸£à¸«à¹à¸à¸ªà¸´à¸à¸à¹à¸²</value>
</property>
<property key="DocumentType.description.PORT_CHARGE_DOCUMENT">
@@ -1436,7 +1436,7 @@
<value xml:lang="en">PORT_CHARGE_DOCUMENT</value>
<value xml:lang="es">Carga en puerto</value>
<value xml:lang="fr">Document de chargement en port</value>
- <value xml:lang="it">Documento di carico</value>
+ <value xml:lang="it">Documento di carico</value>
<value xml:lang="th">à¹à¸à¸à¸ªà¸²à¸£à¸à¸²à¸£à¹à¸à¸¥à¸µà¹à¸¢à¸à¸à¸à¸£à¹à¸</value>
</property>
<property key="DocumentType.description.SHIPPING_DOCUMENT">
@@ -1444,7 +1444,7 @@
<value xml:lang="en">SHIPPING_DOCUMENT</value>
<value xml:lang="es">EnvÃo</value>
<value xml:lang="fr">Document d'expédition</value>
- <value xml:lang="it">Documento di spedizione</value>
+ <value xml:lang="it">Documento di spedizione</value>
<value xml:lang="th">à¹à¸à¸à¸ªà¸²à¸£à¸à¸²à¸£à¸à¸à¸ªà¹à¸</value>
</property>
<property key="MetaDataPredicate.description.author-email">
@@ -1537,7 +1537,7 @@
<value xml:lang="de">Microsoft Excel</value>
<value xml:lang="en">Microsoft Excel</value>
<value xml:lang="fr">Microsoft Excel</value>
- <value xml:lang="it">Microsoft Excel</value>
+ <value xml:lang="it">Microsoft Excel</value>
<value xml:lang="th">Microsoft Excel</value>
<value xml:lang="zh">微软Excel</value>
</property>
@@ -1545,7 +1545,7 @@
<value xml:lang="de">Microsoft PowerPoint</value>
<value xml:lang="en">Microsoft PowerPoint</value>
<value xml:lang="fr">Microsoft PowerPoint</value>
- <value xml:lang="it">Microsoft PowerPoint</value>
+ <value xml:lang="it">Microsoft PowerPoint</value>
<value xml:lang="th">Microsoft PowerPoint</value>
<value xml:lang="zh">微软PowerPoint</value>
</property>
@@ -1580,7 +1580,7 @@
<value xml:lang="de">ZIP-komprimierte Datei</value>
<value xml:lang="en">ZIP compressed file</value>
<value xml:lang="fr">Dossier compressé ZIP</value>
- <value xml:lang="it">File ZIP compresso</value>
+ <value xml:lang="it">File ZIP compresso</value>
<value xml:lang="th">ZIP à¸à¸²à¸£à¸à¸µà¸à¸à¸±à¸à¹à¸à¸¥à¹</value>
<value xml:lang="zh">ZIPå缩æä»¶</value>
</property>
@@ -1633,7 +1633,7 @@
<value xml:lang="de">Progressives JPEG/JPG Bild</value>
<value xml:lang="en">Progressive JPEG/JPG Image</value>
<value xml:lang="fr">Image progressive JPG/JPEG</value>
- <value xml:lang="it">Immagine progressiva JPEG/JPG</value>
+ <value xml:lang="it">Immagine progressiva JPEG/JPG</value>
<value xml:lang="th">รูà¸à¸ าà¸à¸à¸µà¹à¸à¸±à¸à¸à¸²à¸à¸¶à¹à¸ JPEG/JPG</value>
<value xml:lang="zh">è¿æ¥JPEG/JPGå¾å</value>
</property>
@@ -1803,7 +1803,7 @@
<value xml:lang="de">CSV - Comma Separated Value Text</value>
<value xml:lang="en">Comma Separated Value Text </value>
<value xml:lang="fr">Valeur de texte séparée par une virgule (CSV)</value>
- <value xml:lang="it">Valore di testo separati da virgola</value>
+ <value xml:lang="it">Valore di testo separati da virgola</value>
<value xml:lang="th">à¹à¸à¹à¹à¸à¸£à¸·à¹à¸à¸à¸«à¸¡à¸²à¸¢à¸à¸¸à¸¥à¸ าà¸à¸à¸±à¹à¸à¸à¸²à¸à¸±à¸§à¸à¸±à¸à¸©à¸£</value>
<value xml:lang="zh">éå·åéææ¬</value>
</property>
Modified: ofbiz/trunk/applications/content/data/CompDocData.xml
URL: http://svn.apache.org/viewvc/ofbiz/trunk/applications/content/data/CompDocData.xml?rev=737003&r1=737002&r2=737003&view=diff
==============================================================================
--- ofbiz/trunk/applications/content/data/CompDocData.xml (original)
+++ ofbiz/trunk/applications/content/data/CompDocData.xml Fri Jan 23 03:08:47 2009
@@ -18,13 +18,13 @@
under the License.
-->
<entity-engine-xml>
- <SecurityGroup groupId="COMPDOCADMIN" description="CompDoc admin group, all permissions."/>
- <SecurityGroupPermission groupId="COMPDOCADMIN" permissionId="CONTENTMGR_VIEW"/>
- <SecurityGroupPermission groupId="COMPDOCADMIN" permissionId="CONTENTMGR_CREATE"/>
- <SecurityGroupPermission groupId="COMPDOCADMIN" permissionId="CONTENTMGR_DELETE"/>
- <SecurityGroupPermission groupId="COMPDOCADMIN" permissionId="CONTENTMGR_UPDATE"/>
- <SecurityGroupPermission groupId="COMPDOCADMIN" permissionId="CONTENTMGR_ADMIN"/>
-
+ <SecurityGroup groupId="COMPDOCADMIN" description="CompDoc admin group, all permissions."/>
+ <SecurityGroupPermission groupId="COMPDOCADMIN" permissionId="CONTENTMGR_VIEW"/>
+ <SecurityGroupPermission groupId="COMPDOCADMIN" permissionId="CONTENTMGR_CREATE"/>
+ <SecurityGroupPermission groupId="COMPDOCADMIN" permissionId="CONTENTMGR_DELETE"/>
+ <SecurityGroupPermission groupId="COMPDOCADMIN" permissionId="CONTENTMGR_UPDATE"/>
+ <SecurityGroupPermission groupId="COMPDOCADMIN" permissionId="CONTENTMGR_ADMIN"/>
+
<RoleType roleTypeId="APPROVER" description="Approver"/>
<RoleType roleTypeId="REVIEWER" description="Reviewer"/>
<Party partyId="approver" partyTypeId="PERSON"/>
@@ -34,8 +34,8 @@
<PartyRole partyId="admin" roleTypeId="APPROVER"/>
<UserLogin userLoginId="approver" partyId="approver"/>
<UserLoginSecurityGroup groupId="COMPDOCADMIN" userLoginId="approver" fromDate="2006-01-01 12:00:00.0"/>
-
-
+
+
<DataResource dataResourceId="DR1103b" dataResourceTypeId="OFBIZ_FILE_BIN" objectInfo="/applications/content/data/pdftest2.pdf" mimeTypeId="application/pdf" dataResourceName="Personal Profile" />
<DataResource dataResourceId="DR1105b" dataResourceTypeId="OFBIZ_FILE_BIN" objectInfo="/applications/content/data/mswordtest2.doc" mimeTypeId="application/msword" dataResourceName="2nd Quarter Review" />
@@ -59,7 +59,7 @@
<DataResource dataResourceId="DR1115" mimeTypeId="application/pdf" dataResourceName="Performance Review" />
<DataResource dataResourceId="DR1116" mimeTypeId="application/pdf" dataResourceName="Other Upload" />
- <!-- A CDT (Composite Document Template) that can be used independently, or as part of CD0001 defined below -->
+ <!-- A CDT (Composite Document Template) that can be used independently, or as part of CD0001 defined below -->
<Content contentId="CDT1201" contentTypeId="COMPDOC_TEMPLATE" contentName="Demo Template Root (CDT) 1201" ownerContentId="" />
@@ -97,7 +97,7 @@
<ContentAssoc contentIdTo="CDT1201" contentId="CDT1115" contentAssocTypeId="COMPDOC_PART" fromDate="2006-01-12 01:01:01" sequenceNum="0150"/>
<ContentAssoc contentIdTo="CDT1201" contentId="CDT1116" contentAssocTypeId="COMPDOC_PART" fromDate="2006-01-12 01:01:01" sequenceNum="0160"/>
- <!-- sample instances CDT CDT1201 -->
+ <!-- sample instances CDT CDT1201 -->
<Content contentId="CDI1201" instanceOfContentId="CDT1201" contentTypeId="COMPDOC_INSTANCE" contentName="Demo Instance Root (CDI) 1201" ownerContentId="" />
<Content contentId="CDI1103" instanceOfContentId="CDT1103" dataResourceId="DR1103b" contentTypeId="DOCUMENT" contentName="Personal Profile" ownerContentId=""/>
<Content contentId="CDI1105" instanceOfContentId="CDT1105" dataResourceId="DR1105b" contentTypeId="DOCUMENT" contentName="2nd Quarter Review" ownerContentId="" />
@@ -106,7 +106,7 @@
<ContentAssoc contentIdTo="CDI1201" contentId="CDI1103" contentAssocTypeId="COMPDOC_PART" fromDate="2006-01-12 01:01:01" sequenceNum="00130"/>
<ContentAssoc contentIdTo="CDI1201" contentId="CDI1105" contentAssocTypeId="COMPDOC_PART" fromDate="2006-01-12 01:01:01" sequenceNum="0050"/>
- <!-- sample revision entries for CDT CDT1201 -->
+ <!-- sample revision entries for CDT CDT1201 -->
<ContentRevision contentId="CDT1201" contentRevisionSeqId="000002"/>
<ContentRevisionItem contentId="CDT1201" contentRevisionSeqId="000002" itemContentId="CDT1101"/>
<ContentRevisionItem contentId="CDT1201" contentRevisionSeqId="000002" itemContentId="CDT1102"/>
@@ -127,7 +127,7 @@
<ContentRevision contentId="CDT1201" contentRevisionSeqId="000004"/>
- <ContentRevision contentId="CDT1201" contentRevisionSeqId="000013"/>
+ <ContentRevision contentId="CDT1201" contentRevisionSeqId="000013"/>
<ContentRevisionItem contentId="CDT1201" contentRevisionSeqId="000013" itemContentId="CDT1103" oldDataResourceId="DR1103a" newDataResourceId="DR1103b"/>
<ContentRevisionItem contentId="CDT1201" contentRevisionSeqId="000013" itemContentId="CDT1105" oldDataResourceId="DR1105a" newDataResourceId="DR1105b"/>
@@ -136,14 +136,14 @@
<ContentRevision contentId="CDI1201" contentRevisionSeqId="000006"/>
<ContentRevisionItem contentId="CDI1201" contentRevisionSeqId="000006" itemContentId="CDI1105" newDataResourceId="DR1105a"/>
- <ContentRevision contentId="CDI1201" contentRevisionSeqId="000009"/>
+ <ContentRevision contentId="CDI1201" contentRevisionSeqId="000009"/>
<ContentRevisionItem contentId="CDI1201" contentRevisionSeqId="000009" itemContentId="CDI1103" oldDataResourceId="DR1103a" newDataResourceId="DR1103b"/>
- <ContentRevision contentId="CDI1201" contentRevisionSeqId="000010"/>
+ <ContentRevision contentId="CDI1201" contentRevisionSeqId="000010"/>
<ContentRevisionItem contentId="CDI1201" contentRevisionSeqId="000010" itemContentId="CDI1105" oldDataResourceId="DR1105a" newDataResourceId="DR1105b"/>
- <ContentRevision contentId="CDI1201" contentRevisionSeqId="000013"/>
+ <ContentRevision contentId="CDI1201" contentRevisionSeqId="000013"/>
<ContentRevisionItem contentId="CDI1201" contentRevisionSeqId="000013" itemContentId="CDI1103" oldDataResourceId="DR1103a" newDataResourceId="DR1103b"/>
- <ContentRevision contentId="CDI1201" contentRevisionSeqId="000014"/>
+ <ContentRevision contentId="CDI1201" contentRevisionSeqId="000014"/>
<ContentRevisionItem contentId="CDI1201" contentRevisionSeqId="000014" itemContentId="CDI1105" oldDataResourceId="DR1105a" newDataResourceId="DR1105b"/>
Modified: ofbiz/trunk/applications/content/data/DemoBlogUsersData.xml
URL: http://svn.apache.org/viewvc/ofbiz/trunk/applications/content/data/DemoBlogUsersData.xml?rev=737003&r1=737002&r2=737003&view=diff
==============================================================================
--- ofbiz/trunk/applications/content/data/DemoBlogUsersData.xml (original)
+++ ofbiz/trunk/applications/content/data/DemoBlogUsersData.xml Fri Jan 23 03:08:47 2009
@@ -53,31 +53,31 @@
<!-- Updating BLOGROOTBIGAL with bigal as creator so that he will be found as "owner" for subrecords.
This is used in a screen permission test.
-->
- <Party partyId="BLOG_USERS" partyTypeId="PARTY_GROUP"/>
- <Party partyId="BLOG_EDITORS" partyTypeId="PARTY_GROUP"/>
- <Party partyId="BLOG_ADMINS" partyTypeId="PARTY_GROUP"/>
- <Party partyId="BLOG_AUTHORS" partyTypeId="PARTY_GROUP"/>
- <Party partyId="BLOG_PUBLISHERS" partyTypeId="PARTY_GROUP"/>
-
- <DataSource dataSourceId="BLOG_SITE" dataSourceTypeId="WEBSITE_ENTRY" description="Blog Site"/>
-
- <PartyRole partyId="BLOG_USERS" roleTypeId="CONTENT_USER"/>
- <PartyRole partyId="BLOG_EDITORS" roleTypeId="CONTENT_EDITOR"/>
- <PartyRole partyId="BLOG_AUTHORS" roleTypeId="CONTENT_AUTHOR"/>
- <PartyRole partyId="BLOG_ADMINS" roleTypeId="CONTENT_ADMIN"/>
- <PartyRole partyId="BLOG_PUBLISHERS" roleTypeId="CONTENT_ADMIN"/>
-
- <UserLogin userLoginId="blog_guest" currentPassword="47ca69ebb4bdc9ae0adec130880165d2cc05db1a" passwordHint=""/>
- <UserLogin userLoginId="blog_admin" currentPassword="47ca69ebb4bdc9ae0adec130880165d2cc05db1a" passwordHint=""/>
- <UserLogin userLoginId="blog_author" currentPassword="47ca69ebb4bdc9ae0adec130880165d2cc05db1a" passwordHint=""/>
- <UserLogin userLoginId="blog_editor" currentPassword="47ca69ebb4bdc9ae0adec130880165d2cc05db1a" passwordHint=""/>
-
+ <Party partyId="BLOG_USERS" partyTypeId="PARTY_GROUP"/>
+ <Party partyId="BLOG_EDITORS" partyTypeId="PARTY_GROUP"/>
+ <Party partyId="BLOG_ADMINS" partyTypeId="PARTY_GROUP"/>
+ <Party partyId="BLOG_AUTHORS" partyTypeId="PARTY_GROUP"/>
+ <Party partyId="BLOG_PUBLISHERS" partyTypeId="PARTY_GROUP"/>
+
+ <DataSource dataSourceId="BLOG_SITE" dataSourceTypeId="WEBSITE_ENTRY" description="Blog Site"/>
+
+ <PartyRole partyId="BLOG_USERS" roleTypeId="CONTENT_USER"/>
+ <PartyRole partyId="BLOG_EDITORS" roleTypeId="CONTENT_EDITOR"/>
+ <PartyRole partyId="BLOG_AUTHORS" roleTypeId="CONTENT_AUTHOR"/>
+ <PartyRole partyId="BLOG_ADMINS" roleTypeId="CONTENT_ADMIN"/>
+ <PartyRole partyId="BLOG_PUBLISHERS" roleTypeId="CONTENT_ADMIN"/>
+
+ <UserLogin userLoginId="blog_guest" currentPassword="47ca69ebb4bdc9ae0adec130880165d2cc05db1a" passwordHint=""/>
+ <UserLogin userLoginId="blog_admin" currentPassword="47ca69ebb4bdc9ae0adec130880165d2cc05db1a" passwordHint=""/>
+ <UserLogin userLoginId="blog_author" currentPassword="47ca69ebb4bdc9ae0adec130880165d2cc05db1a" passwordHint=""/>
+ <UserLogin userLoginId="blog_editor" currentPassword="47ca69ebb4bdc9ae0adec130880165d2cc05db1a" passwordHint=""/>
+
<Content contentId="BLOGROOTBIGAL"
- createdByUserLogin="bigal"
- lastModifiedByUserLogin="bigal"
- createdDate="2004-10-16 17:32:31.285"
- lastModifiedDate="2004-10-16 17:32:31.291" />
-
+ createdByUserLogin="bigal"
+ lastModifiedByUserLogin="bigal"
+ createdDate="2004-10-16 17:32:31.285"
+ lastModifiedDate="2004-10-16 17:32:31.291" />
+
<Party partyId="AUTHOR_MADMAX" partyTypeId="PERSON" createdDate="2004-03-27 09:37:40.989" createdByUserLogin="admin" lastModifiedDate="2004-03-27 09:37:40.989" lastModifiedByUserLogin="admin"/>
<Person partyId="AUTHOR_MADMAX" lastName="Max" firstName="Mad"/>
<UserLogin userLoginId="madmax" partyId="AUTHOR_MADMAX" currentPassword="47ca69ebb4bdc9ae0adec130880165d2cc05db1a"/>
@@ -88,11 +88,11 @@
<!-- Updating biBLOGROOTMADMAXgal with madmax as creator so that he will be found as "owner" for subrecords.
This is used in a screen permission test.
-->
- <Content contentId="BLOGROOTMADMAX"
- createdByUserLogin="madmax"
- lastModifiedByUserLogin="madmax"
- createdDate="2004-10-16 17:32:31.285"
- lastModifiedDate="2004-10-16 17:32:31.291" />
-
-
+ <Content contentId="BLOGROOTMADMAX"
+ createdByUserLogin="madmax"
+ lastModifiedByUserLogin="madmax"
+ createdDate="2004-10-16 17:32:31.285"
+ lastModifiedDate="2004-10-16 17:32:31.291" />
+
+
</entity-engine-xml>
Modified: ofbiz/trunk/applications/content/data/MimeTypeData.xml
URL: http://svn.apache.org/viewvc/ofbiz/trunk/applications/content/data/MimeTypeData.xml?rev=737003&r1=737002&r2=737003&view=diff
==============================================================================
--- ofbiz/trunk/applications/content/data/MimeTypeData.xml (original)
+++ ofbiz/trunk/applications/content/data/MimeTypeData.xml Fri Jan 23 03:08:47 2009
@@ -164,29 +164,29 @@
sgml [RFC1874]
vnd.latex-z [Lubos]
vnd.fmi.flexstor [Hurtta]
- uri-list [RFC2483]
- vnd.abc [Allen]
+ uri-list [RFC2483]
+ vnd.abc [Allen]
rfc822-headers [RFC1892]
- vnd.in3d.3dml [Powers]
- prs.lines.tag [Lines]
+ vnd.in3d.3dml [Powers]
+ prs.lines.tag [Lines]
vnd.in3d.spot [Powers]
css [RFC2318]
xml [RFC3023]
xml-external-parsed-entity [RFC3023]
- rtf [Lindner]
+ rtf [Lindner]
directory [RFC2425]
calendar [RFC2445]
- vnd.wap.wml [Stark]
- vnd.wap.wmlscript [Stark]
- vnd.motorola.reflex [Patton]
- vnd.fly [Gurney]
+ vnd.wap.wml [Stark]
+ vnd.wap.wmlscript [Stark]
+ vnd.motorola.reflex [Patton]
+ vnd.fly [Gurney]
vnd.wap.sl [WAP-Forum]
vnd.wap.si [WAP-Forum]
t140 [RFC2793]
vnd.ms-mediapackage [Nelson]
- vnd.IPTC.NewsML [IPTC]
+ vnd.IPTC.NewsML [IPTC]
vnd.IPTC.NITF [IPTC]
- vnd.curl [Hodge]
+ vnd.curl [Hodge]
vnd.DMClientScript [Bradley]
parityfec [RFC3009]
@@ -198,7 +198,7 @@
appledouble [MacMime,Patrik Faltstrom]
header-set [Dave Crocker]
form-data [RFC2388]
- related [RFC2387]
+ related [RFC2387]
report [RFC1892]
voice-message [RFC2421,RFC2423]
signed [RFC1847]
@@ -279,80 +279,80 @@
vnd.intertrust.digibox [Tomasello]
vnd.intertrust.nncp [Tomasello]
prs.alvestrand.titrax-sheet [Alvestrand]
- vnd.noblenet-web [Solomon]
+ vnd.noblenet-web [Solomon]
vnd.noblenet-sealer [Solomon]
- vnd.noblenet-directory [Solomon]
- prs.nprend [Doggett]
- vnd.webturbo [Rehem]
- hyperstudio [Domino]
- vnd.shana.informed.formtemplate [Selzler]
- vnd.shana.informed.formdata [Selzler]
- vnd.shana.informed.package [Selzler]
- vnd.shana.informed.interchange [Selzler]
- vnd.$commerce_battelle [Applebaum]
- vnd.osa.netdeploy [Klos]
- vnd.ibm.MiniPay [Herzberg]
- vnd.japannet-jpnstore-wakeup [Yoshitake]
+ vnd.noblenet-directory [Solomon]
+ prs.nprend [Doggett]
+ vnd.webturbo [Rehem]
+ hyperstudio [Domino]
+ vnd.shana.informed.formtemplate [Selzler]
+ vnd.shana.informed.formdata [Selzler]
+ vnd.shana.informed.package [Selzler]
+ vnd.shana.informed.interchange [Selzler]
+ vnd.$commerce_battelle [Applebaum]
+ vnd.osa.netdeploy [Klos]
+ vnd.ibm.MiniPay [Herzberg]
+ vnd.japannet-jpnstore-wakeup [Yoshitake]
vnd.japannet-setstore-wakeup [Yoshitake]
- vnd.japannet-verification [Yoshitake]
- vnd.japannet-registration [Yoshitake]
- vnd.hp-HPGL [Pentecost]
- vnd.hp-PCL [Pentecost]
- vnd.hp-PCLXL [Pentecost]
- vnd.musician [Adams]
- vnd.FloGraphIt [Floersch]
+ vnd.japannet-verification [Yoshitake]
+ vnd.japannet-registration [Yoshitake]
+ vnd.hp-HPGL [Pentecost]
+ vnd.hp-PCL [Pentecost]
+ vnd.hp-PCLXL [Pentecost]
+ vnd.musician [Adams]
+ vnd.FloGraphIt [Floersch]
vnd.intercon.formnet [Gurak]
vemmi [RFC2122]
- vnd.ms-asf [Fleischman]
- vnd.ecdis-update [Buettgenbach]
- vnd.powerbuilder6 [Guy]
- vnd.powerbuilder6-s [Guy]
+ vnd.ms-asf [Fleischman]
+ vnd.ecdis-update [Buettgenbach]
+ vnd.powerbuilder6 [Guy]
+ vnd.powerbuilder6-s [Guy]
vnd.lotus-wordpro [Wattenberger]
vnd.lotus-approach [Wattenberger]
vnd.lotus-1-2-3 [Wattenberger]
vnd.lotus-organizer [Wattenberger]
vnd.lotus-screencam [Wattenberger]
- vnd.lotus-freelance [Wattenberger]
- vnd.fujitsu.oasys [Togashi]
- vnd.fujitsu.oasys2 [Togashi]
- vnd.swiftview-ics [Widener]
- vnd.dna [Searcy]
- prs.cww [Rungchavalnont]
+ vnd.lotus-freelance [Wattenberger]
+ vnd.fujitsu.oasys [Togashi]
+ vnd.fujitsu.oasys2 [Togashi]
+ vnd.swiftview-ics [Widener]
+ vnd.dna [Searcy]
+ prs.cww [Rungchavalnont]
vnd.wt.stf [Wohler]
- vnd.dxr [Duffy]
+ vnd.dxr [Duffy]
vnd.mitsubishi.misty-guard.trustweb [Tanaka]
- vnd.ibm.modcap [Hohensee]
+ vnd.ibm.modcap [Hohensee]
vnd.acucobol [Lubin]
vnd.fujitsu.oasys3 [Okudaira]
marc [RFC2220]
vnd.fujitsu.oasysprs [Ogita]
- vnd.fujitsu.oasysgp [Sugimoto]
+ vnd.fujitsu.oasysgp [Sugimoto]
vnd.visio [Sandal]
vnd.netfpx [Mutz]
- vnd.audiograph [Slusanschi]
- vnd.epson.salt [Nagatomo]
- vnd.3M.Post-it-Notes [O'Brien]
+ vnd.audiograph [Slusanschi]
+ vnd.epson.salt [Nagatomo]
+ vnd.3M.Post-it-Notes [O'Brien]
vnd.novadigm.EDX [Swenson]
vnd.novadigm.EXT [Swenson]
- vnd.novadigm.EDM [Swenson]
- vnd.claymore [Simpson]
- vnd.comsocaller [Dellutri]
+ vnd.novadigm.EDM [Swenson]
+ vnd.claymore [Simpson]
+ vnd.comsocaller [Dellutri]
pkcs7-mime [RFC2311]
pkcs7-signature [RFC2311]
pkcs10 [RFC2311]
- vnd.yellowriver-custom-menu [Yellow]
- vnd.ecowin.chart [Olsson]
- vnd.ecowin.series [Olsson]
+ vnd.yellowriver-custom-menu [Yellow]
+ vnd.ecowin.chart [Olsson]
+ vnd.ecowin.series [Olsson]
vnd.ecowin.filerequest [Olsson]
vnd.ecowin.fileupdate [Olsson]
vnd.ecowin.seriesrequest [Olsson]
vnd.ecowin.seriesupdate [Olsson]
- EDIFACT [RFC1767]
- EDI-X12 [RFC1767]
- EDI-Consent [RFC1767]
- vnd.wrq-hp3000-labelled [Bartram]
- vnd.minisoft-hp3000-save [Bartram]
- vnd.ffsns [Holstage]
+ EDIFACT [RFC1767]
+ EDI-X12 [RFC1767]
+ EDI-Consent [RFC1767]
+ vnd.wrq-hp3000-labelled [Bartram]
+ vnd.minisoft-hp3000-save [Bartram]
+ vnd.ffsns [Holstage]
vnd.hp-hps [Aubrey]
vnd.fujixerox.docuworks [Taguchi]
xml [RFC3023]
@@ -360,78 +360,78 @@
xml-dtd [RFC3023]
vnd.anser-web-funds-transfer-initiation [Mori]
vnd.anser-web-certificate-issue-initiation [Mori]
- vnd.is-xpr [Natarajan]
- vnd.intu.qbo [Scratchley]
- vnd.publishare-delta-tree [Ben-Kiki]
- vnd.cybank [Helmee]
+ vnd.is-xpr [Natarajan]
+ vnd.intu.qbo [Scratchley]
+ vnd.publishare-delta-tree [Ben-Kiki]
+ vnd.cybank [Helmee]
batch-SMTP [RFC2442]
- vnd.uplanet.alert [Martin]
- vnd.uplanet.cacheop [Martin]
- vnd.uplanet.list [Martin]
- vnd.uplanet.listcmd [Martin]
- vnd.uplanet.channel [Martin]
- vnd.uplanet.bearer-choice [Martin]
- vnd.uplanet.signal [Martin]
- vnd.uplanet.alert-wbxml [Martin]
- vnd.uplanet.cacheop-wbxml [Martin]
- vnd.uplanet.list-wbxml [Martin]
- vnd.uplanet.listcmd-wbxml [Martin]
- vnd.uplanet.channel-wbxml [Martin]
- vnd.uplanet.bearer-choice-wbxml [Martin]
+ vnd.uplanet.alert [Martin]
+ vnd.uplanet.cacheop [Martin]
+ vnd.uplanet.list [Martin]
+ vnd.uplanet.listcmd [Martin]
+ vnd.uplanet.channel [Martin]
+ vnd.uplanet.bearer-choice [Martin]
+ vnd.uplanet.signal [Martin]
+ vnd.uplanet.alert-wbxml [Martin]
+ vnd.uplanet.cacheop-wbxml [Martin]
+ vnd.uplanet.list-wbxml [Martin]
+ vnd.uplanet.listcmd-wbxml [Martin]
+ vnd.uplanet.channel-wbxml [Martin]
+ vnd.uplanet.bearer-choice-wbxml [Martin]
vnd.epson.quickanime [Gu]
- vnd.commonspace [Chandhok]
- vnd.fut-misnet [Pruulmann]
- vnd.xfdl [Manning]
+ vnd.commonspace [Chandhok]
+ vnd.fut-misnet [Pruulmann]
+ vnd.xfdl [Manning]
vnd.intu.qfx [Scratchley]
- vnd.epson.ssf [Hoshina]
- vnd.epson.msf [Hoshina]
- vnd.powerbuilder7 [Shilts]
- vnd.powerbuilder7-s [Shilts]
- vnd.lotus-notes [Laramie]
+ vnd.epson.ssf [Hoshina]
+ vnd.epson.msf [Hoshina]
+ vnd.powerbuilder7 [Shilts]
+ vnd.powerbuilder7-s [Shilts]
+ vnd.lotus-notes [Laramie]
pkixcmp [RFC2510]
- vnd.wap.wmlc [Stark]
- vnd.wap.wmlscriptc [Stark]
- vnd.motorola.flexsuite [Patton]
- vnd.wap.wbxml [Stark]
- vnd.motorola.flexsuite.wem [Patton]
- vnd.motorola.flexsuite.kmr [Patton]
- vnd.motorola.flexsuite.adsi [Patton]
- vnd.motorola.flexsuite.fis [Patton]
- vnd.motorola.flexsuite.gotap [Patton]
- vnd.motorola.flexsuite.ttc [Patton]
- vnd.ufdl [Manning]
- vnd.accpac.simply.imp [Leow]
- vnd.accpac.simply.aso [Leow]
- vnd.vcx [T.Sugimoto]
+ vnd.wap.wmlc [Stark]
+ vnd.wap.wmlscriptc [Stark]
+ vnd.motorola.flexsuite [Patton]
+ vnd.wap.wbxml [Stark]
+ vnd.motorola.flexsuite.wem [Patton]
+ vnd.motorola.flexsuite.kmr [Patton]
+ vnd.motorola.flexsuite.adsi [Patton]
+ vnd.motorola.flexsuite.fis [Patton]
+ vnd.motorola.flexsuite.gotap [Patton]
+ vnd.motorola.flexsuite.ttc [Patton]
+ vnd.ufdl [Manning]
+ vnd.accpac.simply.imp [Leow]
+ vnd.accpac.simply.aso [Leow]
+ vnd.vcx [T.Sugimoto]
ipp [RFC2910]
ocsp-request [RFC2560]
ocsp-response [RFC2560]
- vnd.previewsystems.box [Smolgovsky]
- vnd.mediastation.cdkey [Flurry]
- vnd.pg.format [Gandert]
- vnd.pg.osasli [Gandert]
- vnd.hp-hpid [Gupta]
+ vnd.previewsystems.box [Smolgovsky]
+ vnd.mediastation.cdkey [Flurry]
+ vnd.pg.format [Gandert]
+ vnd.pg.osasli [Gandert]
+ vnd.hp-hpid [Gupta]
pkix-cert [RFC2585]
pkix-crl [RFC2585]
- vnd.Mobius.TXF [Kabayama]
- vnd.Mobius.PLC [Kabayama]
- vnd.Mobius.DIS [Kabayama]
- vnd.Mobius.DAF [Kabayama]
- vnd.Mobius.MSL [Kabayama]
- vnd.cups-raster [Sweet]
- vnd.cups-postscript [Sweet]
- vnd.cups-raw [Sweet]
+ vnd.Mobius.TXF [Kabayama]
+ vnd.Mobius.PLC [Kabayama]
+ vnd.Mobius.DIS [Kabayama]
+ vnd.Mobius.DAF [Kabayama]
+ vnd.Mobius.MSL [Kabayama]
+ vnd.cups-raster [Sweet]
+ vnd.cups-postscript [Sweet]
+ vnd.cups-raw [Sweet]
index [RFC2652]
index.cmd [RFC2652]
index.response [RFC2652]
index.obj [RFC2652]
index.vnd [RFC2652]
- vnd.triscape.mxs [Simonoff]
- vnd.powerbuilder75 [Shilts]
- vnd.powerbuilder75-s [Shilts]
- vnd.dpgraph [Parker]
- http [RFC2616]
- sdp [RFC2327]
+ vnd.triscape.mxs [Simonoff]
+ vnd.powerbuilder75 [Shilts]
+ vnd.powerbuilder75-s [Shilts]
+ vnd.dpgraph [Parker]
+ http [RFC2616]
+ sdp [RFC2327]
vnd.eudora.data [Resnick]
vnd.fujixerox.docuworks.binder [Matsumoto]
vnd.vectorworks [Pharr]
@@ -454,13 +454,13 @@
vnd.trueapp [Hepler]
vnd.s3sms [Tarkkala]
iotp [RFC2935]
- vnd.mcd [Gotoh]
- vnd.httphone [Lefevre]
+ vnd.mcd [Gotoh]
+ vnd.httphone [Lefevre]
vnd.informix-visionary [Gales]
vnd.msign [Borcherding]
vnd.ms-lrm [Ledoux]
vnd.contact.cmsg [Patz]
- vnd.epson.esf [Hoshina]
+ vnd.epson.esf [Hoshina]
whoispp-query [RFC2957]
whoispp-response [RFC2958]
vnd.mozilla.xul+xml [McDaniel]
@@ -468,16 +468,16 @@
vnd.palm [Peacock]
vnd.fsc.weblaunch [D.Smith]
vnd.tve-trigger [Welsh]
- dvcs [RFC3029]
+ dvcs [RFC3029]
sieve [RFC3028]
vnd.vividence.scriptfile [Risher]
vnd.hhe.lesson-player [Jones]
- beep+xml [RFC3080]
+ beep+xml [RFC3080]
font-tdpfr [RFC3073]
vnd.mseq [Le Bodic]
vnd.aether.imp [Moskowitz]
- vnd.Mobius.MQY [Devasia]
- vnd.Mobius.MBK [Devasia]
+ vnd.Mobius.MQY [Devasia]
+ vnd.Mobius.MBK [Devasia]
vnd.vidsoft.vidconference [Hess]
vnd.ibm.afplinedata [Buis]
vnd.irepository.package+xml [Knowles]
@@ -487,16 +487,16 @@
vnd.pvi.ptid1 [Lamb]
isup [RFCISUP]
qsig [RFCISUP]
- timestamp-query [RFC3161]
- timestamp-reply [RFC3161]
+ timestamp-query [RFC3161]
+ timestamp-reply [RFC3161]
vnd.pwg-xhtml-print+xml [Wright]
- image jpeg [RFC2045,RFC2046]
+ image jpeg [RFC2045,RFC2046]
gif [RFC2045,RFC2046]
ief Image Exchange Format [RFC1314]
g3fax [RFC1494]
tiff Tag Image File Format [RFC2302]
- cgm Computer Graphics Metafile [Francis]
+ cgm Computer Graphics Metafile [Francis]
naplps [Ferber]
vnd.dwg [Moline]
vnd.svf [Moline]
@@ -504,13 +504,13 @@
png [Randers-Pehrson]
vnd.fpx [Spencer]
vnd.net-fpx [Spencer]
- vnd.xiff [SMartin]
- prs.btif [Simon]
- vnd.fastbidsheet [Becker]
- vnd.wap.wbmp [Stark]
- prs.pti [Laun]
- vnd.cns.inf2 [McLaughlin]
- vnd.mix [Reddy]
+ vnd.xiff [SMartin]
+ prs.btif [Simon]
+ vnd.fastbidsheet [Becker]
+ vnd.wap.wbmp [Stark]
+ prs.pti [Laun]
+ vnd.cns.inf2 [McLaughlin]
+ vnd.mix [Reddy]
vnd.fujixerox.edmics-rlc [Onda]
vnd.fujixerox.edmics-mmr [Onda]
vnd.fst [Fuldseth]
@@ -518,29 +518,29 @@
audio basic [RFC2045,RFC2046]
32kadpcm [RFC2421,RFC2422]
vnd.qcelp [Lundblade]
- vnd.digital-winds [Strazds]
- vnd.lucent.voice [Vaudreuil]
+ vnd.digital-winds [Strazds]
+ vnd.lucent.voice [Vaudreuil]
vnd.octel.sbc [Vaudreuil]
vnd.rhetorex.32kadpcm [Vaudreuil]
vnd.vmx.cvsd [Vaudreuil]
- vnd.nortel.vbk [Parsons]
- vnd.cns.anp1 [McLaughlin]
- vnd.cns.inf1 [McLaughlin]
+ vnd.nortel.vbk [Parsons]
+ vnd.cns.anp1 [McLaughlin]
+ vnd.cns.inf1 [McLaughlin]
L16 [RFC2586]
vnd.everad.plj [Cicelsky]
telephone-event [RFC2833]
tone [RFC2833]
- prs.sid [Walleij]
- vnd.nuera.ecelp4800 [Fox]
- vnd.nuera.ecelp7470 [Fox]
- mpeg [RFC3003]
+ prs.sid [Walleij]
+ vnd.nuera.ecelp4800 [Fox]
+ vnd.nuera.ecelp7470 [Fox]
+ mpeg [RFC3003]
parityfec [RFC3009]
MP4A-LATM [RFC3016]
vnd.nuera.ecelp9600 [Fox]
- G.722.1 [RFC3047]
+ G.722.1 [RFC3047]
mpa-robust [RFC3119]
vnd.cisco.nse [Kumar]
- DAT12 [RFCAVTD]
+ DAT12 [RFCAVTD]
L20 [RFCAVTD]
L24 [RFCAVTD]
@@ -552,7 +552,7 @@
vnd.fvt [Fuldseth]
pointer [RFC2862]
parityfec [RFC3009]
- vnd.mpegurl [Recktenwald]
+ vnd.mpegurl [Recktenwald]
MP4V-ES [RFC3016]
vnd.nokia.interleaved-multimedia [Kangaslampi]
@@ -560,9 +560,9 @@
iges [Parks]
vrml [RFC2077]
mesh [RFC2077]
- vnd.dwf [Pratt]
- vnd.gtw [Ozaki]
- vnd.flatland.3dml [Powers]
+ vnd.dwf [Pratt]
+ vnd.gtw [Ozaki]
+ vnd.flatland.3dml [Powers]
vnd.vtu [Rabinovitch]
vnd.mts [Rabinovitch]
vnd.gdl [Babits]
@@ -595,7 +595,7 @@
correspondance between the few character sets listed in the MIME
specifications [RFC2045,RFC2046] and the list in that section are:
- Type Description Reference
+ Type Description Reference
-=-= -=-=-=-=-=- -=-=-=-=-
US-ASCII see ANSI_X3.4-1968 below [RFC2045,RFC2046]
ISO-8859-1 see ISO_8859-1:1987 below [RFC2045,RFC2046]
@@ -611,14 +611,14 @@
Access Types
-=-=-=-=-=-=
- Type Description Reference
- -=-= -=-=-=-=-=- -=-=-=-=-
- FTP [RFC2045,RFC2046]
- ANON-FTP [RFC2045,RFC2046]
- TFTP [RFC2045,RFC2046]
- AFS [RFC2045,RFC2046]
- LOCAL-FILE [RFC2045,RFC2046]
- MAIL-SERVER [RFC2045,RFC2046]
+ Type Description Reference
+ -=-= -=-=-=-=-=- -=-=-=-=-
+ FTP [RFC2045,RFC2046]
+ ANON-FTP [RFC2045,RFC2046]
+ TFTP [RFC2045,RFC2046]
+ AFS [RFC2045,RFC2046]
+ LOCAL-FILE [RFC2045,RFC2046]
+ MAIL-SERVER [RFC2045,RFC2046]
content-id [RFC1873]
@@ -627,11 +627,11 @@
Conversion values or Content Transfer Encodings.
- Type Description Reference
- -=-= -=-=-=-=-=- -=-=-=-=-
+ Type Description Reference
+ -=-= -=-=-=-=-=- -=-=-=-=-
7BIT [RFC2045,RFC2046]
8BIT [RFC2045,RFC2046]
- BASE64 [RFC2045,RFC2046]
+ BASE64 [RFC2045,RFC2046]
BINARY [RFC2045,RFC2046]
QUOTED-PRINTABLE [RFC2045,RFC2046]
@@ -971,7 +971,7 @@
[Fuldseth] Arild Fuldseth, <Ar...@fast.no>, June 2000.
[Gales] Christopher Gales, <ch...@informix.com>,
- August 2000.
+ August 2000.
[Gandert] April Gandert <ga...@pg.com>, April 1999.
@@ -1132,7 +1132,7 @@
[Pharr] Paul C. Pharr <ph...@diehlgraphsoft.com>, February 2000.
[Powers] Michael Powers, <po...@insideout.net>, January 1998.
- <po...@flatland.com>, January 1999.
+ <po...@flatland.com>, January 1999.
[Pratt] Jason Pratt, <ja...@autodesk.com>, August 1997.
@@ -1157,7 +1157,7 @@
[Rosenberg] Jonathan Rosenberg, <jd...@dynamicsoft.com>, October 2000.
[Rungchavalnont] Khemchart Rungchavalnont,
- <kh...@cpu.cp.eng.chula.ac.th>, July 1997.
+ <kh...@cpu.cp.eng.chula.ac.th>, July 1997.
[Sandal] Troy Sandal <tr...@visio.com>, November 1997.
Modified: ofbiz/trunk/applications/content/entitydef/entitymodel.xml
URL: http://svn.apache.org/viewvc/ofbiz/trunk/applications/content/entitydef/entitymodel.xml?rev=737003&r1=737002&r2=737003&view=diff
==============================================================================
--- ofbiz/trunk/applications/content/entitydef/entitymodel.xml (original)
+++ ofbiz/trunk/applications/content/entitydef/entitymodel.xml Fri Jan 23 03:08:47 2009
@@ -1175,7 +1175,7 @@
</entity>
<entity entity-name="SurveyApplType"
package-name="org.ofbiz.content.survey"
- default-resource-name="ContentEntityLabels"
+ default-resource-name="ContentEntityLabels"
title="Survey Application Type Entity">
<field name="surveyApplTypeId" type="id-ne"/>
<field name="description" type="description"/>
Modified: ofbiz/trunk/applications/content/script/org/ofbiz/content/content/ContentServices.xml
URL: http://svn.apache.org/viewvc/ofbiz/trunk/applications/content/script/org/ofbiz/content/content/ContentServices.xml?rev=737003&r1=737002&r2=737003&view=diff
==============================================================================
--- ofbiz/trunk/applications/content/script/org/ofbiz/content/content/ContentServices.xml (original)
+++ ofbiz/trunk/applications/content/script/org/ofbiz/content/content/ContentServices.xml Fri Jan 23 03:08:47 2009
@@ -358,9 +358,9 @@
<make-value entity-name="ContentPurposeType" value-field="newEntity"/>
<set-nonpk-fields map="parameters" value-field="newEntity"/>
<set-pk-fields map="parameters" value-field="newEntity"/>
- <if-empty field="newEntity.contentPurposeTypeId">
- <make-next-seq-id seq-field-name="contentPurposeTypeId" value-field="newEntity"/>
- </if-empty>
+ <if-empty field="newEntity.contentPurposeTypeId">
+ <make-next-seq-id seq-field-name="contentPurposeTypeId" value-field="newEntity"/>
+ </if-empty>
<create-value value-field="newEntity"/>
<field-to-result field="newEntity.contentPurposeTypeId" result-name="contentPurposeTypeId" />
</simple-method>
@@ -764,105 +764,105 @@
</simple-method>
<!-- This method first creates Content, DataResource and ElectronicText, ImageDataResource, etc. entities (if needed)
- by calling persistContentAndAssoc.
-
- It then takes the contentId coming out of that service, the passed in communicationEventId
- and calls the "createCommEventContentAssoc" service to tie the CommunicationEvent and Content entities together.
- -->
+ by calling persistContentAndAssoc.
+
+ It then takes the contentId coming out of that service, the passed in communicationEventId
+ and calls the "createCommEventContentAssoc" service to tie the CommunicationEvent and Content entities together.
+ -->
<simple-method method-name="createCommContentDataResource" short-description="Create CommunicationEvent and Content">
-
- <!--
+
+ <!--
<check-permission permission="CONTENTMGR" action="_DELETE"><fail-message message="Security Error: to run updateContent you must have the CONTENTMGR_DELETE or CONTENTMGR_ADMIN permission"/></check-permission>
<check-errors/>
- -->
-
+ -->
+
<now-timestamp field="nowTimestamp"/>
- <set-service-fields to-map="persistIn" service-name="persistContentAndAssoc" map="parameters"/>
- <!-- let's take a guess at what the dataResourceTypeId should be if it is empty -->
- <if-empty field="persistIn.dataResourceTypeId">
- <log level="info" message="persistIn.drMimeTypeId: ${persistIn.drMimeTypeId}" />
- <if-regexp expr="text.*" field="persistIn.drMimeTypeId">
- <set field="persistIn.dataResourceTypeId" value="ELECTRONIC_TEXT"/>
- <else>
- <set field="persistIn.dataResourceTypeId" value="IMAGE_OBJECT"/>
- </else>
- </if-regexp>
- </if-empty>
- <log level="info" message="persistIn.dataResourceTypeId: ${persistIn.dataResourceTypeId}" />
-
- <call-service service-name="persistContentAndAssoc" in-map-name="persistIn">
- <results-to-map map-name="persistOut"/>
- </call-service>
-
- <iterate-map key="key" value="val" map="persistOut">
- <field-to-result field="val" result-name="${key}"/>
- </iterate-map>
-
- <set field="mapIn.contentId" from-field="persistOut.contentId"/>
- <!-- <set field="mapIn.fromDate" from-field="nowTimestamp"/> -->
- <set field="mapIn.communicationEventId" from-field="parameters.communicationEventId"/>
- <set field="mapIn.sequenceNum" from-field="parameters.sequenceNum"/>
- <call-service service-name="createCommEventContentAssoc" in-map-name="mapIn">
- <result-to-result result-name="fromDate"/>
- </call-service>
-
- </simple-method>
-
- <!-- This method first updates Content, DataResource and ElectronicText, ImageDataResource, etc. entities (if needed)
- by calling persistContentAndAssoc. It then takes the passed in contentId, communicationEventId and fromDate primary keys
- and calls the "updateCommEventContentAssoc" service to tie the CommunicationEvent and Content entities together.
- -->
+ <set-service-fields to-map="persistIn" service-name="persistContentAndAssoc" map="parameters"/>
+ <!-- let's take a guess at what the dataResourceTypeId should be if it is empty -->
+ <if-empty field="persistIn.dataResourceTypeId">
+ <log level="info" message="persistIn.drMimeTypeId: ${persistIn.drMimeTypeId}" />
+ <if-regexp expr="text.*" field="persistIn.drMimeTypeId">
+ <set field="persistIn.dataResourceTypeId" value="ELECTRONIC_TEXT"/>
+ <else>
+ <set field="persistIn.dataResourceTypeId" value="IMAGE_OBJECT"/>
+ </else>
+ </if-regexp>
+ </if-empty>
+ <log level="info" message="persistIn.dataResourceTypeId: ${persistIn.dataResourceTypeId}" />
+
+ <call-service service-name="persistContentAndAssoc" in-map-name="persistIn">
+ <results-to-map map-name="persistOut"/>
+ </call-service>
+
+ <iterate-map key="key" value="val" map="persistOut">
+ <field-to-result field="val" result-name="${key}"/>
+ </iterate-map>
+
+ <set field="mapIn.contentId" from-field="persistOut.contentId"/>
+ <!-- <set field="mapIn.fromDate" from-field="nowTimestamp"/> -->
+ <set field="mapIn.communicationEventId" from-field="parameters.communicationEventId"/>
+ <set field="mapIn.sequenceNum" from-field="parameters.sequenceNum"/>
+ <call-service service-name="createCommEventContentAssoc" in-map-name="mapIn">
+ <result-to-result result-name="fromDate"/>
+ </call-service>
+
+ </simple-method>
+
+ <!-- This method first updates Content, DataResource and ElectronicText, ImageDataResource, etc. entities (if needed)
+ by calling persistContentAndAssoc. It then takes the passed in contentId, communicationEventId and fromDate primary keys
+ and calls the "updateCommEventContentAssoc" service to tie the CommunicationEvent and Content entities together.
+ -->
<simple-method method-name="updateCommContentDataResource" short-description="Update CommunicationEvent and Content">
-
- <!--
+
+ <!--
<check-permission permission="CONTENTMGR" action="_DELETE"><fail-message message="Security Error: to run updateContent you must have the CONTENTMGR_DELETE or CONTENTMGR_ADMIN permission"/></check-permission>
<check-errors/>
- -->
- <set-service-fields to-map="persistIn" service-name="persistContentAndAssoc" map="parameters"/>
- <call-service service-name="persistContentAndAssoc" in-map-name="persistIn">
- <results-to-map map-name="persistOut"/>
- </call-service>
-
- <set field="mapIn.contentId" from-field="persistOut.contentId"/>
- <set field="mapIn.fromDate" from-field="parameters.fromDate"/>
- <set field="mapIn.communicationEventId" from-field="parameters.communicationEventId"/>
- <set field="mapIn.sequenceNum" from-field="parameters.sequenceNum"/>
- <call-service service-name="updateCommEventContentAssoc" in-map-name="mapIn">
- </call-service>
-
- <iterate-map key="key" value="val" map="persistOut">
- <field-to-result field="val" result-name="${key}"/>
- </iterate-map>
+ -->
+ <set-service-fields to-map="persistIn" service-name="persistContentAndAssoc" map="parameters"/>
+ <call-service service-name="persistContentAndAssoc" in-map-name="persistIn">
+ <results-to-map map-name="persistOut"/>
+ </call-service>
- </simple-method>
+ <set field="mapIn.contentId" from-field="persistOut.contentId"/>
+ <set field="mapIn.fromDate" from-field="parameters.fromDate"/>
+ <set field="mapIn.communicationEventId" from-field="parameters.communicationEventId"/>
+ <set field="mapIn.sequenceNum" from-field="parameters.sequenceNum"/>
+ <call-service service-name="updateCommEventContentAssoc" in-map-name="mapIn">
+ </call-service>
+
+ <iterate-map key="key" value="val" map="persistOut">
+ <field-to-result field="val" result-name="${key}"/>
+ </iterate-map>
+
+ </simple-method>
- <!-- This service ties CommunicationEvent and Content entities together along with the standard from/thruDate fields.
- -->
+ <!-- This service ties CommunicationEvent and Content entities together along with the standard from/thruDate fields.
+ -->
<simple-method method-name="createCommEventContentAssoc" short-description="Create CommEventContentAssoc">
- <make-value entity-name="CommEventContentAssoc" value-field="commEventContentAssoc" />
- <set-pk-fields value-field="commEventContentAssoc" map="parameters"/>
- <set-nonpk-fields value-field="commEventContentAssoc" map="parameters"/>
- <if-empty field="commEventContentAssoc.fromDate">
- <now-timestamp field="commEventContentAssoc.fromDate"/>
- </if-empty>
- <create-value value-field="commEventContentAssoc" />
- <field-to-result field="commEventContentAssoc.fromDate" result-name="fromDate"/>
- </simple-method>
+ <make-value entity-name="CommEventContentAssoc" value-field="commEventContentAssoc" />
+ <set-pk-fields value-field="commEventContentAssoc" map="parameters"/>
+ <set-nonpk-fields value-field="commEventContentAssoc" map="parameters"/>
+ <if-empty field="commEventContentAssoc.fromDate">
+ <now-timestamp field="commEventContentAssoc.fromDate"/>
+ </if-empty>
+ <create-value value-field="commEventContentAssoc" />
+ <field-to-result field="commEventContentAssoc.fromDate" result-name="fromDate"/>
+ </simple-method>
- <!-- This service would primarily be used to update the thruDate field.
- -->
+ <!-- This service would primarily be used to update the thruDate field.
+ -->
<simple-method method-name="updateCommEventContentAssoc" short-description="Create CommEventContentAssoc">
- <make-value entity-name="CommEventContentAssoc" value-field="pkCommEventContentAssoc" />
- <set-pk-fields value-field="pkCommEventContentAssoc" map="parameters"/>
- <find-by-primary-key value-field="commEventContentAssoc" map="pkCommEventContentAssoc" entity-name="CommEventContentAssoc"/>
- <if-empty field="commEventContentAssoc">
- <add-error>
- <fail-message message="CommEventContentAssoc entity not found for update, communicationEventId: ${parameters.communicationEventId} and contentId: ${parameters.contentId}"/>
- </add-error>
- </if-empty>
- <set-nonpk-fields value-field="commEventContentAssoc" map="parameters"/>
- <store-value value-field="commEventContentAssoc" />
- </simple-method>
+ <make-value entity-name="CommEventContentAssoc" value-field="pkCommEventContentAssoc" />
+ <set-pk-fields value-field="pkCommEventContentAssoc" map="parameters"/>
+ <find-by-primary-key value-field="commEventContentAssoc" map="pkCommEventContentAssoc" entity-name="CommEventContentAssoc"/>
+ <if-empty field="commEventContentAssoc">
+ <add-error>
+ <fail-message message="CommEventContentAssoc entity not found for update, communicationEventId: ${parameters.communicationEventId} and contentId: ${parameters.contentId}"/>
+ </add-error>
+ </if-empty>
+ <set-nonpk-fields value-field="commEventContentAssoc" map="parameters"/>
+ <store-value value-field="commEventContentAssoc" />
+ </simple-method>
<simple-method method-name="removeCommEventContentAssoc" short-description="Delete CommEventContentAssoc">
<make-value entity-name="CommEventContentAssoc" value-field="pkCommEventContentAssoc" />
@@ -1146,8 +1146,8 @@
<simple-method method-name="getSubContentWithPermCheck" short-description="Get sub content and perform permission check on each record">
- <set field="filterByDate" from-field="parameters.filterByDate" default-value="true" type="Boolean" />
- <set field="useCache" from-field="parameters.useCache" default-value="true" type="Boolean" />
+ <set field="filterByDate" from-field="parameters.filterByDate" default-value="true" type="Boolean" />
+ <set field="useCache" from-field="parameters.useCache" default-value="true" type="Boolean" />
<entity-condition list="viewList" entity-name="ContentAssocViewTo" filter-by-date="${filterByDate}" use-cache="${useCache}">
<condition-list combine="and">
<condition-expr field-name="contentIdStart" from-field="parameters.contentId"/>
@@ -1161,12 +1161,12 @@
<if>
<condition>
<and>
- <not>
- <if-empty field="parameters.mainAction"/>
- </not>
- <not>
- <if-empty field="parameters.userLogin"/>
- </not>
+ <not>
+ <if-empty field="parameters.mainAction"/>
+ </not>
+ <not>
+ <if-empty field="parameters.userLogin"/>
+ </not>
</and>
</condition>
<then>
@@ -1196,25 +1196,25 @@
</call-service>
<iterate entry="view" list="subContentList">
- <entity-condition list="viewList" entity-name="ContentAssocViewTo" filter-by-date="true" use-cache="${useCache}">
- <condition-list combine="and">
- <condition-expr field-name="contentIdStart" from-field="view.caContentIdTo"/>
- <condition-expr field-name="caContentAssocTypeId" from-field="parameters.subContentAssocTypeId" ignore-if-empty="true"/>
- <condition-expr field-name="caMapKey" from-field="parameters.subMapKey" ignore-if-empty="true"/>
- </condition-list>
- </entity-condition>
- <clear-field field="view2"/>
- <first-from-list entry="view2" list="viewList"/>
- <clear-field field="map"/>
- <set field="map.contentIdFrom" from-field="view.contentId"/>
- <set field="map.dataResourceIdFrom" from-field="view.dataResourceId"/>
- <set field="map.contentId" from-field="view2.contentId"/>
- <set field="map.contentName" from-field="view2.contentName"/>
- <set field="map.description" from-field="view2.description"/>
- <entity-one entity-name="ElectronicText" value-field="electronicText">
- <field-map field-name="dataResourceId" from-field="view2.dataResourceId"/>
- </entity-one>
- <set field="map.textData" from-field="electronicText.textData"/>
+ <entity-condition list="viewList" entity-name="ContentAssocViewTo" filter-by-date="true" use-cache="${useCache}">
+ <condition-list combine="and">
+ <condition-expr field-name="contentIdStart" from-field="view.caContentIdTo"/>
+ <condition-expr field-name="caContentAssocTypeId" from-field="parameters.subContentAssocTypeId" ignore-if-empty="true"/>
+ <condition-expr field-name="caMapKey" from-field="parameters.subMapKey" ignore-if-empty="true"/>
+ </condition-list>
+ </entity-condition>
+ <clear-field field="view2"/>
+ <first-from-list entry="view2" list="viewList"/>
+ <clear-field field="map"/>
+ <set field="map.contentIdFrom" from-field="view.contentId"/>
+ <set field="map.dataResourceIdFrom" from-field="view.dataResourceId"/>
+ <set field="map.contentId" from-field="view2.contentId"/>
+ <set field="map.contentName" from-field="view2.contentName"/>
+ <set field="map.description" from-field="view2.description"/>
+ <entity-one entity-name="ElectronicText" value-field="electronicText">
+ <field-map field-name="dataResourceId" from-field="view2.dataResourceId"/>
+ </entity-one>
+ <set field="map.textData" from-field="electronicText.textData"/>
<set field="contentViewList[]" from-field="map"/>
</iterate>
<field-to-result field="subContentList" result-name="subContentList"/>
Modified: ofbiz/trunk/applications/content/script/org/ofbiz/content/permission/ContentPermissionServices.xml
URL: http://svn.apache.org/viewvc/ofbiz/trunk/applications/content/script/org/ofbiz/content/permission/ContentPermissionServices.xml?rev=737003&r1=737002&r2=737003&view=diff
==============================================================================
--- ofbiz/trunk/applications/content/script/org/ofbiz/content/permission/ContentPermissionServices.xml (original)
+++ ofbiz/trunk/applications/content/script/org/ofbiz/content/permission/ContentPermissionServices.xml Fri Jan 23 03:08:47 2009
@@ -131,14 +131,14 @@
<set field="parameters.contentOperationId" value="CONTENT_VIEW"/>
</if-empty>
- <!-- contentId is required for update checking -->
- <if-empty field="contentId">
- <set field="contentId" from-field="parameters.contentId"/>
- </if-empty>
- <if-empty field="contentId">
- <add-error><fail-message message="Content Permission Service VIEW requires a contentId!"/></add-error>
- </if-empty>
- <check-errors/>
+ <!-- contentId is required for update checking -->
+ <if-empty field="contentId">
+ <set field="contentId" from-field="parameters.contentId"/>
+ </if-empty>
+ <if-empty field="contentId">
+ <add-error><fail-message message="Content Permission Service VIEW requires a contentId!"/></add-error>
+ </if-empty>
+ <check-errors/>
<!-- grab the current requested content record -->
<entity-one entity-name="Content" value-field="content">
Modified: ofbiz/trunk/applications/content/servicedef/services_commevent.xml
URL: http://svn.apache.org/viewvc/ofbiz/trunk/applications/content/servicedef/services_commevent.xml?rev=737003&r1=737002&r2=737003&view=diff
==============================================================================
--- ofbiz/trunk/applications/content/servicedef/services_commevent.xml (original)
+++ ofbiz/trunk/applications/content/servicedef/services_commevent.xml Fri Jan 23 03:08:47 2009
@@ -23,22 +23,22 @@
<description>Content Component Services</description>
<vendor>OFBiz</vendor>
- <!--
- This service must do two things:
-
- First, call persistContentAndAssoc service to create the Content, DataResource and ImageDataResource/ElectronicText/??? entities.
- Note that is will not create a ContentAssoc entity, which persistContentAndAssoc can do.
- It should be able to auto populate the service parameters for persistContentAndAssoc from this service's input parameters
- using ModelService.makeValid (or the simple method equivalent).
- persistContentAndAssoc will return contentId.
-
- Second, it must create a CommunicationEventContent record.
- The fromData should be defaulted if not passed in.
+ <!--
+ This service must do two things:
+
+ First, call persistContentAndAssoc service to create the Content, DataResource and ImageDataResource/ElectronicText/??? entities.
+ Note that is will not create a ContentAssoc entity, which persistContentAndAssoc can do.
+ It should be able to auto populate the service parameters for persistContentAndAssoc from this service's input parameters
+ using ModelService.makeValid (or the simple method equivalent).
+ persistContentAndAssoc will return contentId.
+
+ Second, it must create a CommunicationEventContent record.
+ The fromData should be defaulted if not passed in.
-->
<service name="createCommContentDataResource" engine="simple"
location="org/ofbiz/content/content/ContentServices.xml" invoke="createCommContentDataResource" auth="true">
<description>Create CommunicationEvent and Content</description>
- <implements service="persistContentAndAssoc"/>
+ <implements service="persistContentAndAssoc"/>
<attribute name="communicationEventId" type="String" mode="IN" optional="false"/>
<attribute name="fromDate" type="java.sql.Timestamp" mode="OUT" optional="false"/>
</service>
@@ -46,7 +46,7 @@
<service name="updateCommContentDataResource" engine="simple"
location="org/ofbiz/content/content/ContentServices.xml" invoke="updateCommContentDataResource" auth="true">
<description>Update CommunicationEvent and Content</description>
- <implements service="persistContentAndAssoc"/>
+ <implements service="persistContentAndAssoc"/>
<attribute name="communicationEventId" type="String" mode="IN" optional="false"/>
<attribute name="fromDate" type="java.sql.Timestamp" mode="IN" optional="false"/>
</service>
@@ -58,9 +58,9 @@
<attribute name="contentId" type="String" mode="IN" optional="false"/>
<attribute name="fromDate" type="java.sql.Timestamp" mode="INOUT" optional="true"/>
<attribute name="thruDate" type="java.sql.Timestamp" mode="IN" optional="true"/>
- <attribute name="sequenceNum" type="Long" mode="IN" optional="true"/>
- </service>
-
+ <attribute name="sequenceNum" type="Long" mode="IN" optional="true"/>
+ </service>
+
<service name="updateCommEventContentAssoc" engine="simple"
location="org/ofbiz/content/content/ContentServices.xml" invoke="updateCommEventContentAssoc" auth="true">
<description>Update CommEventContentAssoc</description>
@@ -68,9 +68,9 @@
<attribute name="contentId" type="String" mode="IN" optional="false"/>
<attribute name="fromDate" type="java.sql.Timestamp" mode="IN" optional="false"/>
<attribute name="thruDate" type="java.sql.Timestamp" mode="IN" optional="true"/>
- <attribute name="sequenceNum" type="Long" mode="IN" optional="true"/>
- </service>
-
+ <attribute name="sequenceNum" type="Long" mode="IN" optional="true"/>
+ </service>
+
<service name="removeCommEventContentAssoc" engine="simple"
location="org/ofbiz/content/content/ContentServices.xml" invoke="removeCommEventContentAssoc" auth="true">
<description>Remove CommEventContentAssoc</description>
Modified: ofbiz/trunk/applications/content/servicedef/services_email.xml
URL: http://svn.apache.org/viewvc/ofbiz/trunk/applications/content/servicedef/services_email.xml?rev=737003&r1=737002&r2=737003&view=diff
==============================================================================
--- ofbiz/trunk/applications/content/servicedef/services_email.xml (original)
+++ ofbiz/trunk/applications/content/servicedef/services_email.xml Fri Jan 23 03:08:47 2009
@@ -25,8 +25,8 @@
<!-- Email Related Services -->
<service name="sendMailInterface" engine="interface" location="" invoke="">
- <description>Interface service for mail services. contentType defaults to "text/html", sendType defaults to
- "mail.smtp.host". sendVia must be specified if sendType is different. Configured in general.properties</description>
+ <description>Interface service for mail services. contentType defaults to "text/html", sendType defaults to
+ "mail.smtp.host". sendVia must be specified if sendType is different. Configured in general.properties</description>
<attribute name="sendTo" type="String" mode="IN" optional="true"/>
<attribute name="sendCc" type="String" mode="IN" optional="true"/>
<attribute name="sendBcc" type="String" mode="IN" optional="true"/>