You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@hbase.apache.org by "Hadoop QA (JIRA)" <ji...@apache.org> on 2014/08/26 19:09:58 UTC

[jira] [Commented] (HBASE-11828) callers of SeverName.valueOf should use equals and not ==

    [ https://issues.apache.org/jira/browse/HBASE-11828?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14110958#comment-14110958 ] 

Hadoop QA commented on HBASE-11828:
-----------------------------------

{color:red}-1 overall{color}.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12664420/HBASE-11828.patch
  against trunk revision .
  ATTACHMENT ID: 12664420

    {color:green}+1 @author{color}.  The patch does not contain any @author tags.

    {color:green}+0 tests included{color}.  The patch appears to be a documentation patch that doesn't require tests.

    {color:green}+1 javac{color}.  The applied patch does not increase the total number of javac compiler warnings.

    {color:green}+1 javac{color}.  The applied patch does not increase the total number of javac compiler warnings.

    {color:green}+1 javadoc{color}.  The javadoc tool did not generate any warning messages.

    {color:green}+1 findbugs{color}.  The patch does not introduce any new Findbugs (version 2.0.3) warnings.

    {color:green}+1 release audit{color}.  The applied patch does not increase the total number of release audit warnings.

    {color:green}+1 lineLengths{color}.  The patch does not introduce lines longer than 100

  {color:green}+1 site{color}.  The mvn site goal succeeds with this patch.

     {color:red}-1 core tests{color}.  The patch failed these unit tests:
     

Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/10593//testReport/
Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/10593//artifact/patchprocess/newPatchFindbugsWarningshbase-prefix-tree.html
Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/10593//artifact/patchprocess/newPatchFindbugsWarningshbase-examples.html
Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/10593//artifact/patchprocess/newPatchFindbugsWarningshbase-common.html
Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/10593//artifact/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/10593//artifact/patchprocess/newPatchFindbugsWarningshbase-client.html
Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/10593//artifact/patchprocess/newPatchFindbugsWarningshbase-thrift.html
Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/10593//artifact/patchprocess/newPatchFindbugsWarningshbase-protocol.html
Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/10593//artifact/patchprocess/newPatchFindbugsWarningshbase-server.html
Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/10593//artifact/patchprocess/newPatchFindbugsWarningshbase-hadoop2-compat.html
Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/10593//console

This message is automatically generated.

> callers of SeverName.valueOf should use equals and not ==
> ---------------------------------------------------------
>
>                 Key: HBASE-11828
>                 URL: https://issues.apache.org/jira/browse/HBASE-11828
>             Project: HBase
>          Issue Type: Improvement
>          Components: Client
>            Reporter: Sean Busbey
>            Assignee: Sean Busbey
>            Priority: Minor
>              Labels: documentation
>         Attachments: HBASE-11828.patch
>
>
> ServerName.valueOf is missing docs about the safety of using == vs .equals on returned members.
> For clarity, we should specify that users are expected to use .equals even though we may return shared immutable instances. The .equals method short circuits on object equality, so the cost difference in the positive case is 1 function call.
> Current behavior is to return a new instance on each call (0.96, 0.98, branch-1, master). So presumably any current users are either doing this or they have a bug.



--
This message was sent by Atlassian JIRA
(v6.2#6252)