You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@bookkeeper.apache.org by "Ivan Kelly (JIRA)" <ji...@apache.org> on 2012/11/07 15:47:12 UTC

[jira] [Commented] (BOOKKEEPER-409) Integration Test - Perform bookie rereplication cycle by Auditor-RW processes

    [ https://issues.apache.org/jira/browse/BOOKKEEPER-409?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13492388#comment-13492388 ] 

Ivan Kelly commented on BOOKKEEPER-409:
---------------------------------------

Sorry for taking so long to look at this. I have a few comments on the patch.

Theres  no need for numberOfLedgers, numberOfEntries, listOfLedgerHandle, listOfLedgerReplica to be global in the class. whats more, declaring them global makes it harder to follow the flow of the tests.

I agree with Uma about BookKeeperClusterBaseTest handling the starting of underreplication. Perhaps, add two methods, 
void setAutoRecoveryEnabled(boolean) & boolean isAutoRecoveryEnabled()
BookieAutoRecoveryTest should call setAutoRecoveryEnabled(true) 
When starting a bookie, we should start autorecovery if isAutoRecoveryEnabled() returns true. 

Rename createLedgerAndAddEntries -> createLedgersAndAddEntries. It should take two parameters, numLedgers & entriesPerLedger. Calling method should use the returned list rather than using the global list.

You should retrieve the bookie to kill from the metadata of the ledger, to ensure the bookie killed is actually used.

rename watchingLedgerNode -> watchUrLedgerNode

You should use  ZkLedgerUnderreplicationManager#getUrLedgerZnode(long ledgerId); rather than copy-pasting the code

                
> Integration Test - Perform bookie rereplication cycle by Auditor-RW processes
> -----------------------------------------------------------------------------
>
>                 Key: BOOKKEEPER-409
>                 URL: https://issues.apache.org/jira/browse/BOOKKEEPER-409
>             Project: Bookkeeper
>          Issue Type: Sub-task
>          Components: bookkeeper-auto-recovery
>    Affects Versions: 4.2.0
>            Reporter: Rakesh R
>            Assignee: Rakesh R
>              Labels: test
>             Fix For: 4.2.0
>
>         Attachments: BOOKKEEPER-409-1.patch, BOOKKEEPER-409.patch
>
>
> The idea is to perform integration testing of entire re-replication module : Auditor-RW processes

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira