You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@cassandra.apache.org by "Jonathan Ellis (JIRA)" <ji...@apache.org> on 2009/06/01 17:44:07 UTC

[jira] Commented: (CASSANDRA-202) Refactor different getRow calls in Table.java to more specific name and add more logging information

    [ https://issues.apache.org/jira/browse/CASSANDRA-202?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12715130#action_12715130 ] 

Jonathan Ellis commented on CASSANDRA-202:
------------------------------------------

the more i think about it the more i think that changing the method names instead of using overloads of getRow makes it less clear rather than more -- using the same method name emphasizes the similarity of the functionality which is appropriate here.

as for the re-throw, if you put the try/catch/rethrow around

                ColumnFamily columnFamily = fetchColumnFamily(key, cf, filter, file);

in CFS, then you would only have to add it in one place.

> Refactor different getRow calls in Table.java to more specific name and add more logging information
> ----------------------------------------------------------------------------------------------------
>
>                 Key: CASSANDRA-202
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-202
>             Project: Cassandra
>          Issue Type: Improvement
>            Reporter: Jun Rao
>            Assignee: Jun Rao
>         Attachments: issue202.patchv1, issue202.patchv2
>
>
> The Table class has five different getRow methods. We need to change them to more appropriate names. Also, when an IOException occurs, it would be useful to log the parameters of the request. 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.