You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@hc.apache.org by "Michajlo Matijkiw (JIRA)" <ji...@apache.org> on 2010/09/29 18:10:35 UTC

[jira] Updated: (HTTPCLIENT-1001) CacheEntryUpdater does not properly update cache entry resource

     [ https://issues.apache.org/jira/browse/HTTPCLIENT-1001?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Michajlo Matijkiw updated HTTPCLIENT-1001:
------------------------------------------

    Attachment: cache_entry_updater_bug_test.patch

This patch should be applied against TestCacheEntryUpdater and it exposes the mentioned bug.  I have started to work on a fix but was hoping for some feedback on my approach.

I am looking to move the logic of CacheEntryUpdater#updateCacheEntry into BasicHttpCache (this is the only place where it is used).  The rest of CacheEntryUpdater's methods can remain as helper methods.  I think this will simplify the logic and help prevent any code duplication.  I believe it might make respolving HTTPCLIENT-1003 easier as well.

Any thoughts?

Thanks,
Michajlo

> CacheEntryUpdater does not properly update cache entry resource
> ---------------------------------------------------------------
>
>                 Key: HTTPCLIENT-1001
>                 URL: https://issues.apache.org/jira/browse/HTTPCLIENT-1001
>             Project: HttpComponents HttpClient
>          Issue Type: Bug
>          Components: Cache
>            Reporter: Michajlo Matijkiw
>         Attachments: cache_entry_updater_bug_test.patch
>
>
> CacheEntryUpdater#updateCacheEntry() copies the old cache entry's resource, though I believe it should only do so if the response is a 304.  Otherwise it should take the response from the server to update the entry.  This method gets called when validating a cache entry and the server returns a 200 or 304.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@hc.apache.org
For additional commands, e-mail: dev-help@hc.apache.org