You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commons-dev@ws.apache.org by "David Waite (JIRA)" <ji...@apache.org> on 2006/06/22 00:53:29 UTC

[jira] Created: (WSCOMMONS-45) PolicyUtil.matchByQName defect when lists are the same size

PolicyUtil.matchByQName defect when lists are the same size
-----------------------------------------------------------

         Key: WSCOMMONS-45
         URL: http://issues.apache.org/jira/browse/WSCOMMONS-45
     Project: WS-Commons
        Type: Bug

  Components: Policy  
    Reporter: David Waite


The following lines:

		List larger = (primTermsA.size() > primTermsB.size()) ? primTermsA
				: primTermsB;
		List smaller = (primTermsA.size() < primTermsB.size()) ? primTermsA
				: primTermsB;

Will cause larger and smaller to both be set to primTermsB when the lists are of the same size. This can be solved by changing one of the comparisons to either >= or <=, or (perhaps more ideally for readability) making the statements in an if block.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: commons-dev-help@ws.apache.org


[jira] Resolved: (WSCOMMONS-45) PolicyUtil.matchByQName defect when lists are the same size

Posted by "Sanka Samaranayake (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/WSCOMMONS-45?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Sanka Samaranayake resolved WSCOMMONS-45.
-----------------------------------------

    Resolution: Fixed

Fixed in the current code base.

> PolicyUtil.matchByQName defect when lists are the same size
> -----------------------------------------------------------
>
>                 Key: WSCOMMONS-45
>                 URL: https://issues.apache.org/jira/browse/WSCOMMONS-45
>             Project: WS-Commons
>          Issue Type: Bug
>          Components: Policy
>            Reporter: David Waite
>         Assigned To: Sanka Samaranayake
>
> The following lines:
> 		List larger = (primTermsA.size() > primTermsB.size()) ? primTermsA
> 				: primTermsB;
> 		List smaller = (primTermsA.size() < primTermsB.size()) ? primTermsA
> 				: primTermsB;
> Will cause larger and smaller to both be set to primTermsB when the lists are of the same size. This can be solved by changing one of the comparisons to either >= or <=, or (perhaps more ideally for readability) making the statements in an if block.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: commons-dev-help@ws.apache.org


[jira] Updated: (WSCOMMONS-45) PolicyUtil.matchByQName defect when lists are the same size

Posted by "Davanum Srinivas (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/WSCOMMONS-45?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Davanum Srinivas updated WSCOMMONS-45:
--------------------------------------

    Assignee: Sanka Samaranayake

> PolicyUtil.matchByQName defect when lists are the same size
> -----------------------------------------------------------
>
>                 Key: WSCOMMONS-45
>                 URL: https://issues.apache.org/jira/browse/WSCOMMONS-45
>             Project: WS-Commons
>          Issue Type: Bug
>          Components: Policy
>            Reporter: David Waite
>         Assigned To: Sanka Samaranayake
>
> The following lines:
> 		List larger = (primTermsA.size() > primTermsB.size()) ? primTermsA
> 				: primTermsB;
> 		List smaller = (primTermsA.size() < primTermsB.size()) ? primTermsA
> 				: primTermsB;
> Will cause larger and smaller to both be set to primTermsB when the lists are of the same size. This can be solved by changing one of the comparisons to either >= or <=, or (perhaps more ideally for readability) making the statements in an if block.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: commons-dev-help@ws.apache.org