You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "Stephan Ewen (JIRA)" <ji...@apache.org> on 2017/03/10 13:56:04 UTC

[jira] [Resolved] (FLINK-5976) Refactoring duplicate Tokenizer in flink-test

     [ https://issues.apache.org/jira/browse/FLINK-5976?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Stephan Ewen resolved FLINK-5976.
---------------------------------
       Resolution: Fixed
    Fix Version/s:     (was: 1.2.0)
                   1.3.0

Fixed in e5e6da0b38495d4030fd0b790a81ca70f9ce84b2

> Refactoring duplicate Tokenizer in flink-test
> ---------------------------------------------
>
>                 Key: FLINK-5976
>                 URL: https://issues.apache.org/jira/browse/FLINK-5976
>             Project: Flink
>          Issue Type: Improvement
>          Components: Examples
>    Affects Versions: 1.2.0
>            Reporter: liuyuzhong7
>            Priority: Minor
>              Labels: test
>             Fix For: 1.3.0
>
>
> There are some duplicate code like this in flink-test, I think refactor this will be better. 
> ```
> public final class Tokenizer implements FlatMapFunction<String, Tuple2<String, Integer>> {
> 	@Override
> 	public void flatMap(String value, Collector<Tuple2<String, Integer>> out) {
> 		// normalize and split the line
> 		String[] tokens = value.toLowerCase().split("\\W+");
> 		// emit the pairs
> 		for (String token : tokens) {
> 			if (token.length() > 0) {
> 				out.collect(new Tuple2<String, Integer>(token, 1));
> 			}
> 		}
> 	}
> }
> ```



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)