You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@maven.apache.org by "Stephen Connolly (JIRA)" <ji...@codehaus.org> on 2010/01/08 09:23:55 UTC
[jira] Created: (SUREFIRE-592) Refactor plugins to remove duplicate
code
Refactor plugins to remove duplicate code
-----------------------------------------
Key: SUREFIRE-592
URL: http://jira.codehaus.org/browse/SUREFIRE-592
Project: Maven Surefire
Issue Type: Improvement
Affects Versions: 2.5
Reporter: Stephen Connolly
After the addition of maven-failsafe-plugin there is now a fair bit of duplicate code between failsafe and surefire plugins.
This code needs to be refactored into a single base class
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira
[jira] Commented: (SUREFIRE-592) Refactor plugins to remove
duplicate code
Posted by "Samuel Le Berrigaud (JIRA)" <ji...@codehaus.org>.
[ http://jira.codehaus.org/browse/SUREFIRE-592?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=207246#action_207246 ]
Samuel Le Berrigaud commented on SUREFIRE-592:
----------------------------------------------
Shouldn't the plugins simply be merged? That would make it a lot more simple to use.
I am sure there are issues with merging them, but better solving them now. Somethings would have to change I believe (if possible) and maven3 coming soon might give the chance to make those changes. I'm thinking for example we might want a {{src/it/java}} for integration tests etc.
I think they could be merged without those changes though.
What do you think? Worth thinking about?
> Refactor plugins to remove duplicate code
> -----------------------------------------
>
> Key: SUREFIRE-592
> URL: http://jira.codehaus.org/browse/SUREFIRE-592
> Project: Maven Surefire
> Issue Type: Improvement
> Affects Versions: 2.5
> Reporter: Stephen Connolly
> Assignee: Stephen Connolly
> Fix For: 2.6
>
>
> After the addition of maven-failsafe-plugin there is now a fair bit of duplicate code between failsafe and surefire plugins.
> This code needs to be refactored into a single base class
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira
[jira] Commented: (SUREFIRE-592) Refactor plugins to remove
duplicate code
Posted by "Paul Gier (JIRA)" <ji...@codehaus.org>.
[ http://jira.codehaus.org/browse/SUREFIRE-592?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=221263#action_221263 ]
Paul Gier commented on SUREFIRE-592:
------------------------------------
Merging them seems like it makes sense. Maybe the goals from failsafe can just be moved into surefire.
> Refactor plugins to remove duplicate code
> -----------------------------------------
>
> Key: SUREFIRE-592
> URL: http://jira.codehaus.org/browse/SUREFIRE-592
> Project: Maven Surefire
> Issue Type: Improvement
> Affects Versions: 2.5
> Reporter: Stephen Connolly
> Assignee: Stephen Connolly
> Fix For: 2.6
>
>
> After the addition of maven-failsafe-plugin there is now a fair bit of duplicate code between failsafe and surefire plugins.
> This code needs to be refactored into a single base class
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira
[jira] Commented: (SUREFIRE-592) Refactor plugins to remove
duplicate code
Posted by "Stephen Connolly (JIRA)" <ji...@codehaus.org>.
[ http://jira.codehaus.org/browse/SUREFIRE-592?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=221531#action_221531 ]
Stephen Connolly commented on SUREFIRE-592:
-------------------------------------------
There has been a bit of discussion and the consensus view at the time is to keep the plugins separate but find a way for having the common code shared.
I have made some progress on making the common code shared, I still have a little bit more refactoring to tidy things up some more before I am ready to mark this issue resolved
> Refactor plugins to remove duplicate code
> -----------------------------------------
>
> Key: SUREFIRE-592
> URL: http://jira.codehaus.org/browse/SUREFIRE-592
> Project: Maven Surefire
> Issue Type: Improvement
> Affects Versions: 2.5
> Reporter: Stephen Connolly
> Assignee: Stephen Connolly
> Fix For: 2.6
>
>
> After the addition of maven-failsafe-plugin there is now a fair bit of duplicate code between failsafe and surefire plugins.
> This code needs to be refactored into a single base class
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira
[jira] Work started: (SUREFIRE-592) Refactor plugins to remove
duplicate code
Posted by "Stephen Connolly (JIRA)" <ji...@codehaus.org>.
[ http://jira.codehaus.org/browse/SUREFIRE-592?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Work on SUREFIRE-592 started by Stephen Connolly.
> Refactor plugins to remove duplicate code
> -----------------------------------------
>
> Key: SUREFIRE-592
> URL: http://jira.codehaus.org/browse/SUREFIRE-592
> Project: Maven Surefire
> Issue Type: Improvement
> Affects Versions: 2.5
> Reporter: Stephen Connolly
> Assignee: Stephen Connolly
> Fix For: 2.6
>
>
> After the addition of maven-failsafe-plugin there is now a fair bit of duplicate code between failsafe and surefire plugins.
> This code needs to be refactored into a single base class
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira
[jira] Updated: (SUREFIRE-592) Refactor plugins to remove duplicate
code
Posted by "Stephen Connolly (JIRA)" <ji...@codehaus.org>.
[ http://jira.codehaus.org/browse/SUREFIRE-592?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Stephen Connolly updated SUREFIRE-592:
--------------------------------------
Fix Version/s: 2.6
> Refactor plugins to remove duplicate code
> -----------------------------------------
>
> Key: SUREFIRE-592
> URL: http://jira.codehaus.org/browse/SUREFIRE-592
> Project: Maven Surefire
> Issue Type: Improvement
> Affects Versions: 2.5
> Reporter: Stephen Connolly
> Assignee: Stephen Connolly
> Fix For: 2.6
>
>
> After the addition of maven-failsafe-plugin there is now a fair bit of duplicate code between failsafe and surefire plugins.
> This code needs to be refactored into a single base class
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira
[jira] Closed: (SUREFIRE-592) Refactor plugins to remove duplicate
code
Posted by "Stephen Connolly (JIRA)" <ji...@codehaus.org>.
[ http://jira.codehaus.org/browse/SUREFIRE-592?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Stephen Connolly closed SUREFIRE-592.
-------------------------------------
Resolution: Fixed
r945183 looks to be all the refactoring I wanted to do. If more is needed/desired we can open another enhancement request
> Refactor plugins to remove duplicate code
> -----------------------------------------
>
> Key: SUREFIRE-592
> URL: http://jira.codehaus.org/browse/SUREFIRE-592
> Project: Maven Surefire
> Issue Type: Improvement
> Affects Versions: 2.5
> Reporter: Stephen Connolly
> Assignee: Stephen Connolly
> Fix For: 2.6
>
>
> After the addition of maven-failsafe-plugin there is now a fair bit of duplicate code between failsafe and surefire plugins.
> This code needs to be refactored into a single base class
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira