You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-dev@hadoop.apache.org by "dhruba borthakur (JIRA)" <ji...@apache.org> on 2008/04/04 22:41:24 UTC
[jira] Created: (HADOOP-3176) Change lease record when a
open-for-write-file gets renamed
Change lease record when a open-for-write-file gets renamed
-----------------------------------------------------------
Key: HADOOP-3176
URL: https://issues.apache.org/jira/browse/HADOOP-3176
Project: Hadoop Core
Issue Type: Bug
Components: dfs
Reporter: dhruba borthakur
When a file/directory is removed, the namenode should repair the leases so that the existing leases point to the appropriate file. The lease record has the pathname of the file that it refers to.
This is required because the namenode has to invoke lease-recovery on the correct file if the client that was writing to a file dies.
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Updated: (HADOOP-3176) Change lease record when a
open-for-write-file gets renamed
Posted by "dhruba borthakur (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HADOOP-3176?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
dhruba borthakur updated HADOOP-3176:
-------------------------------------
Status: Patch Available (was: Open)
> Change lease record when a open-for-write-file gets renamed
> -----------------------------------------------------------
>
> Key: HADOOP-3176
> URL: https://issues.apache.org/jira/browse/HADOOP-3176
> Project: Hadoop Core
> Issue Type: Bug
> Components: dfs
> Reporter: dhruba borthakur
> Assignee: dhruba borthakur
> Attachments: danglingLease.patch, danglingLease2.patch
>
>
> When a file/directory is removed, the namenode should repair the leases so that the existing leases point to the appropriate file. The lease record has the pathname of the file that it refers to.
> This is required because the namenode has to invoke lease-recovery on the correct file if the client that was writing to a file dies.
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Updated: (HADOOP-3176) Change lease record when a
open-for-write-file gets renamed
Posted by "Tsz Wo (Nicholas), SZE (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HADOOP-3176?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Tsz Wo (Nicholas), SZE updated HADOOP-3176:
-------------------------------------------
Hadoop Flags: [Reviewed]
+1 Patch looks good
> Change lease record when a open-for-write-file gets renamed
> -----------------------------------------------------------
>
> Key: HADOOP-3176
> URL: https://issues.apache.org/jira/browse/HADOOP-3176
> Project: Hadoop Core
> Issue Type: Bug
> Components: dfs
> Reporter: dhruba borthakur
> Assignee: dhruba borthakur
> Attachments: danglingLease.patch, danglingLease2.patch
>
>
> When a file/directory is removed, the namenode should repair the leases so that the existing leases point to the appropriate file. The lease record has the pathname of the file that it refers to.
> This is required because the namenode has to invoke lease-recovery on the correct file if the client that was writing to a file dies.
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Updated: (HADOOP-3176) Change lease record when a
open-for-write-file gets renamed
Posted by "dhruba borthakur (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HADOOP-3176?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
dhruba borthakur updated HADOOP-3176:
-------------------------------------
Resolution: Fixed
Fix Version/s: 0.18.0
Status: Resolved (was: Patch Available)
I just committed this.
> Change lease record when a open-for-write-file gets renamed
> -----------------------------------------------------------
>
> Key: HADOOP-3176
> URL: https://issues.apache.org/jira/browse/HADOOP-3176
> Project: Hadoop Core
> Issue Type: Bug
> Components: dfs
> Reporter: dhruba borthakur
> Assignee: dhruba borthakur
> Fix For: 0.18.0
>
> Attachments: danglingLease.patch, danglingLease2.patch
>
>
> When a file/directory is removed, the namenode should repair the leases so that the existing leases point to the appropriate file. The lease record has the pathname of the file that it refers to.
> This is required because the namenode has to invoke lease-recovery on the correct file if the client that was writing to a file dies.
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Commented: (HADOOP-3176) Change lease record when a
open-for-write-file gets renamed
Posted by "Hudson (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HADOOP-3176?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12589532#action_12589532 ]
Hudson commented on HADOOP-3176:
--------------------------------
Integrated in Hadoop-trunk #462 (See [http://hudson.zones.apache.org/hudson/job/Hadoop-trunk/462/])
> Change lease record when a open-for-write-file gets renamed
> -----------------------------------------------------------
>
> Key: HADOOP-3176
> URL: https://issues.apache.org/jira/browse/HADOOP-3176
> Project: Hadoop Core
> Issue Type: Bug
> Components: dfs
> Reporter: dhruba borthakur
> Assignee: dhruba borthakur
> Fix For: 0.18.0
>
> Attachments: danglingLease.patch, danglingLease2.patch
>
>
> When a file/directory is removed, the namenode should repair the leases so that the existing leases point to the appropriate file. The lease record has the pathname of the file that it refers to.
> This is required because the namenode has to invoke lease-recovery on the correct file if the client that was writing to a file dies.
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Commented: (HADOOP-3176) Change lease record when a
open-for-write-file gets renamed
Posted by "Hadoop QA (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HADOOP-3176?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12588372#action_12588372 ]
Hadoop QA commented on HADOOP-3176:
-----------------------------------
-1 overall. Here are the results of testing the latest attachment
http://issues.apache.org/jira/secure/attachment/12379994/danglingLease.patch
against trunk revision 645773.
@author +1. The patch does not contain any @author tags.
tests included +1. The patch appears to include 3 new or modified tests.
javadoc +1. The javadoc tool did not generate any warning messages.
javac +1. The applied patch does not generate any new javac compiler warnings.
release audit +1. The applied patch does not generate any new release audit warnings.
findbugs -1. The patch appears to introduce 2 new Findbugs warnings.
core tests +1. The patch passed core unit tests.
contrib tests +1. The patch passed contrib unit tests.
Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/2222/testReport/
Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/2222/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/2222/artifact/trunk/build/test/checkstyle-errors.html
Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/2222/console
This message is automatically generated.
> Change lease record when a open-for-write-file gets renamed
> -----------------------------------------------------------
>
> Key: HADOOP-3176
> URL: https://issues.apache.org/jira/browse/HADOOP-3176
> Project: Hadoop Core
> Issue Type: Bug
> Components: dfs
> Reporter: dhruba borthakur
> Assignee: dhruba borthakur
> Attachments: danglingLease.patch
>
>
> When a file/directory is removed, the namenode should repair the leases so that the existing leases point to the appropriate file. The lease record has the pathname of the file that it refers to.
> This is required because the namenode has to invoke lease-recovery on the correct file if the client that was writing to a file dies.
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Assigned: (HADOOP-3176) Change lease record when a
open-for-write-file gets renamed
Posted by "dhruba borthakur (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HADOOP-3176?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
dhruba borthakur reassigned HADOOP-3176:
----------------------------------------
Assignee: dhruba borthakur
> Change lease record when a open-for-write-file gets renamed
> -----------------------------------------------------------
>
> Key: HADOOP-3176
> URL: https://issues.apache.org/jira/browse/HADOOP-3176
> Project: Hadoop Core
> Issue Type: Bug
> Components: dfs
> Reporter: dhruba borthakur
> Assignee: dhruba borthakur
>
> When a file/directory is removed, the namenode should repair the leases so that the existing leases point to the appropriate file. The lease record has the pathname of the file that it refers to.
> This is required because the namenode has to invoke lease-recovery on the correct file if the client that was writing to a file dies.
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Updated: (HADOOP-3176) Change lease record when a
open-for-write-file gets renamed
Posted by "dhruba borthakur (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HADOOP-3176?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
dhruba borthakur updated HADOOP-3176:
-------------------------------------
Attachment: danglingLease2.patch
1. Fixed findbugs warnings.
2. Enhanced test case by renaming a directory that has two open files in its subdirectory.
3. Removed LeaseComparator
4. All debug logs are encapsulated inside IsDebugEnabled()
> Change lease record when a open-for-write-file gets renamed
> -----------------------------------------------------------
>
> Key: HADOOP-3176
> URL: https://issues.apache.org/jira/browse/HADOOP-3176
> Project: Hadoop Core
> Issue Type: Bug
> Components: dfs
> Reporter: dhruba borthakur
> Assignee: dhruba borthakur
> Attachments: danglingLease.patch, danglingLease2.patch
>
>
> When a file/directory is removed, the namenode should repair the leases so that the existing leases point to the appropriate file. The lease record has the pathname of the file that it refers to.
> This is required because the namenode has to invoke lease-recovery on the correct file if the client that was writing to a file dies.
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Updated: (HADOOP-3176) Change lease record when a
open-for-write-file gets renamed
Posted by "dhruba borthakur (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HADOOP-3176?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
dhruba borthakur updated HADOOP-3176:
-------------------------------------
Status: Open (was: Patch Available)
> Change lease record when a open-for-write-file gets renamed
> -----------------------------------------------------------
>
> Key: HADOOP-3176
> URL: https://issues.apache.org/jira/browse/HADOOP-3176
> Project: Hadoop Core
> Issue Type: Bug
> Components: dfs
> Reporter: dhruba borthakur
> Assignee: dhruba borthakur
> Attachments: danglingLease.patch
>
>
> When a file/directory is removed, the namenode should repair the leases so that the existing leases point to the appropriate file. The lease record has the pathname of the file that it refers to.
> This is required because the namenode has to invoke lease-recovery on the correct file if the client that was writing to a file dies.
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Updated: (HADOOP-3176) Change lease record when a
open-for-write-file gets renamed
Posted by "dhruba borthakur (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HADOOP-3176?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
dhruba borthakur updated HADOOP-3176:
-------------------------------------
Status: Patch Available (was: Open)
> Change lease record when a open-for-write-file gets renamed
> -----------------------------------------------------------
>
> Key: HADOOP-3176
> URL: https://issues.apache.org/jira/browse/HADOOP-3176
> Project: Hadoop Core
> Issue Type: Bug
> Components: dfs
> Reporter: dhruba borthakur
> Assignee: dhruba borthakur
> Attachments: danglingLease.patch
>
>
> When a file/directory is removed, the namenode should repair the leases so that the existing leases point to the appropriate file. The lease record has the pathname of the file that it refers to.
> This is required because the namenode has to invoke lease-recovery on the correct file if the client that was writing to a file dies.
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Updated: (HADOOP-3176) Change lease record when a
open-for-write-file gets renamed
Posted by "dhruba borthakur (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HADOOP-3176?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
dhruba borthakur updated HADOOP-3176:
-------------------------------------
Attachment: danglingLease.patch
When a file is renamed, change the name of affected lease records.
> Change lease record when a open-for-write-file gets renamed
> -----------------------------------------------------------
>
> Key: HADOOP-3176
> URL: https://issues.apache.org/jira/browse/HADOOP-3176
> Project: Hadoop Core
> Issue Type: Bug
> Components: dfs
> Reporter: dhruba borthakur
> Assignee: dhruba borthakur
> Attachments: danglingLease.patch
>
>
> When a file/directory is removed, the namenode should repair the leases so that the existing leases point to the appropriate file. The lease record has the pathname of the file that it refers to.
> This is required because the namenode has to invoke lease-recovery on the correct file if the client that was writing to a file dies.
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Commented: (HADOOP-3176) Change lease record when a
open-for-write-file gets renamed
Posted by "Hadoop QA (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HADOOP-3176?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12589386#action_12589386 ]
Hadoop QA commented on HADOOP-3176:
-----------------------------------
+1 overall. Here are the results of testing the latest attachment
http://issues.apache.org/jira/secure/attachment/12380206/danglingLease2.patch
against trunk revision 645773.
@author +1. The patch does not contain any @author tags.
tests included +1. The patch appears to include 3 new or modified tests.
javadoc +1. The javadoc tool did not generate any warning messages.
javac +1. The applied patch does not generate any new javac compiler warnings.
release audit +1. The applied patch does not generate any new release audit warnings.
findbugs +1. The patch does not introduce any new Findbugs warnings.
core tests +1. The patch passed core unit tests.
contrib tests +1. The patch passed contrib unit tests.
Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/2244/testReport/
Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/2244/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/2244/artifact/trunk/build/test/checkstyle-errors.html
Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/2244/console
This message is automatically generated.
> Change lease record when a open-for-write-file gets renamed
> -----------------------------------------------------------
>
> Key: HADOOP-3176
> URL: https://issues.apache.org/jira/browse/HADOOP-3176
> Project: Hadoop Core
> Issue Type: Bug
> Components: dfs
> Reporter: dhruba borthakur
> Assignee: dhruba borthakur
> Attachments: danglingLease.patch, danglingLease2.patch
>
>
> When a file/directory is removed, the namenode should repair the leases so that the existing leases point to the appropriate file. The lease record has the pathname of the file that it refers to.
> This is required because the namenode has to invoke lease-recovery on the correct file if the client that was writing to a file dies.
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.