You are viewing a plain text version of this content. The canonical link for it is here.
Posted to scm-dev@maven.apache.org by "Dennis Lundberg (JIRA)" <ji...@codehaus.org> on 2006/01/22 13:29:06 UTC

[jira] Created: (SCM-139) Create a utility class for scm url checking/parsing

Create a utility class for scm url checking/parsing
---------------------------------------------------

         Key: SCM-139
         URL: http://jira.codehaus.org/browse/SCM-139
     Project: Maven SCM
        Type: New Feature

  Components: maven-scm-api  
    Reporter: Dennis Lundberg


There is a lot of code in different places, both in maven-scm and elsewhere, that checks and parses scm url:s. I propose that a utility class ScmUrlUtils be crated in maven-scm-api where such code (static methods) can be placed. The code there should not be scm provider specific. This should be accompanied by a test suite.

This concept might also be applied to individual scm providers, e.g. there could be a CvsScmUrlUtils in maven-scm-provider-cvs.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


[jira] Updated: (SCM-139) Create a utility class for scm url checking/parsing

Posted by "Dennis Lundberg (JIRA)" <ji...@codehaus.org>.
     [ http://jira.codehaus.org/browse/SCM-139?page=all ]

Dennis Lundberg updated SCM-139:
--------------------------------

    Attachment: ScmUrlUtils.java

> Create a utility class for scm url checking/parsing
> ---------------------------------------------------
>
>          Key: SCM-139
>          URL: http://jira.codehaus.org/browse/SCM-139
>      Project: Maven SCM
>         Type: New Feature

>   Components: maven-scm-api
>     Reporter: Dennis Lundberg
>  Attachments: ScmUrlUtils.java
>
>
> There is a lot of code in different places, both in maven-scm and elsewhere, that checks and parses scm url:s. I propose that a utility class ScmUrlUtils be crated in maven-scm-api where such code (static methods) can be placed. The code there should not be scm provider specific. This should be accompanied by a test suite.
> This concept might also be applied to individual scm providers, e.g. there could be a CvsScmUrlUtils in maven-scm-provider-cvs.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


[jira] Commented: (SCM-139) Create a utility class for scm url checking/parsing

Posted by "Dennis Lundberg (JIRA)" <ji...@codehaus.org>.
    [ http://jira.codehaus.org/browse/SCM-139?page=comments#action_59465 ] 

Dennis Lundberg commented on SCM-139:
-------------------------------------

I'll pull something together then.

I assume that this will be put in after 1.0 has been released, so I will create the patch against 1.0 final. Will that be OK?

> Create a utility class for scm url checking/parsing
> ---------------------------------------------------
>
>          Key: SCM-139
>          URL: http://jira.codehaus.org/browse/SCM-139
>      Project: Maven SCM
>         Type: New Feature

>   Components: maven-scm-api
>     Reporter: Dennis Lundberg
>  Attachments: SCM-139-2.zip, SCM-139.zip, ScmUrlUtils.java
>
>
> There is a lot of code in different places, both in maven-scm and elsewhere, that checks and parses scm url:s. I propose that a utility class ScmUrlUtils be crated in maven-scm-api where such code (static methods) can be placed. The code there should not be scm provider specific. This should be accompanied by a test suite.
> This concept might also be applied to individual scm providers, e.g. there could be a CvsScmUrlUtils in maven-scm-provider-cvs.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


[jira] Commented: (SCM-139) Create a utility class for scm url checking/parsing

Posted by "Dennis Lundberg (JIRA)" <ji...@codehaus.org>.
    [ http://jira.codehaus.org/browse/SCM-139?page=comments#action_59343 ] 

Dennis Lundberg commented on SCM-139:
-------------------------------------

Do you mean duplicated code in the new files that I created or in the files that are already a part of maven-scm?

> Create a utility class for scm url checking/parsing
> ---------------------------------------------------
>
>          Key: SCM-139
>          URL: http://jira.codehaus.org/browse/SCM-139
>      Project: Maven SCM
>         Type: New Feature

>   Components: maven-scm-api
>     Reporter: Dennis Lundberg
>  Attachments: SCM-139-2.zip, SCM-139.zip, ScmUrlUtils.java
>
>
> There is a lot of code in different places, both in maven-scm and elsewhere, that checks and parses scm url:s. I propose that a utility class ScmUrlUtils be crated in maven-scm-api where such code (static methods) can be placed. The code there should not be scm provider specific. This should be accompanied by a test suite.
> This concept might also be applied to individual scm providers, e.g. there could be a CvsScmUrlUtils in maven-scm-provider-cvs.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


[jira] Commented: (SCM-139) Create a utility class for scm url checking/parsing

Posted by "Emmanuel Venisse (JIRA)" <ji...@codehaus.org>.
    [ http://jira.codehaus.org/browse/SCM-139?page=comments#action_59384 ] 

Emmanuel Venisse commented on SCM-139:
--------------------------------------

i thought to a patch that remove "lot of code in different place" and use your class instead.

> Create a utility class for scm url checking/parsing
> ---------------------------------------------------
>
>          Key: SCM-139
>          URL: http://jira.codehaus.org/browse/SCM-139
>      Project: Maven SCM
>         Type: New Feature

>   Components: maven-scm-api
>     Reporter: Dennis Lundberg
>  Attachments: SCM-139-2.zip, SCM-139.zip, ScmUrlUtils.java
>
>
> There is a lot of code in different places, both in maven-scm and elsewhere, that checks and parses scm url:s. I propose that a utility class ScmUrlUtils be crated in maven-scm-api where such code (static methods) can be placed. The code there should not be scm provider specific. This should be accompanied by a test suite.
> This concept might also be applied to individual scm providers, e.g. there could be a CvsScmUrlUtils in maven-scm-provider-cvs.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


[jira] Commented: (SCM-139) Create a utility class for scm url checking/parsing

Posted by "Emmanuel Venisse (JIRA)" <ji...@codehaus.org>.
    [ http://jira.codehaus.org/browse/SCM-139?page=comments#action_59466 ] 

Emmanuel Venisse commented on SCM-139:
--------------------------------------

yes

> Create a utility class for scm url checking/parsing
> ---------------------------------------------------
>
>          Key: SCM-139
>          URL: http://jira.codehaus.org/browse/SCM-139
>      Project: Maven SCM
>         Type: New Feature

>   Components: maven-scm-api
>     Reporter: Dennis Lundberg
>  Attachments: SCM-139-2.zip, SCM-139.zip, ScmUrlUtils.java
>
>
> There is a lot of code in different places, both in maven-scm and elsewhere, that checks and parses scm url:s. I propose that a utility class ScmUrlUtils be crated in maven-scm-api where such code (static methods) can be placed. The code there should not be scm provider specific. This should be accompanied by a test suite.
> This concept might also be applied to individual scm providers, e.g. there could be a CvsScmUrlUtils in maven-scm-provider-cvs.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


[jira] Commented: (SCM-139) Create a utility class for scm url checking/parsing

Posted by "Emmanuel Venisse (JIRA)" <ji...@codehaus.org>.
    [ http://jira.codehaus.org/browse/SCM-139?page=comments#action_56596 ] 

Emmanuel Venisse commented on SCM-139:
--------------------------------------

- isValid(): I'd prefer an other name like isValidGeneralFormat
- remove "void validate( scmUrl )
- getSeparator() : I prefer a String as returned value


> Create a utility class for scm url checking/parsing
> ---------------------------------------------------
>
>          Key: SCM-139
>          URL: http://jira.codehaus.org/browse/SCM-139
>      Project: Maven SCM
>         Type: New Feature

>   Components: maven-scm-api
>     Reporter: Dennis Lundberg
>  Attachments: ScmUrlUtils.java
>
>
> There is a lot of code in different places, both in maven-scm and elsewhere, that checks and parses scm url:s. I propose that a utility class ScmUrlUtils be crated in maven-scm-api where such code (static methods) can be placed. The code there should not be scm provider specific. This should be accompanied by a test suite.
> This concept might also be applied to individual scm providers, e.g. there could be a CvsScmUrlUtils in maven-scm-provider-cvs.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


[jira] Commented: (SCM-139) Create a utility class for scm url checking/parsing

Posted by "Emmanuel Venisse (JIRA)" <ji...@codehaus.org>.
    [ http://jira.codehaus.org/browse/SCM-139?page=comments#action_59259 ] 

Emmanuel Venisse commented on SCM-139:
--------------------------------------

It will be good if you can provide a patch that remove all duplicated code

> Create a utility class for scm url checking/parsing
> ---------------------------------------------------
>
>          Key: SCM-139
>          URL: http://jira.codehaus.org/browse/SCM-139
>      Project: Maven SCM
>         Type: New Feature

>   Components: maven-scm-api
>     Reporter: Dennis Lundberg
>  Attachments: SCM-139-2.zip, SCM-139.zip, ScmUrlUtils.java
>
>
> There is a lot of code in different places, both in maven-scm and elsewhere, that checks and parses scm url:s. I propose that a utility class ScmUrlUtils be crated in maven-scm-api where such code (static methods) can be placed. The code there should not be scm provider specific. This should be accompanied by a test suite.
> This concept might also be applied to individual scm providers, e.g. there could be a CvsScmUrlUtils in maven-scm-provider-cvs.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


[jira] Updated: (SCM-139) Create a utility class for scm url checking/parsing

Posted by "Dennis Lundberg (JIRA)" <ji...@codehaus.org>.
     [ http://jira.codehaus.org/browse/SCM-139?page=all ]

Dennis Lundberg updated SCM-139:
--------------------------------

    Attachment: SCM-139.zip

> Create a utility class for scm url checking/parsing
> ---------------------------------------------------
>
>          Key: SCM-139
>          URL: http://jira.codehaus.org/browse/SCM-139
>      Project: Maven SCM
>         Type: New Feature

>   Components: maven-scm-api
>     Reporter: Dennis Lundberg
>  Attachments: SCM-139.zip, ScmUrlUtils.java
>
>
> There is a lot of code in different places, both in maven-scm and elsewhere, that checks and parses scm url:s. I propose that a utility class ScmUrlUtils be crated in maven-scm-api where such code (static methods) can be placed. The code there should not be scm provider specific. This should be accompanied by a test suite.
> This concept might also be applied to individual scm providers, e.g. there could be a CvsScmUrlUtils in maven-scm-provider-cvs.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


[jira] Updated: (SCM-139) Create a utility class for scm url checking/parsing

Posted by "Dennis Lundberg (JIRA)" <ji...@codehaus.org>.
     [ http://jira.codehaus.org/browse/SCM-139?page=all ]

Dennis Lundberg updated SCM-139:
--------------------------------

    Attachment: SCM-139-2.zip

> Create a utility class for scm url checking/parsing
> ---------------------------------------------------
>
>          Key: SCM-139
>          URL: http://jira.codehaus.org/browse/SCM-139
>      Project: Maven SCM
>         Type: New Feature

>   Components: maven-scm-api
>     Reporter: Dennis Lundberg
>  Attachments: SCM-139-2.zip, SCM-139.zip, ScmUrlUtils.java
>
>
> There is a lot of code in different places, both in maven-scm and elsewhere, that checks and parses scm url:s. I propose that a utility class ScmUrlUtils be crated in maven-scm-api where such code (static methods) can be placed. The code there should not be scm provider specific. This should be accompanied by a test suite.
> This concept might also be applied to individual scm providers, e.g. there could be a CvsScmUrlUtils in maven-scm-provider-cvs.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira