You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@cxf.apache.org by Glen Mazza <gl...@verizon.net> on 2007/10/11 03:59:53 UTC

Re: svn commit: r583653 - in /incubator/cxf/trunk: rt/frontend/jaxws/src/main/java/org/apache/cxf/jaxws/ rt/frontend/jaxws/src/main/java/org/apache/cxf/jaxws/support/ rt/frontend/jaxws/src/test/java/org/apache/cxf/jaxws/support/ systests/ systests/src/test...

Am Donnerstag, den 11.10.2007, 00:33 +0000 schrieb mmao@apache.org:
> Author: mmao
> Date: Wed Oct 10 17:33:43 2007
> New Revision: 583653
> 
> Added: incubator/cxf/trunk/systests/src/test/resources/wsdl/mtom.wsdl
> URL: http://svn.apache.org/viewvc/incubator/cxf/trunk/systests/src/test/resources/wsdl/mtom.wsdl?rev=583653&view=auto
> ==============================================================================
> --- incubator/cxf/trunk/systests/src/test/resources/wsdl/mtom.wsdl (added)
> +++ incubator/cxf/trunk/systests/src/test/resources/wsdl/mtom.wsdl Wed Oct 10 17:33:43 2007
> @@ -0,0 +1,88 @@
> +<?xml version="1.0" encoding="UTF-8"?>
> +<wsdl:definitions xmlns:types="http://apache.org/cxf/systest/mtom_feature/types" 
> +		  xmlns:xsd="http://www.w3.org/2001/XMLSchema" 
> +		  xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/" 
> +		  xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/" 
> +		  xmlns:tns="http://apache.org/cxf/systest/mtom_feature" 
> +		  name="jaxws mtom feature"
> +		  targetNamespace="http://apache.org/cxf/systest/mtom_feature">
> +
> +    <wsdl:types>
> +	<schema xmlns="http://www.w3.org/2001/XMLSchema" 
> +		xmlns:xmime="http://www.w3.org/2005/05/xmlmime" 
> +		targetNamespace="http://apache.org/cxf/systest/mtom_feature/types"
> +		elementFormDefault="qualified">
> +	    <complexType name="DetailType">
> +		<sequence>
> +		    <element name="photo" type="base64Binary"></element>
> +		    <element name="image" type="base64Binary" xmime:expectedContentTypes="image/jpeg"></element>
> +		</sequence>
> +	    </complexType>
> +	    <element name="Detail" type="types:DetailType"></element>
> +	    <element name="DetailResponse" type="types:DetailType"></element>
> +	    <element name="data" type="base64Binary"></element>
> +	</schema>
> +    </wsdl:types>
> +
> +    <wsdl:message name="echoDataIn">
> +	<wsdl:part name="data" element="types:data"></wsdl:part>
> +    </wsdl:message>
> +
> +    <wsdl:message name="echoDataOut">
> +	<wsdl:part name="data" element="types:data"></wsdl:part>
> +    </wsdl:message>
> +
> +    <wsdl:message name="HelloIn">
> +	<wsdl:part name="data" element="types:Detail"></wsdl:part>
> +    </wsdl:message>
> +
> +    <wsdl:message name="HelloOut">
> +	<wsdl:part name="data" element="types:DetailResponse"></wsdl:part>
> +    </wsdl:message>
> +
> +    <wsdl:portType name="Hello">
> +	<wsdl:operation name="echoData">
> +	    <wsdl:input message="tns:echoDataIn"></wsdl:input>
> +	    <wsdl:output message="tns:echoDataOut"></wsdl:output>
> +	</wsdl:operation>
> +
> +	<!-- mtom test -->
> +	<wsdl:operation name="Detail">
> +	    <wsdl:input message="tns:HelloIn"></wsdl:input>
> +	    <wsdl:output message="tns:HelloOut"></wsdl:output>
> +	</wsdl:operation>
> +

I think tns:DetailIn and tns:DetailOut would be more readable, no?

Regards,
Glen


> +    </wsdl:portType>
> +
> +    <wsdl:binding name="HelloBinding" type="tns:Hello">
> +	<soap:binding style="document" transport="http://schemas.xmlsoap.org/soap/http"></soap:binding>
> +
> +	<wsdl:operation name="echoData">
> +	    <soap:operation soapAction=""></soap:operation>
> +	    <wsdl:input>
> +		<soap:body use="literal"></soap:body>
> +	    </wsdl:input>
> +	    <wsdl:output>
> +		<soap:body use="literal"></soap:body>
> +	    </wsdl:output>
> +	</wsdl:operation>
> +
> +	<wsdl:operation name="Detail">
> +	    <soap:operation soapAction=""></soap:operation>
> +	    <wsdl:input>
> +		<soap:body use="literal"></soap:body>
> +	    </wsdl:input>
> +	    <wsdl:output>
> +		<soap:body use="literal"></soap:body>
> +	    </wsdl:output>
> +	</wsdl:operation>
> +
> +    </wsdl:binding>
> +
> +    <wsdl:service name="HelloService">
> +	<wsdl:port name="HelloPort" binding="tns:HelloBinding">
> +	    <soap:address location="http://localhost:9090/jaxws-mtom/hello"></soap:address>
> +	</wsdl:port>
> +    </wsdl:service>
> +
> +</wsdl:definitions>
> \ No newline at end of file
> 
> 


Re: svn commit: r583653 - in /incubator/cxf/trunk: rt/frontend/jaxws/src/main/java/org/apache/cxf/jaxws/ rt/frontend/jaxws/src/main/java/org/apache/cxf/jaxws/support/ rt/frontend/jaxws/src/test/java/org/apache/cxf/jaxws/support/ systests/ systests/src/test...

Posted by James Mao <ja...@iona.com>.
Glen Mazza wrote:
> Am Donnerstag, den 11.10.2007, 00:33 +0000 schrieb mmao@apache.org:
>   
>> Author: mmao
>> Date: Wed Oct 10 17:33:43 2007
>> New Revision: 583653
>>
>> Added: incubator/cxf/trunk/systests/src/test/resources/wsdl/mtom.wsdl
>> URL: http://svn.apache.org/viewvc/incubator/cxf/trunk/systests/src/test/resources/wsdl/mtom.wsdl?rev=583653&view=auto
>> ==============================================================================
>> --- incubator/cxf/trunk/systests/src/test/resources/wsdl/mtom.wsdl (added)
>> +++ incubator/cxf/trunk/systests/src/test/resources/wsdl/mtom.wsdl Wed Oct 10 17:33:43 2007
>> @@ -0,0 +1,88 @@
>> +<?xml version="1.0" encoding="UTF-8"?>
>> +<wsdl:definitions xmlns:types="http://apache.org/cxf/systest/mtom_feature/types" 
>> +		  xmlns:xsd="http://www.w3.org/2001/XMLSchema" 
>> +		  xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/" 
>> +		  xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/" 
>> +		  xmlns:tns="http://apache.org/cxf/systest/mtom_feature" 
>> +		  name="jaxws mtom feature"
>> +		  targetNamespace="http://apache.org/cxf/systest/mtom_feature">
>> +
>> +    <wsdl:types>
>> +	<schema xmlns="http://www.w3.org/2001/XMLSchema" 
>> +		xmlns:xmime="http://www.w3.org/2005/05/xmlmime" 
>> +		targetNamespace="http://apache.org/cxf/systest/mtom_feature/types"
>> +		elementFormDefault="qualified">
>> +	    <complexType name="DetailType">
>> +		<sequence>
>> +		    <element name="photo" type="base64Binary"></element>
>> +		    <element name="image" type="base64Binary" xmime:expectedContentTypes="image/jpeg"></element>
>> +		</sequence>
>> +	    </complexType>
>> +	    <element name="Detail" type="types:DetailType"></element>
>> +	    <element name="DetailResponse" type="types:DetailType"></element>
>> +	    <element name="data" type="base64Binary"></element>
>> +	</schema>
>> +    </wsdl:types>
>> +
>> +    <wsdl:message name="echoDataIn">
>> +	<wsdl:part name="data" element="types:data"></wsdl:part>
>> +    </wsdl:message>
>> +
>> +    <wsdl:message name="echoDataOut">
>> +	<wsdl:part name="data" element="types:data"></wsdl:part>
>> +    </wsdl:message>
>> +
>> +    <wsdl:message name="HelloIn">
>> +	<wsdl:part name="data" element="types:Detail"></wsdl:part>
>> +    </wsdl:message>
>> +
>> +    <wsdl:message name="HelloOut">
>> +	<wsdl:part name="data" element="types:DetailResponse"></wsdl:part>
>> +    </wsdl:message>
>> +
>> +    <wsdl:portType name="Hello">
>> +	<wsdl:operation name="echoData">
>> +	    <wsdl:input message="tns:echoDataIn"></wsdl:input>
>> +	    <wsdl:output message="tns:echoDataOut"></wsdl:output>
>> +	</wsdl:operation>
>> +
>> +	<!-- mtom test -->
>> +	<wsdl:operation name="Detail">
>> +	    <wsdl:input message="tns:HelloIn"></wsdl:input>
>> +	    <wsdl:output message="tns:HelloOut"></wsdl:output>
>> +	</wsdl:operation>
>> +
>>     
>
> I think tns:DetailIn and tns:DetailOut would be more readable, no?
>
> Regards,
> Glen
>
>   

Right ;) Will change that in the next commit

Thanks,
James