You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@ozone.apache.org by "Attila Doroszlai (Jira)" <ji...@apache.org> on 2024/01/02 18:06:00 UTC
[jira] [Updated] (HDDS-10050) Clean up TestStorageContainerManagerHelper
[ https://issues.apache.org/jira/browse/HDDS-10050?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Attila Doroszlai updated HDDS-10050:
------------------------------------
Parent: HDDS-9931
Issue Type: Sub-task (was: Improvement)
> Clean up TestStorageContainerManagerHelper
> ------------------------------------------
>
> Key: HDDS-10050
> URL: https://issues.apache.org/jira/browse/HDDS-10050
> Project: Apache Ozone
> Issue Type: Sub-task
> Components: test
> Reporter: Attila Doroszlai
> Assignee: Attila Doroszlai
> Priority: Major
>
> * {{TestStorageContainerManagerHelper}} is a helper class, not a test, so it does not match naming conventions.
> * It has an unused method.
> * Most methods are only used by {{TestStorageContainerManager}}, could be moved there.
> * {{createKeys}} does not need to be an instance method and it could be moved (maybe even replaced with existing test data creation utility)
--
This message was sent by Atlassian Jira
(v8.20.10#820010)
---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@ozone.apache.org
For additional commands, e-mail: issues-help@ozone.apache.org