You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@ignite.apache.org by "Kirill Tkalenko (Jira)" <ji...@apache.org> on 2022/02/03 08:33:00 UTC

[jira] [Updated] (IGNITE-16350) [Native Persistence 3.0] Post-porting renames and improvements

     [ https://issues.apache.org/jira/browse/IGNITE-16350?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Kirill Tkalenko updated IGNITE-16350:
-------------------------------------
    Description: 
This task should be used for TODO links in code. All suggestions must be stated in the list below or in TODO in code, or both:
 * {{IgniteUtils#hexInt}} and {{IgniteUtils#hexLong}} should be moved to other class like {{IgniteStringUtils}} and possible renamed.
 * Improve javadoc on the {{PageMemory}} class.
 * Describe {{page}} and {{pageAddr}} naming convention in {{{}PageSupport{}}}.
 * Rename and properly document {{PageMemory#systemPageSize}} and {{{}PageMemory#realPageSize{}}}.
* Get rid of *DataStructure#rnd*, use for example {{private final IntUnaryOperator rng;}}.

  was:
This task should be used for TODO links in code. All suggestions must be stated in the list below or in TODO in code, or both:
 * {{IgniteUtils#hexInt}} and {{IgniteUtils#hexLong}} should be moved to other class like {{IgniteStringUtils}} and possible renamed.
 * Improve javadoc on the {{PageMemory}} class.
 * Describe {{page}} and {{pageAddr}} naming convention in {{{}PageSupport{}}}.
 * Rename and properly document {{PageMemory#systemPageSize}} and {{{}PageMemory#realPageSize{}}}.


> [Native Persistence 3.0] Post-porting renames and improvements
> --------------------------------------------------------------
>
>                 Key: IGNITE-16350
>                 URL: https://issues.apache.org/jira/browse/IGNITE-16350
>             Project: Ignite
>          Issue Type: Improvement
>            Reporter: Ivan Bessonov
>            Priority: Major
>              Labels: ignite-3
>
> This task should be used for TODO links in code. All suggestions must be stated in the list below or in TODO in code, or both:
>  * {{IgniteUtils#hexInt}} and {{IgniteUtils#hexLong}} should be moved to other class like {{IgniteStringUtils}} and possible renamed.
>  * Improve javadoc on the {{PageMemory}} class.
>  * Describe {{page}} and {{pageAddr}} naming convention in {{{}PageSupport{}}}.
>  * Rename and properly document {{PageMemory#systemPageSize}} and {{{}PageMemory#realPageSize{}}}.
> * Get rid of *DataStructure#rnd*, use for example {{private final IntUnaryOperator rng;}}.



--
This message was sent by Atlassian Jira
(v8.20.1#820001)