You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@servicecomb.apache.org by "Jun Gan (Jira)" <ji...@apache.org> on 2020/05/14 18:10:00 UTC
[jira] [Created] (SCB-1900) [Refactor service-registry Module]
Refactor swagger package
Jun Gan created SCB-1900:
----------------------------
Summary: [Refactor service-registry Module] Refactor swagger package
Key: SCB-1900
URL: https://issues.apache.org/jira/browse/SCB-1900
Project: Apache ServiceComb
Issue Type: Improvement
Reporter: Jun Gan
There is ONLY one class (SwaggerLoader.java) which is essentially a Util class. There is no need to create a package.
Also, this "Util" class is used/referenced by java-chassis-core module,
Suggestion:
split this class to decuple the dependency (core rely on this class to loadSwagger).
--
This message was sent by Atlassian Jira
(v8.3.4#803005)