You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@ozone.apache.org by "Siyao Meng (Jira)" <ji...@apache.org> on 2025/05/01 04:55:00 UTC
[jira] [Created] (HDDS-12941) Revisit method and variable names related to reserved / committed (allocated) space
Siyao Meng created HDDS-12941:
---------------------------------
Summary: Revisit method and variable names related to reserved / committed (allocated) space
Key: HDDS-12941
URL: https://issues.apache.org/jira/browse/HDDS-12941
Project: Apache Ozone
Issue Type: Sub-task
Reporter: Siyao Meng
Change the names of those method names to conform to the [javadoc|https://github.com/apache/ozone/blob/2a1a6bf124007821eb68779663bbaad371ea668f/hadoop-hdds/container-service/src/main/java/org/apache/hadoop/ozone/container/common/volume/VolumeUsage.java#L43-L56].
e.g.:
1. [{{committedSpace}}|https://github.com/apache/ozone/blob/0f5b59089b865a5d7a9fd305573e3a818c3836b9/hadoop-hdds/container-service/src/main/java/org/apache/hadoop/ozone/container/common/impl/ContainerData.java#L81] can be {{allocatedSpace}} , as suggested by [~erose]
2. [{{getUsableSpace()}}|https://github.com/apache/ozone/blob/6d0a8306aba01483edfeab04e8b527985fa471b0/hadoop-hdds/container-service/src/main/java/org/apache/hadoop/ozone/container/common/impl/StorageLocationReport.java#L58] should be {{getAvailableSpace()}} if following the convention defined in javadoc.
--
This message was sent by Atlassian Jira
(v8.20.10#820010)
---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@ozone.apache.org
For additional commands, e-mail: issues-help@ozone.apache.org