You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "TisonKun (Jira)" <ji...@apache.org> on 2019/09/11 08:08:00 UTC

[jira] [Created] (FLINK-14050) Refactor YarnClusterDescriptor inheritance

TisonKun created FLINK-14050:
--------------------------------

             Summary: Refactor YarnClusterDescriptor inheritance
                 Key: FLINK-14050
                 URL: https://issues.apache.org/jira/browse/FLINK-14050
             Project: Flink
          Issue Type: Sub-task
          Components: Client / Job Submission, Command Line Client
    Affects Versions: 1.10.0
            Reporter: TisonKun
             Fix For: 1.10.0


Currently, the inheritance looks like

{{AbstractYarnClusterDescriptor}}
    -> {{YarnClusterDescriptor}}
    -> {{TestingYarnClusterDescriptor}}
    -> {{NonDeployingYarnClusterDescriptor}}
    ->    -> {{NonDeployingDetachedYarnClusterDescriptor}}

With an investigation, I find

1. {{AbstractYarnClusterDescriptor}} is introduced for migration purpose and no need any more.
2. {{TestingYarnClusterDescriptor}} is redundant and can be replaced directly with {{YarnClusterDescriptor}}.
3. Some methods like {{#createYarnClusterClient}} have parameters that never used, which are for historical reasons.

Thus, I propose we refactor {{YarnClusterDescriptor}} inheritance 
{{YarnClusterDescriptor}}
    -> {{NonDeployingYarnClusterDescriptor}}
    ->    -> {{NonDeployingDetachedYarnClusterDescriptor}}

and also methods remove unused parameters.

CC [~kkl0u] [~aljoscha] [~till.rohrmann]



--
This message was sent by Atlassian Jira
(v8.3.2#803003)