You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@tuscany.apache.org by Jean-Sebastien Delfino <js...@apache.org> on 2007/04/08 23:37:04 UTC

Tuscany extension mechanism, was: svn commit: r526532

rfeng@apache.org wrote:
> Author: rfeng
> Date: Sat Apr  7 23:10:04 2007
> New Revision: 526532
>
> URL: http://svn.apache.org/viewvc?view=rev&rev=526532
> Log:
> Move ExtensionActivator and ExtensionPointRegistry to core-spi
>
>   

This looks pretty good. I just have a few minor comments.

I think it would make sense to rename ExtensionActivator to something 
else, since it is used to represent a Module more than an Extension, and 
can contribute many Extensions. I would suggest to name this 
RuntimeModule, with the following methods:

The start() method is called when the module starts. This is where you 
can add the Extensions that you contribute to the relevant Extension points.

The stop() method is called when the module stops.

A new Object[] getExtensionPoints() method. The getExtensionPoint() 
method will be called before the start() method and should return the 
Extension points defined by the module. I think we'll need this to 
determine the set of available Extension points and populate your 
ExtensionPointRegistry before passing it to the RuntimeModule.start() 
methods.

Thoughts?

-- 
Jean-Sebastien


---------------------------------------------------------------------
To unsubscribe, e-mail: tuscany-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: tuscany-dev-help@ws.apache.org


Re: Tuscany extension mechanism, was: svn commit: r526532

Posted by Raymond Feng <en...@gmail.com>.
Hi,

Please see my comments inline.

Thanks,
Raymond

----- Original Message ----- 
From: "Jean-Sebastien Delfino" <js...@apache.org>
To: <tu...@ws.apache.org>
Sent: Sunday, April 08, 2007 2:37 PM
Subject: Tuscany extension mechanism, was: svn commit: r526532


> rfeng@apache.org wrote:
>> Author: rfeng
>> Date: Sat Apr  7 23:10:04 2007
>> New Revision: 526532
>>
>> URL: http://svn.apache.org/viewvc?view=rev&rev=526532
>> Log:
>> Move ExtensionActivator and ExtensionPointRegistry to core-spi
>>
>>
>
> This looks pretty good. I just have a few minor comments.
>
> I think it would make sense to rename ExtensionActivator to something 
> else, since it is used to represent a Module more than an Extension, and 
> can contribute many Extensions. I would suggest to name this 
> RuntimeModule, with the following methods:

I was about to propose a similar change such as ModuleActivator or 
ModuleBinder.

>
> The start() method is called when the module starts. This is where you can 
> add the Extensions that you contribute to the relevant Extension points.
>
> The stop() method is called when the module stops.
>
> A new Object[] getExtensionPoints() method. The getExtensionPoint() method 
> will be called before the start() method and should return the Extension 
> points defined by the module. I think we'll need this to determine the set 
> of available Extension points and populate your ExtensionPointRegistry 
> before passing it to the RuntimeModule.start() methods.

I agree.

>
> Thoughts?
>
> -- 
> Jean-Sebastien
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tuscany-dev-unsubscribe@ws.apache.org
> For additional commands, e-mail: tuscany-dev-help@ws.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: tuscany-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: tuscany-dev-help@ws.apache.org