You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@hc.apache.org by ol...@apache.org on 2025/05/25 11:02:33 UTC
(httpcomponents-website) branch master updated: Updated project website for HttpClient 5.5 release; project status update
This is an automated email from the ASF dual-hosted git repository.
olegk pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/httpcomponents-website.git
The following commit(s) were added to refs/heads/master by this push:
new 786f1f4 Updated project website for HttpClient 5.5 release; project status update
786f1f4 is described below
commit 786f1f4d0c001dbe5b3c9b1f58da701062b5df7b
Author: Oleg Kalnichevski <ol...@apache.org>
AuthorDate: Sun May 25 12:27:57 2025 +0200
Updated project website for HttpClient 5.5 release; project status update
---
.../httpcomponents-client-5.4.x/download.md | 39 -----
.../httpcomponents-client-5.4.x/examples-async.md | 85 ----------
.../examples-reactive.md | 25 ---
.../httpcomponents-client-5.4.x/examples.md | 114 -------------
.../markdown/httpcomponents-client-5.4.x/index.md | 90 -----------
.../httpcomponents-client-5.4.x/quickstart.md | 178 ---------------------
.../android.md | 0
.../httpcomponents-client-5.5.x/download.md | 2 +-
.../logging.md | 0
.../migration-guide/index.md | 0
.../migration-guide/migration-to-async-http2.md | 0
.../migration-guide/migration-to-async-simple.md | 0
.../migration-to-async-streaming.md | 0
.../migration-guide/migration-to-classic.md | 0
.../migration-guide/preparation.md | 0
.../related-projects.md | 0
src/site/markdown/news.md | 41 +++--
src/site/markdown/status.md | 22 ++-
src/site/resources/.htaccess | 13 +-
.../documentation.links | 3 +-
src/site/site.xml | 32 ++--
src/site/xdoc/downloads.xml | 60 ++-----
22 files changed, 69 insertions(+), 635 deletions(-)
diff --git a/src/site/markdown/httpcomponents-client-5.4.x/download.md b/src/site/markdown/httpcomponents-client-5.4.x/download.md
deleted file mode 100644
index c98d157..0000000
--- a/src/site/markdown/httpcomponents-client-5.4.x/download.md
+++ /dev/null
@@ -1,39 +0,0 @@
-<!--
- Licensed to the Apache Software Foundation (ASF) under one
- or more contributor license agreements. See the NOTICE file
- distributed with this work for additional information
- regarding copyright ownership. The ASF licenses this file
- to you under the Apache License, Version 2.0 (the
- "License"); you may not use this file except in compliance
- with the License. You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
- Unless required by applicable law or agreed to in writing,
- software distributed under the License is distributed on an
- "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
- KIND, either express or implied. See the License for the
- specific language governing permissions and limitations
- under the License.
--->
-
-HttpClient Downloads
-====================
-
-The latest release available for download:
-
-[Release packages](https://hc.apache.org/downloads.cgi) -
-[Release Notes](https://www.apache.org/dist/httpcomponents/httpclient/RELEASE_NOTES-5.4.x.txt) -
-[License](https://www.apache.org/licenses/LICENSE-2.0.html)
-
-Dependency management
----------------------
-
-If you are using a dependency manager for your project such as [Apache Maven](https://maven.apache.org),
-[Gradle](https://gradle.org/) or [Apache Ivy](https://ant.apache.org/projects/ivy.html), you can create a dependency on
-HttpClient modules by using this information:
-
-- [HttpClient](https://search.maven.org/artifact/org.apache.httpcomponents.client5/httpclient5)
-- [HttpClient Fluent](https://search.maven.org/artifact/org.apache.httpcomponents.client5/httpclient5-fluent)
-- [HttpClient Cache](https://search.maven.org/artifact/org.apache.httpcomponents.client5/httpclient5-cache)
-- [HttpClient Windows extensions](https://search.maven.org/artifact/org.apache.httpcomponents.client5/httpclient5-win)
diff --git a/src/site/markdown/httpcomponents-client-5.4.x/examples-async.md b/src/site/markdown/httpcomponents-client-5.4.x/examples-async.md
deleted file mode 100644
index a09caab..0000000
--- a/src/site/markdown/httpcomponents-client-5.4.x/examples-async.md
+++ /dev/null
@@ -1,85 +0,0 @@
-<!--
- Licensed to the Apache Software Foundation (ASF) under one
- or more contributor license agreements. See the NOTICE file
- distributed with this work for additional information
- regarding copyright ownership. The ASF licenses this file
- to you under the Apache License, Version 2.0 (the
- "License"); you may not use this file except in compliance
- with the License. You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
- Unless required by applicable law or agreed to in writing,
- software distributed under the License is distributed on an
- "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
- KIND, either express or implied. See the License for the
- specific language governing permissions and limitations
- under the License.
--->
-
-HttpClient Examples (Async)
-===========================
-
-- [Asynchronous HTTP exchange](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/AsyncClientHttpExchange.java)
-
- This example demonstrates a basic asynchronous HTTP request / response exchange. Response content is buffered in
- memory for simplicity.
-
-- [Asynchronous HTTP exchange with content streaming](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/AsyncClientHttpExchangeStreaming.java)
-
- This example demonstrates an asynchronous HTTP request / response exchange with a full content streaming.
-
-- [Pipelined HTTP/1.1 exchanges](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/AsyncClientHttp1Pipelining.java)
-
- This example demonstrates a pipelined execution of multiple HTTP/1.1 request / response exchanges. Response content is
- buffered in memory for simplicity.
-
-- [Multiplexed HTTP/2 exchanges](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/AsyncClientH2Multiplexing.java)
-
- This example demonstrates a multiplexed execution of multiple HTTP/2 request / response exchanges. Response content is
- buffered in memory for simplicity.
-
-- [Request execution interceptors](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/AsyncClientInterceptors.java)
-
- This example demonstrates how to insert custom request interceptor and an execution interceptor to the request
- execution chain.
-
-- [Message trailers](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/AsyncClientMessageTrailers.java)
-
- This example demonstrates how to use a custom execution interceptor to add trailers to all outgoing request enclosing
- an entity..
-
-- [Multiplexed HTTP/2 exchanges](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/AsyncClientHttp2ServerPush.java)
-
-This example demonstrates handling of HTTP/2 message exchanges pushed by the server.
-
-- [Client authentication](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/AsyncClientAuthentication.java)
-
- This example demonstrates execution of an HTTP request against a target site that requires user authentication.
-
-- [Custom SSL context](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/AsyncClientCustomSSL.java)
-
- This example demonstrates how to create secure connections with a custom SSL context.
-
-- [Connection / TLS configuation per route / host](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/AsyncClientConnectionConfig.java)
-
- This example demonstrates how to use connection configuration on a per-route or a per-host basis.
-
-- [Connection eviction](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/AsyncClientConnectionEviction.java)
-
- This example demonstrates how to evict expired and idle connections from the connection pool.
-
-- [Preemptive BASIC authentication](https://github.com/apache/httpcomponents-client/blob/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/AsyncPreemptiveBasicClientAuthentication.java)
-
- This example shows how HttpClient can be customized to authenticate preemptively using BASIC scheme. Generally,
- preemptive authentication can be considered less secure than a response to an authentication challenge and therefore
- discouraged.
-
-- [HTTP version negotiation](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/AsyncClientHttpVersionPolicy.java)
-
- This example demonstrates how to make HttpClient negotiate or force a particular version of HTTP protocol during
- the TLS handshake. Please note that protocol version policy setting also applies to non-HTTPS connections.
-
-- [Virtual HTTPS / SNI](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/AsyncClientSNI.java)
-
- This example demonstrates how to use SNI to send requests to a virtual HTTPS endpoint using the async I/O.
\ No newline at end of file
diff --git a/src/site/markdown/httpcomponents-client-5.4.x/examples-reactive.md b/src/site/markdown/httpcomponents-client-5.4.x/examples-reactive.md
deleted file mode 100644
index 2aab8bd..0000000
--- a/src/site/markdown/httpcomponents-client-5.4.x/examples-reactive.md
+++ /dev/null
@@ -1,25 +0,0 @@
-<!--
- Licensed to the Apache Software Foundation (ASF) under one
- or more contributor license agreements. See the NOTICE file
- distributed with this work for additional information
- regarding copyright ownership. The ASF licenses this file
- to you under the Apache License, Version 2.0 (the
- "License"); you may not use this file except in compliance
- with the License. You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
- Unless required by applicable law or agreed to in writing,
- software distributed under the License is distributed on an
- "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
- KIND, either express or implied. See the License for the
- specific language governing permissions and limitations
- under the License.
--->
-
-HttpClient Examples (Async)
-===========================
-
-- [HTTP exchange with Reactive Streams](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/AsyncClientHttpExchange.java)
-
- This example demonstrates a reactive, full-duplex HTTP/1.1 message exchange using RxJava.
diff --git a/src/site/markdown/httpcomponents-client-5.4.x/examples.md b/src/site/markdown/httpcomponents-client-5.4.x/examples.md
deleted file mode 100644
index d095090..0000000
--- a/src/site/markdown/httpcomponents-client-5.4.x/examples.md
+++ /dev/null
@@ -1,114 +0,0 @@
-<!--
- Licensed to the Apache Software Foundation (ASF) under one
- or more contributor license agreements. See the NOTICE file
- distributed with this work for additional information
- regarding copyright ownership. The ASF licenses this file
- to you under the Apache License, Version 2.0 (the
- "License"); you may not use this file except in compliance
- with the License. You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
- Unless required by applicable law or agreed to in writing,
- software distributed under the License is distributed on an
- "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
- KIND, either express or implied. See the License for the
- specific language governing permissions and limitations
- under the License.
--->
-
-HttpClient Examples (Classic)
-=============================
-
-- [Response handling](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientResponseProcessing.java)
-
- This example demonstrates how to process HTTP responses using a response handler. This is the recommended way of
- executing HTTP requests and processing HTTP responses. This approach enables the caller to concentrate on the process
- of digesting HTTP responses and to delegate the task of system resource deallocation to HttpClient. The use of an HTTP
- response handler guarantees that the underlying HTTP connection will be released back to the connection manager
- automatically in all cases.
-
-- [Manual connection release](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientConnectionRelease.java)
-
- This example demonstrates how to ensure the release of the underlying HTTP connection back to the connection manager
- in case of a manual processing of HTTP responses.
-
-- [HttpClient configuration](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientConfiguration.java)
-
- This example demonstrates how to customize and configure the most common aspects of HTTP request execution and
- connection management.
-
-- [Request execution interceptors](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientInterceptors.java)
-
- This example demonstrates how to insert custom request interceptor and an execution interceptor to the request
- execution chain.
-
-- [Abort method](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientAbortMethod.java)
-
- This example demonstrates how to abort an HTTP request before its normal completion.
-
-- [Client authentication](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientAuthentication.java)
-
- This example uses HttpClient to execute an HTTP request against a target site that requires user authentication.
-
-- [Request via a proxy](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientExecuteProxy.java)
-
- This example demonstrates how to send an HTTP request via a proxy.
-
-- [Proxy authentication](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientProxyAuthentication.java)
-
- A simple example showing execution of an HTTP request over a secure connection tunneled through an authenticating
- proxy.
-
-- [Chunk encoded POST](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientChunkEncodedPost.java)
-
- This example shows how to stream out a request entity using chunk encoding.
-
-- [Custom execution context](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientCustomContext.java)
-
- This example demonstrates the use of a local HTTP context populated custom attributes.
-
-- [Form based logon](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientFormLogin.java)
-
- This example demonstrates how HttpClient can be used to perform form-based logon.
-
-- [Threaded request execution](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientMultiThreadedExecution.java)
-
- An example that executes HTTP requests from multiple worker threads.
-
-- [Custom SSL context](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientCustomSSL.java)
-
- This example demonstrates how to create secure connections with a custom SSL context.
-
-- [Connection / TLS configuation per route / host](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientConnectionConfig.java)
-
- This example demonstrates how to use connection configuration on a per-route or a per-host basis.
-
-- [Preemptive BASIC authentication](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientPreemptiveBasicAuthentication.java)
-
- This example shows how HttpClient can be customized to authenticate preemptively using BASIC scheme. Generally,
- preemptive authentication can be considered less secure than a response to an authentication challenge and therefore
- discouraged.
-
-- [Preemptive DIGEST authentication](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientPreemptiveDigestAuthentication.java)
-
- This example shows how HttpClient can be customized to authenticate preemptively using DIGEST scheme. Generally,
- preemptive authentication can be considered less secure than a response to an authentication challenge and therefore
- discouraged.
-
-- [Proxy tunnel](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ProxyTunnelDemo.java)
-
- This example shows how to use ProxyClient in order to establish a tunnel through an HTTP proxy for an arbitrary
- protocol.
-
-- [Multipart encoded request entity](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientMultipartFormPost.java)
-
- This example shows how to execute requests enclosing a multipart encoded entity.
-
-- [Connection endpoint details](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientRemoteEndpointDetails.java)
-
- This example demonstrates how to get details of the underlying connection endpoint.
-
-- [Virtual HTTPS / SNI](https://github.com/apache/httpcomponents-client/tree/5.4.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientSNI.java)
-
- This example demonstrates how to use SNI to send requests to a virtual HTTPS endpoint using the classic I/O.
\ No newline at end of file
diff --git a/src/site/markdown/httpcomponents-client-5.4.x/index.md b/src/site/markdown/httpcomponents-client-5.4.x/index.md
deleted file mode 100644
index 4e38e77..0000000
--- a/src/site/markdown/httpcomponents-client-5.4.x/index.md
+++ /dev/null
@@ -1,90 +0,0 @@
-<!--
- Licensed to the Apache Software Foundation (ASF) under one
- or more contributor license agreements. See the NOTICE file
- distributed with this work for additional information
- regarding copyright ownership. The ASF licenses this file
- to you under the Apache License, Version 2.0 (the
- "License"); you may not use this file except in compliance
- with the License. You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
- Unless required by applicable law or agreed to in writing,
- software distributed under the License is distributed on an
- "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
- KIND, either express or implied. See the License for the
- specific language governing permissions and limitations
- under the License.
--->
-
-HttpClient Overview
-===================
-
-The Hyper-Text Transfer Protocol (HTTP) is perhaps the most significant protocol used on the Internet today. Web
-services, network-enabled appliances and the growth of network computing continue to expand the role of the HTTP
-protocol beyond user-driven web browsers, while increasing the number of applications that require HTTP support.
-
-Although the java.net package provides basic functionality for accessing resources via HTTP, it doesn't provide the full
-flexibility or functionality needed by many applications. HttpClient seeks to fill this void by providing an efficient,
-up-to-date, and feature-rich package implementing the client side of the most recent HTTP standards and recommendations.
-
-Designed for extension while providing robust support for the base HTTP protocol, HttpClient may be of interest to
-anyone building HTTP-aware client applications such as web browsers, web service clients, or systems that leverage or
-extend the HTTP protocol for distributed communication.
-
-Documentation
--------------
-
-1. [Quick Start](quickstart.md) - contains simple, complete examples of request execution with the classic, fluent and
- async APIs.
-1. Examples demonstrating some common as well as more complex use cases
-
- * [HttpClient (classic APIs)](examples.md)
- * [HttpClient (async APIs)](examples-async.md)
- * [HttpClient (reactive APIs)](examples-reactive.md)
-
-1. Javadocs
-
- * [HttpClient](./current/httpclient5/apidocs/)
- * [HC Fluent](./current/httpclient5-fluent/apidocs/)
- * [HttpClient Cache](./current/httpclient5-cache/apidocs/)
- * [HttpClient Windows extensions](./current/httpclient5-win/apidocs/)
-
-1. API compatibility reports
-
- * [HttpClient](./current/httpclient5/japicmp.html)
- * [HC Fluent](./current/httpclient5-fluent/japicmp.html)
- * [HttpClient Cache](./current/httpclient5-cache/japicmp.html)
- * [HttpClient Windows extensions](./current/httpclient5-win/japicmp.html)
-
-Features
---------
-
-- Standards based, pure Java, implementation of HTTP versions 1.0, 1.1, 2.0 (only async APIs)
-- Supports encryption with HTTPS (HTTP over SSL) protocol.
-- Pluggable TLS strategies.
-- Transparent message exchanges through HTTP/1.1, HTTP/1.0 and SOCKS proxies.
-- Tunneled HTTPS connections through HTTP/1.1 and HTTP/1.0 proxies, via the CONNECT method.
-- Basic, Digest, Bearer authentication schemes.
-- HTTP state management and cookie support.
-- Flexible connection management and pooling.
-- Support for HTTP response caching.
-- Source code is freely available under the Apache License.
-
-Standards Compliance
---------------------
-
-HttpClient strives to conform to the following specifications endorsed by the Internet Engineering Task Force (IETF) and
-the internet at large:
-
-- [RFC 9110](https://datatracker.ietf.org/doc/html/rfc9110) - HTTP Semantics
-- [RFC 9111](https://datatracker.ietf.org/doc/html/rfc9111) - HTTP Caching
-- [RFC 9112](https://datatracker.ietf.org/doc/html/rfc9112) - Hypertext Transfer Protocol Version 1.1 (HTTP/1.1)
-- [RFC 7540](https://datatracker.ietf.org/doc/html/rfc7540) - Hypertext Transfer Protocol Version 2 (HTTP/2)
-- [RFC 7541](https://datatracker.ietf.org/doc/html/rfc7541) - HPACK: Header Compression for HTTP/2
-- [RFC 1945](https://datatracker.ietf.org/doc/html/rfc1945) - Hypertext Transfer Protocol -- HTTP/1.0
-- [RFC 2396](https://datatracker.ietf.org/doc/html/rfc2396) - Uniform Resource Identifiers (URI): Generic Syntax
-- [RFC 6265](https://datatracker.ietf.org/doc/html/rfc6265) - HTTP State Management Mechanism (Cookies)
-- [RFC 7616](https://datatracker.ietf.org/doc/html/rfc7616) - HTTP Digest Access Authentication
-- [RFC 7617](https://datatracker.ietf.org/doc/html/rfc7617) - HTTP 'Basic' Authentication Scheme
-- [RFC 5861](https://datatracker.ietf.org/doc/html/rfc5861) - HTTP Cache-Control Extensions for Stale Content
diff --git a/src/site/markdown/httpcomponents-client-5.4.x/quickstart.md b/src/site/markdown/httpcomponents-client-5.4.x/quickstart.md
deleted file mode 100644
index 61a1f5c..0000000
--- a/src/site/markdown/httpcomponents-client-5.4.x/quickstart.md
+++ /dev/null
@@ -1,178 +0,0 @@
-<!--
- Licensed to the Apache Software Foundation (ASF) under one
- or more contributor license agreements. See the NOTICE file
- distributed with this work for additional information
- regarding copyright ownership. The ASF licenses this file
- to you under the Apache License, Version 2.0 (the
- "License"); you may not use this file except in compliance
- with the License. You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
- Unless required by applicable law or agreed to in writing,
- software distributed under the License is distributed on an
- "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
- KIND, either express or implied. See the License for the
- specific language governing permissions and limitations
- under the License.
--->
-
-HttpClient Quick Start
-======================
-
-- Download 'Binary' package of the latest HttpClient 5.4 release or configure dependency on `HttpClient` and `Fluent HC`
- modules using a dependency manager of your choice as described [here](./download.md).
-
-- HttpClient 5.4 requires Java 1.8 or newer.
-
-- The below code fragment illustrates the execution of HTTP GET and POST requests using the HttpClient native API.
-
- ```
- try (CloseableHttpClient httpclient = HttpClients.createDefault()) {
- ClassicHttpRequest httpGet = ClassicRequestBuilder.get("http://httpbin.org/get")
- .build();
- // The underlying HTTP connection is still held by the response object
- // to allow the response content to be streamed directly from the network socket.
- // In order to ensure correct deallocation of system resources
- // the user MUST call CloseableHttpResponse#close() from a finally clause.
- // Please note that if response content is not fully consumed the underlying
- // connection cannot be safely re-used and will be shut down and discarded
- // by the connection manager.
- httpclient.execute(httpGet, response -> {
- System.out.println(response.getCode() + " " + response.getReasonPhrase());
- final HttpEntity entity1 = response.getEntity();
- // do something useful with the response body
- // and ensure it is fully consumed
- EntityUtils.consume(entity1);
- return null;
- });
-
- ClassicHttpRequest httpPost = ClassicRequestBuilder.post("http://httpbin.org/post")
- .setEntity(new UrlEncodedFormEntity(Arrays.asList(
- new BasicNameValuePair("username", "vip"),
- new BasicNameValuePair("password", "secret"))))
- .build();
- httpclient.execute(httpPost, response -> {
- System.out.println(response.getCode() + " " + response.getReasonPhrase());
- final HttpEntity entity2 = response.getEntity();
- // do something useful with the response body
- // and ensure it is fully consumed
- EntityUtils.consume(entity2);
- return null;
- });
- }
- ```
-
-- The same requests can be executed using a simpler, albeit less flexible, fluent API.
-
- ```
- // The fluent API relieves the user from having to deal with manual deallocation of system
- // resources at the cost of having to buffer response content in memory in some cases.
-
- Request.Get("http://targethost/homepage")
- .execute().returnContent();
- Request.Post("http://targethost/login")
- .bodyForm(Form.form().add("username", "vip").add("password", "secret").build())
- .execute().returnContent();
- ```
-
-- The below code fragment illustrates the execution of HTTP requests using HttpClient async API.
-
- ```
- try (CloseableHttpAsyncClient httpclient = HttpAsyncClients.createDefault()) {
- // Start the client
- httpclient.start();
-
- // Execute request
- SimpleHttpRequest request1 = SimpleRequestBuilder.get("http://httpbin.org/get").build();
- Future<SimpleHttpResponse> future = httpclient.execute(request1, null);
- // and wait until response is received
- SimpleHttpResponse response1 = future.get();
- System.out.println(request1.getRequestUri() + "->" + response1.getCode());
-
- // One most likely would want to use a callback for operation result
- CountDownLatch latch1 = new CountDownLatch(1);
- SimpleHttpRequest request2 = SimpleRequestBuilder.get("http://httpbin.org/get").build();
- httpclient.execute(request2, new FutureCallback<SimpleHttpResponse>() {
-
- @Override
- public void completed(SimpleHttpResponse response2) {
- latch1.countDown();
- System.out.println(request2.getRequestUri() + "->" + response2.getCode());
- }
-
- @Override
- public void failed(Exception ex) {
- latch1.countDown();
- System.out.println(request2.getRequestUri() + "->" + ex);
- }
-
- @Override
- public void cancelled() {
- latch1.countDown();
- System.out.println(request2.getRequestUri() + " cancelled");
- }
-
- });
- latch1.await();
-
- // In real world one most likely would want also want to stream
- // request and response body content
- CountDownLatch latch2 = new CountDownLatch(1);
- AsyncRequestProducer producer3 = AsyncRequestBuilder.get("http://httpbin.org/get").build();
- AbstractCharResponseConsumer<HttpResponse> consumer3 = new AbstractCharResponseConsumer<HttpResponse>() {
-
- HttpResponse response;
-
- @Override
- protected void start(HttpResponse response, ContentType contentType) throws HttpException, IOException {
- this.response = response;
- }
-
- @Override
- protected int capacityIncrement() {
- return Integer.MAX_VALUE;
- }
-
- @Override
- protected void data(CharBuffer data, boolean endOfStream) throws IOException {
- // Do something useful
- }
-
- @Override
- protected HttpResponse buildResult() throws IOException {
- return response;
- }
-
- @Override
- public void releaseResources() {
- }
-
- };
- httpclient.execute(producer3, consumer3, new FutureCallback<HttpResponse>() {
-
- @Override
- public void completed(HttpResponse response3) {
- latch2.countDown();
- System.out.println(request2.getRequestUri() + "->" + response3.getCode());
- }
-
- @Override
- public void failed(Exception ex) {
- latch2.countDown();
- System.out.println(request2.getRequestUri() + "->" + ex);
- }
-
- @Override
- public void cancelled() {
- latch2.countDown();
- System.out.println(request2.getRequestUri() + " cancelled");
- }
-
- });
- latch2.await();
-
- }
- ```
-
-
diff --git a/src/site/markdown/httpcomponents-client-5.4.x/android.md b/src/site/markdown/httpcomponents-client-5.5.x/android.md
similarity index 100%
rename from src/site/markdown/httpcomponents-client-5.4.x/android.md
rename to src/site/markdown/httpcomponents-client-5.5.x/android.md
diff --git a/src/site/markdown/httpcomponents-client-5.5.x/download.md b/src/site/markdown/httpcomponents-client-5.5.x/download.md
index c98d157..b39cc8e 100644
--- a/src/site/markdown/httpcomponents-client-5.5.x/download.md
+++ b/src/site/markdown/httpcomponents-client-5.5.x/download.md
@@ -23,7 +23,7 @@ HttpClient Downloads
The latest release available for download:
[Release packages](https://hc.apache.org/downloads.cgi) -
-[Release Notes](https://www.apache.org/dist/httpcomponents/httpclient/RELEASE_NOTES-5.4.x.txt) -
+[Release Notes](https://www.apache.org/dist/httpcomponents/httpclient/RELEASE_NOTES-5.5.x.txt) -
[License](https://www.apache.org/licenses/LICENSE-2.0.html)
Dependency management
diff --git a/src/site/markdown/httpcomponents-client-5.4.x/logging.md b/src/site/markdown/httpcomponents-client-5.5.x/logging.md
similarity index 100%
rename from src/site/markdown/httpcomponents-client-5.4.x/logging.md
rename to src/site/markdown/httpcomponents-client-5.5.x/logging.md
diff --git a/src/site/markdown/httpcomponents-client-5.4.x/migration-guide/index.md b/src/site/markdown/httpcomponents-client-5.5.x/migration-guide/index.md
similarity index 100%
rename from src/site/markdown/httpcomponents-client-5.4.x/migration-guide/index.md
rename to src/site/markdown/httpcomponents-client-5.5.x/migration-guide/index.md
diff --git a/src/site/markdown/httpcomponents-client-5.4.x/migration-guide/migration-to-async-http2.md b/src/site/markdown/httpcomponents-client-5.5.x/migration-guide/migration-to-async-http2.md
similarity index 100%
rename from src/site/markdown/httpcomponents-client-5.4.x/migration-guide/migration-to-async-http2.md
rename to src/site/markdown/httpcomponents-client-5.5.x/migration-guide/migration-to-async-http2.md
diff --git a/src/site/markdown/httpcomponents-client-5.4.x/migration-guide/migration-to-async-simple.md b/src/site/markdown/httpcomponents-client-5.5.x/migration-guide/migration-to-async-simple.md
similarity index 100%
rename from src/site/markdown/httpcomponents-client-5.4.x/migration-guide/migration-to-async-simple.md
rename to src/site/markdown/httpcomponents-client-5.5.x/migration-guide/migration-to-async-simple.md
diff --git a/src/site/markdown/httpcomponents-client-5.4.x/migration-guide/migration-to-async-streaming.md b/src/site/markdown/httpcomponents-client-5.5.x/migration-guide/migration-to-async-streaming.md
similarity index 100%
rename from src/site/markdown/httpcomponents-client-5.4.x/migration-guide/migration-to-async-streaming.md
rename to src/site/markdown/httpcomponents-client-5.5.x/migration-guide/migration-to-async-streaming.md
diff --git a/src/site/markdown/httpcomponents-client-5.4.x/migration-guide/migration-to-classic.md b/src/site/markdown/httpcomponents-client-5.5.x/migration-guide/migration-to-classic.md
similarity index 100%
rename from src/site/markdown/httpcomponents-client-5.4.x/migration-guide/migration-to-classic.md
rename to src/site/markdown/httpcomponents-client-5.5.x/migration-guide/migration-to-classic.md
diff --git a/src/site/markdown/httpcomponents-client-5.4.x/migration-guide/preparation.md b/src/site/markdown/httpcomponents-client-5.5.x/migration-guide/preparation.md
similarity index 100%
rename from src/site/markdown/httpcomponents-client-5.4.x/migration-guide/preparation.md
rename to src/site/markdown/httpcomponents-client-5.5.x/migration-guide/preparation.md
diff --git a/src/site/markdown/httpcomponents-client-5.4.x/related-projects.md b/src/site/markdown/httpcomponents-client-5.5.x/related-projects.md
similarity index 100%
rename from src/site/markdown/httpcomponents-client-5.4.x/related-projects.md
rename to src/site/markdown/httpcomponents-client-5.5.x/related-projects.md
diff --git a/src/site/markdown/news.md b/src/site/markdown/news.md
index c5ab80a..8100e4c 100644
--- a/src/site/markdown/news.md
+++ b/src/site/markdown/news.md
@@ -20,6 +20,30 @@
HttpComponents Project News
===========================
+###### 26 May 2025 - HttpComponents Client 5.5 GA released
+
+This is the first GA release in the 5.5 release series. It adds several experimental
+features and improvements such as request multiplexing over a shared HTTP/2 connection
+and the Classic API facade acting as a compatibility bridge between classic I/O client
+services and the asynchronous message transport used internally.
+
+Notable changes and features included in the 5.5 series:
+
+* Improved conformance to RFC 7616 (HTTP Digest Access Authentication).
+
+* The connection pool implementation acts as a caching facade in front of a standard
+ managed connection pool and shares already leased connections to multiplex message
+ exchanges over active HTTP/2 connections. Experimental.
+
+* Extended Auth API and improved authentication protocol logic to support mutual
+ authentication.
+
+* The Classic API facade acting as a compatibility bridge between the classic I/O client
+ services (based on the standard InputStream / OutputStream model) and the asynchronous
+ message transport used internally. Experimental.
+
+* HTTP/2 support for the Fluent Facade (via Classic API facade). Experimental.
+
###### 28 April 2025 - HttpComponents Client 5.4.4 GA released
This maintenance release corrects several regressions reported since the last release,
@@ -44,23 +68,6 @@ features and improvements such as request multiplexing over a shared HTTP/2 conn
and the Classic API facade acting as a compatibility bridge between classic I/O client
services and the asynchronous message transport used internally.
-Notable changes and features included in the 5.5 series:
-
-* Improved conformance to RFC 7616 (HTTP Digest Access Authentication).
-
-* The connection pool implementation acts as a caching facade in front of a standard
- managed connection pool and shares already leased connections to multiplex message
- exchanges over active HTTP/2 connections. Experimental.
-
-* Extended Auth API and improved authentication protocol logic to support mutual
- authentication.
-
-* The Classic API facade acting as a compatibility bridge between the classic I/O client
- services (based on the standard InputStream / OutputStream model) and the asynchronous
- message transport used internally. Experimental.
-
-* HTTP/2 support for the Fluent Facade (via Classic API facade). Experimental.
-
###### 3 Feb 2025 - HttpComponents Client 5.4.2 GA released
This is a maintenance release that upgrades HttpCore to version 5.3.3 and fixes several
diff --git a/src/site/markdown/status.md b/src/site/markdown/status.md
index a42a320..0985637 100644
--- a/src/site/markdown/status.md
+++ b/src/site/markdown/status.md
@@ -23,21 +23,19 @@ HttpComponents Project Status
HttpComponents HttpClient 5.5.x
-------------------------------
-HttpClient 5.5.x branch is the current development branch. The 5.5.x release series is going to feature
-an experimental Classic API facade acting as a compatibility bridge between the classic I/O client services
-(based on the standard InputStream / OutputStream model) and the asynchronous message transport used internally.
-This branch also makes it possible for the pooling connection manager to make use of HTTP/2 message
-multiplexing.
+HttpClient 5.5.x branch is considered stable and production ready. It is being actively maintained and supported.
+The 5.5.x release series features an experimental Classic API facade acting as a compatibility bridge between
+the classic I/O client services (based on the standard InputStream / OutputStream model) and the asynchronous
+message transport used internally. This branch also makes it possible for the pooling connection manager to make
+use of HTTP/2 message multiplexing.
-HttpComponents HttpClient 5.4.x
+HttpComponents HttpCore 5.4.x
-------------------------------
-HttpClient 5.4.x branch is considered stable and production ready. It is being actively maintained and supported.
-The 5.4.x release series upgrades HTTP protocol conformance level to RFC 9110, replaces `synchronized` blocks
-with lock primitives, redesigns the HTTP caching protocol layer for better efficiency and improved conformance
-to RFC 9111, introduces support for RFC 2817 (Upgrading to TLS Within HTTP/1.1), and provides a number of
-other API enhancements. This branch also seeks to optimize common HTTP context operations that should translate
-in a better performance of HTTP message exchanges.
+HttpCore 5.4.x branch is the current development branch. The 5.5.x release series is going to feature
+an experimental Classic API facade acting as a compatibility bridge between the classic I/O client and server
+services (based on the standard InputStream / OutputStream model) and the asynchronous message transport used
+internally. It also adds HTTP QUERY method support.
HttpComponents HttpCore 5.3.x
-------------------------------
diff --git a/src/site/resources/.htaccess b/src/site/resources/.htaccess
index ff89460..2b14120 100644
--- a/src/site/resources/.htaccess
+++ b/src/site/resources/.htaccess
@@ -26,9 +26,10 @@ Redirect permanent "/httpcomponents-core-5.1.x" "/httpcomponents-core-5.3
Redirect permanent "/httpcomponents-core-5.2.x" "/httpcomponents-core-5.3.x"
Redirect permanent "/httpcomponents-core" "/httpcomponents-core-5.3.x"
Redirect permanent "/httpcomponents-core-ga" "/httpcomponents-core-5.3.x"
-Redirect permanent "/httpcomponents-client-5.0.x" "/httpcomponents-client-5.4.x"
-Redirect permanent "/httpcomponents-client-5.1.x" "/httpcomponents-client-5.4.x"
-Redirect permanent "/httpcomponents-client-5.2.x" "/httpcomponents-client-5.4.x"
-Redirect permanent "/httpcomponents-client-5.3.x" "/httpcomponents-client-5.4.x"
-Redirect permanent "/httpcomponents-client" "/httpcomponents-client-5.4.x"
-Redirect permanent "/httpcomponents-client-ga" "/httpcomponents-client-5.4.x"
\ No newline at end of file
+Redirect permanent "/httpcomponents-client-5.0.x" "/httpcomponents-client-5.5.x"
+Redirect permanent "/httpcomponents-client-5.1.x" "/httpcomponents-client-5.5.x"
+Redirect permanent "/httpcomponents-client-5.2.x" "/httpcomponents-client-5.5.x"
+Redirect permanent "/httpcomponents-client-5.3.x" "/httpcomponents-client-5.5.x"
+Redirect permanent "/httpcomponents-client-5.4.x" "/httpcomponents-client-5.5.x"
+Redirect permanent "/httpcomponents-client" "/httpcomponents-client-5.5.x"
+Redirect permanent "/httpcomponents-client-ga" "/httpcomponents-client-5.5.x"
\ No newline at end of file
diff --git a/src/site/resources/httpcomponents-client-5.5.x/documentation.links b/src/site/resources/httpcomponents-client-5.5.x/documentation.links
index 406798a..013cc09 100644
--- a/src/site/resources/httpcomponents-client-5.5.x/documentation.links
+++ b/src/site/resources/httpcomponents-client-5.5.x/documentation.links
@@ -21,4 +21,5 @@
# links to components in https://hc.apache.org/components/
5.5-alpha1 ../components/httpcomponents-client-5.5.x/5.5-alpha1
-current ../components/httpcomponents-client-5.5.x/5.5-alpha1
+5.5 ../components/httpcomponents-client-5.5.x/5.5
+current ../components/httpcomponents-client-5.5.x/5.5
diff --git a/src/site/site.xml b/src/site/site.xml
index b631ae2..0ce9621 100644
--- a/src/site/site.xml
+++ b/src/site/site.xml
@@ -72,33 +72,23 @@ under the License.
<item name="Get Involved" href="get-involved.html"/>
</menu>
<menu name="Components">
- <item name="HttpClient 5.5 ALPHA" collapse="true" href="httpcomponents-client-5.5.x/index.html">
+ <item name="HttpClient 5.5" collapse="true" href="httpcomponents-client-5.5.x/index.html">
<item name="Quick Start" href="httpcomponents-client-5.5.x/quickstart.html"/>
+ <item name="Migration Guide" collapse="true" href="httpcomponents-client-5.5.x/migration-guide/index.html">
+ <item name="Preparation" href="httpcomponents-client-5.5.x/migration-guide/preparation.html"/>
+ <item name="Classic" href="httpcomponents-client-5.5.x/migration-guide/migration-to-classic.html"/>
+ <item name="Async Simple" href="httpcomponents-client-5.5.x/migration-guide/migration-to-async-simple.html"/>
+ <item name="Async Streaming" href="httpcomponents-client-5.5.x/migration-guide/migration-to-async-streaming.html"/>
+ <item name="Async HTTP/2 only" href="httpcomponents-client-5.5.x/migration-guide/migration-to-async-http2.html"/>
+ </item>
<item name="Examples (Classic)" href="httpcomponents-client-5.5.x/examples.html"/>
<item name="Examples (Async)" href="httpcomponents-client-5.5.x/examples-async.html"/>
<item name="Examples (Reactive)" href="httpcomponents-client-5.5.x/examples-reactive.html"/>
- <item name="Logging Guide" href="httpcomponents-client-5.4.x/logging.html"/>
- <item name="Android" href="httpcomponents-client-5.4.x/android.html"/>
- <item name="Related" href="httpcomponents-client-5.4.x/related-projects.html"/>
+ <item name="Logging Guide" href="httpcomponents-client-5.5.x/logging.html"/>
+ <item name="Android" href="httpcomponents-client-5.5.x/android.html"/>
+ <item name="Related" href="httpcomponents-client-5.5.x/related-projects.html"/>
<item name="Download" href="httpcomponents-client-5.5.x/download.html"/>
</item>
- <item name="HttpClient 5.4" collapse="true" href="httpcomponents-client-5.4.x/index.html">
- <item name="Quick Start" href="httpcomponents-client-5.4.x/quickstart.html"/>
- <item name="Migration Guide" collapse="true" href="httpcomponents-client-5.4.x/migration-guide/index.html">
- <item name="Preparation" href="httpcomponents-client-5.4.x/migration-guide/preparation.html"/>
- <item name="Classic" href="httpcomponents-client-5.4.x/migration-guide/migration-to-classic.html"/>
- <item name="Async Simple" href="httpcomponents-client-5.4.x/migration-guide/migration-to-async-simple.html"/>
- <item name="Async Streaming" href="httpcomponents-client-5.4.x/migration-guide/migration-to-async-streaming.html"/>
- <item name="Async HTTP/2 only" href="httpcomponents-client-5.4.x/migration-guide/migration-to-async-http2.html"/>
- </item>
- <item name="Examples (Classic)" href="httpcomponents-client-5.4.x/examples.html"/>
- <item name="Examples (Async)" href="httpcomponents-client-5.4.x/examples-async.html"/>
- <item name="Examples (Reactive)" href="httpcomponents-client-5.4.x/examples-reactive.html"/>
- <item name="Logging Guide" href="httpcomponents-client-5.4.x/logging.html"/>
- <item name="Android" href="httpcomponents-client-5.4.x/android.html"/>
- <item name="Related" href="httpcomponents-client-5.4.x/related-projects.html"/>
- <item name="Download" href="httpcomponents-client-5.4.x/download.html"/>
- </item>
<item name="HttpCore 5.3" collapse="true" href="httpcomponents-core-5.3.x/index.html">
<item name="Examples" href="httpcomponents-core-5.3.x/examples.html"/>
<item name="Related" href="httpcomponents-core-5.3.x/related-projects.html"/>
diff --git a/src/site/xdoc/downloads.xml b/src/site/xdoc/downloads.xml
index 93208c1..a7e5262 100644
--- a/src/site/xdoc/downloads.xml
+++ b/src/site/xdoc/downloads.xml
@@ -64,34 +64,34 @@
<code>sha512</code> link downloads the SHA 512 checksum from the main site.
</p>
- <subsection name="HttpClient 5.4.4 (GA)">
+ <subsection name="HttpClient 5.5 (GA)">
<a href="https://downloads.apache.org/httpcomponents/httpclient/KEYS">KEYS</a>
- <a href="https://downloads.apache.org/httpcomponents/httpclient/RELEASE_NOTES-5.4.x.txt">Release Notes</a>
+ <a href="https://downloads.apache.org/httpcomponents/httpclient/RELEASE_NOTES-5.5.x.txt">Release Notes</a>
<br/>
<p>Binary</p>
<ul>
<li>
- <a href="[preferred]/httpcomponents/httpclient/binary/httpcomponents-client-5.4.4-bin.tar.gz">5.4.4.tar.gz</a>
- [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.4.4-bin.tar.gz.sha512">sha512</a>]
- [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.4.4-bin.tar.gz.asc">pgp</a>]
+ <a href="[preferred]/httpcomponents/httpclient/binary/httpcomponents-client-5.5-bin.tar.gz">5.5.tar.gz</a>
+ [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.5-bin.tar.gz.sha512">sha512</a>]
+ [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.5-bin.tar.gz.asc">pgp</a>]
</li>
<li>
- <a href="[preferred]/httpcomponents/httpclient/binary/httpcomponents-client-5.4.4-bin.zip">5.4.4.zip</a>
- [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.4.4-bin.zip.sha512">sha512</a>]
- [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.4.4-bin.zip.asc">pgp</a>]
+ <a href="[preferred]/httpcomponents/httpclient/binary/httpcomponents-client-5.5-bin.zip">5.5.zip</a>
+ [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.5-bin.zip.sha512">sha512</a>]
+ [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.5-bin.zip.asc">pgp</a>]
</li>
</ul>
<p>Source</p>
<ul>
<li>
- <a href="[preferred]/httpcomponents/httpclient/source/httpcomponents-client-5.4.4-src.tar.gz">5.4.4.tar.gz</a>
- [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.4.4-src.tar.gz.sha512">sha512</a>]
- [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.4.4-src.tar.gz.asc">pgp</a>]
+ <a href="[preferred]/httpcomponents/httpclient/source/httpcomponents-client-5.5-src.tar.gz">5.5.tar.gz</a>
+ [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.5-src.tar.gz.sha512">sha512</a>]
+ [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.5-src.tar.gz.asc">pgp</a>]
</li>
<li>
- <a href="[preferred]/httpcomponents/httpclient/source/httpcomponents-client-5.4.4-src.zip">5.4.4.zip</a>
- [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.4.4-src.zip.sha512">sha512</a>]
- [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.4.4-src.zip.asc">pgp</a>]
+ <a href="[preferred]/httpcomponents/httpclient/source/httpcomponents-client-5.5-src.zip">5.5.zip</a>
+ [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.5-src.zip.sha512">sha512</a>]
+ [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.5-src.zip.asc">pgp</a>]
</li>
</ul>
</subsection>
@@ -138,38 +138,6 @@
</ul>
</subsection>
- <subsection name="HttpClient 5.5 ALPHA1">
- <a href="https://downloads.apache.org/httpcomponents/httpclient/KEYS">KEYS</a>
- <a href="https://downloads.apache.org/httpcomponents/httpclient/RELEASE_NOTES-5.5.x.txt">Release Notes</a>
- <br/>
- <p>Binary</p>
- <ul>
- <li>
- <a href="[preferred]/httpcomponents/httpclient/binary/httpcomponents-client-5.5-alpha1-bin.tar.gz">5.5-alpha1.tar.gz</a>
- [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.5-alpha1-bin.tar.gz.sha512">sha512</a>]
- [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.5-alpha1-bin.tar.gz.asc">pgp</a>]
- </li>
- <li>
- <a href="[preferred]/httpcomponents/httpclient/binary/httpcomponents-client-5.5-alpha1-bin.zip">5.5-alpha1.zip</a>
- [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.5-alpha1-bin.zip.sha512">sha512</a>]
- [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.5-alpha1-bin.zip.asc">pgp</a>]
- </li>
- </ul>
- <p>Source</p>
- <ul>
- <li>
- <a href="[preferred]/httpcomponents/httpclient/source/httpcomponents-client-5.5-alpha1-src.tar.gz">5.5-alpha1.tar.gz</a>
- [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.5-alpha1-src.tar.gz.sha512">sha512</a>]
- [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.5-alpha1-src.tar.gz.asc">pgp</a>]
- </li>
- <li>
- <a href="[preferred]/httpcomponents/httpclient/source/httpcomponents-client-5.5-alpha1-src.zip">5.5-alpha1.zip</a>
- [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.5-alpha1-src.zip.sha512">sha512</a>]
- [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.5-alpha1-src.zip.asc">pgp</a>]
- </li>
- </ul>
- </subsection>
-
<subsection name="HttpClient 4.5.14 (GA)">
<a href="https://downloads.apache.org/httpcomponents/httpclient/KEYS">KEYS</a>
<a href="https://downloads.apache.org/httpcomponents/httpclient/RELEASE_NOTES-4.5.x.txt">Release Notes</a>