You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@maven.apache.org by "John Casey (JIRA)" <ji...@codehaus.org> on 2005/09/30 16:20:11 UTC
[jira] Commented: (MNG-868) Use uniform format for and other tags
[ http://jira.codehaus.org/browse/MNG-868?page=comments#action_47534 ]
John Casey commented on MNG-868:
--------------------------------
The activation property is not the same as any old configuration parameter. For one thing, we're not (currently) supporting combinatorial logic for multiple properties, which means that using a flat MAP style is leaving the door open to problems of multiple property specification. Perhaps I'd better rename the activation property to <systemProperty>, where the separation is more clear.
In all other cases, properties are a map, or a DOM. In this case, I want the semantics to clearly support one property specification.
> Use uniform format for <properties> and other tags
> --------------------------------------------------
>
> Key: MNG-868
> URL: http://jira.codehaus.org/browse/MNG-868
> Project: Maven 2
> Type: Bug
> Components: design
> Versions: 2.0-beta-1
> Reporter: Kenney Westerhof
> Fix For: 2.0-beta-3
>
> Original Estimate: 2 hours
> Remaining: 2 hours
>
> In settings.xml, the activationproperties have the format: <property><name/><value/></property>
> whereas the 'user' properties below (which don't have any documentation) have the format
> <my.property.name>my.property.value</my.property.name>.
> They should really be uniform. My personal favourite is ofcourse: <property name="....">....</property>.
> There are more places where duplicate classes are used (repositories,..).
> (Also suggest to remove the <dependencies> tag from <dependencyManagement>
> and make DependencyManagement extend from Dependencies (or, make it a list)., but this
> could prove troublesome.)
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
http://www.atlassian.com/software/jira
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org