You are viewing a plain text version of this content. The canonical link for it is here.
Posted to derby-dev@db.apache.org by "Junjie Peng (JIRA)" <ji...@apache.org> on 2008/08/05 06:16:50 UTC

[jira] Updated: (DERBY-3798) Remove unnecessary call to Hashtable.get() in TableScanResultSet.getNextRowCore()

     [ https://issues.apache.org/jira/browse/DERBY-3798?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Junjie Peng updated DERBY-3798:
-------------------------------

    Attachment: derby-3798-1.stat
                derby-3798-1.patch

Hi, Knut.

I agree with you. I have do the change as you suggested.
Besides, remove an variable never used.

Please check it!


> Remove unnecessary call to Hashtable.get() in TableScanResultSet.getNextRowCore()
> ---------------------------------------------------------------------------------
>
>                 Key: DERBY-3798
>                 URL: https://issues.apache.org/jira/browse/DERBY-3798
>             Project: Derby
>          Issue Type: Improvement
>          Components: Newcomer, SQL
>    Affects Versions: 10.5.0.0
>            Reporter: Knut Anders Hatlen
>            Assignee: Junjie Peng
>            Priority: Trivial
>         Attachments: derby-3798-1.patch, derby-3798-1.stat
>
>
> I came across this piece of code in TableScanResultSet.getNextRowCore():
> 						if (past2FutureTbl.get(rowLoc) != null)
> 						{
> 							past2FutureTbl.remove(rowLoc);
> 							continue;
> 						}
> I believe the call to Hashtable.get() is unnecessary since Hashtable.remove() returns the object it removed or null if the key was not in the table. So I believe the code could be simplified like this without changing the behaviour:
>     if (past2FutureTbl.remove(rowLoc) != null) {
>         continue;
>     }

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.