You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@hive.apache.org by cheng xu <ch...@intel.com> on 2015/05/28 07:19:23 UTC
Review Request 34752: Beeline-CLI: Implement CLI source command using
Beeline functionality
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/34752/
-----------------------------------------------------------
Review request for hive and Xuefu Zhang.
Bugs: HIVE-10821
https://issues.apache.org/jira/browse/HIVE-10821
Repository: hive-git
Description
-------
Add source command support for CLI using beeline
Diffs
-----
beeline/src/java/org/apache/hive/beeline/BeeLine.java 4a82635
beeline/src/test/org/apache/hive/beeline/cli/TestHiveCli.java cc0b598
Diff: https://reviews.apache.org/r/34752/diff/
Testing
-------
Newly created UT passed
Thanks,
cheng xu
Re: Review Request 34752: Beeline-CLI: Implement CLI source command
using Beeline functionality
Posted by cheng xu <ch...@intel.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/34752/
-----------------------------------------------------------
(Updated May 29, 2015, 2:44 a.m.)
Review request for hive and Xuefu Zhang.
Bugs: HIVE-10821
https://issues.apache.org/jira/browse/HIVE-10821
Repository: hive-git
Description
-------
Add source command support for CLI using beeline
Diffs (updated)
-----
beeline/src/java/org/apache/hive/beeline/BeeLine.java 4a82635
beeline/src/test/org/apache/hive/beeline/cli/TestHiveCli.java cc0b598
Diff: https://reviews.apache.org/r/34752/diff/
Testing
-------
Newly created UT passed
Thanks,
cheng xu
Re: Review Request 34752: Beeline-CLI: Implement CLI source command
using Beeline functionality
Posted by ch...@huawei.com.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/34752/#review85540
-----------------------------------------------------------
beeline/src/java/org/apache/hive/beeline/BeeLine.java
<https://reviews.apache.org/r/34752/#comment137137>
Instead of changing variable scope declare these constants in test class.
beeline/src/java/org/apache/hive/beeline/BeeLine.java
<https://reviews.apache.org/r/34752/#comment137133>
Change variable isSource to isSourceCmd for better readability.
beeline/src/java/org/apache/hive/beeline/BeeLine.java
<https://reviews.apache.org/r/34752/#comment137134>
If possible move setExit(false) to sourceFile(String cmd) method.
beeline/src/java/org/apache/hive/beeline/BeeLine.java
<https://reviews.apache.org/r/34752/#comment137135>
Avoid trriming the cmd after the method cliToBeelineCmd(line), until if we are making some change on this command because it is already trimmed.
beeline/src/java/org/apache/hive/beeline/BeeLine.java
<https://reviews.apache.org/r/34752/#comment137136>
Declare the variable outside the loop.
- chinna
On May 28, 2015, 5:19 a.m., cheng xu wrote:
>
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/34752/
> -----------------------------------------------------------
>
> (Updated May 28, 2015, 5:19 a.m.)
>
>
> Review request for hive and Xuefu Zhang.
>
>
> Bugs: HIVE-10821
> https://issues.apache.org/jira/browse/HIVE-10821
>
>
> Repository: hive-git
>
>
> Description
> -------
>
> Add source command support for CLI using beeline
>
>
> Diffs
> -----
>
> beeline/src/java/org/apache/hive/beeline/BeeLine.java 4a82635
> beeline/src/test/org/apache/hive/beeline/cli/TestHiveCli.java cc0b598
>
> Diff: https://reviews.apache.org/r/34752/diff/
>
>
> Testing
> -------
>
> Newly created UT passed
>
>
> Thanks,
>
> cheng xu
>
>