You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Colin Patrick McCabe (JIRA)" <ji...@apache.org> on 2012/07/11 00:36:34 UTC

[jira] [Updated] (HDFS-3537) put libhdfs source files in a directory named libhdfs

     [ https://issues.apache.org/jira/browse/HDFS-3537?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Colin Patrick McCabe updated HDFS-3537:
---------------------------------------

    Attachment: do.sh

It seemed easier just to put the svn commands and patch command into a script.  So here it is, do.sh.  If you run it from the root of the svn repo, it will perform the move.

I also moved fuse_dfs out of contrib and into src/main/native, as discussed in HDFS-3451, since it seems like we want to do that too, and it's easier to combine them.  Let me know if you want me to split that out again.
                
> put libhdfs source files in a directory named libhdfs
> -----------------------------------------------------
>
>                 Key: HDFS-3537
>                 URL: https://issues.apache.org/jira/browse/HDFS-3537
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>    Affects Versions: 2.0.0-alpha
>            Reporter: Colin Patrick McCabe
>            Assignee: Colin Patrick McCabe
>            Priority: Minor
>             Fix For: 2.0.1-alpha
>
>         Attachments: HDFS-3537.001.patch, do.sh
>
>
> Move libhdfs source files from main/native to main/native/libhdfs.  Rename hdfs_read to libhdfs_test_read; rename hdfs_write to libhdfs_test_write.
> The rationale is that we'd like to add some other stuff under main/native (like fuse_dfs) and it's nice to have separate things in separate directories.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira