You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "Piotr Nowojski (Jira)" <ji...@apache.org> on 2020/03/25 14:08:00 UTC
[jira] [Closed] (FLINK-16316) Provide new base class for
StreamOperators
[ https://issues.apache.org/jira/browse/FLINK-16316?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Piotr Nowojski closed FLINK-16316.
----------------------------------
Resolution: Fixed
Merged as 89ceb2a59c..73d410354d
> Provide new base class for StreamOperators
> ------------------------------------------
>
> Key: FLINK-16316
> URL: https://issues.apache.org/jira/browse/FLINK-16316
> Project: Flink
> Issue Type: Sub-task
> Components: API / DataStream
> Affects Versions: 1.10.0
> Reporter: Piotr Nowojski
> Assignee: Piotr Nowojski
> Priority: Major
> Labels: pull-request-available
> Fix For: 1.11.0
>
> Time Spent: 20m
> Remaining Estimate: 0h
>
> Current {{AbstractStreamOperator}} has at least couple of issues:
> # it's using deprecated {{SetupableStreamOperator}} interface, instead of relaying on {{StreamOperatorFactory}}.
> # it depends on {{OneInputStreamOperator}} and {{TwoInputStreamOperator}} interfaces, by providing indirectly implementation of methods like {{processLatencyMarker}}, {{processLatencyMarker1}} and {{processLatencyMarker2}}
> Both of those things makes {{AbstractStreamOperator}} an unsuitable base implementation for {{MultipleInputStreamOperator}}. We should provide a new base class (or hierarchy of base classes), without those two limitations.
> CC [~aljoscha]
--
This message was sent by Atlassian Jira
(v8.3.4#803005)