You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@hbase.apache.org by Jim Kellerman <ji...@powerset.com> on 2008/07/30 00:11:50 UTC
Naming patches
Several people, myself included, have become confused trying to decide which patch to test for an issue when multiple versions of the patch have been uploaded to Jira and each patch has a different name.
Please try to follow the following naming conventions when uploading a patch:
hbase-<version_patch_applies_to>-<jira_number>.patch
For example the latest patch for HBASE-766 would be named:
hbase-0.2.0-766.patch
If there is a subsequent revision to a patch, please name it the same thing. Jira will show the most recent one at the top of the list.
Finally, if you want your patch reviewed, mark the Jira issue as patch available. Then it will show up in the patch review queue:
https://issues.apache.org/jira/secure/IssueNavigator.jspa?mode=hide&requestId=12312392
---
Jim Kellerman, Senior Engineer; Powerset
RE: Naming patches
Posted by Jim Kellerman <ji...@powerset.com>.
Added patch name conventions to http://wiki.apache.org/hadoop/Hbase/HowToContribute
Also incorporated Stack's suggestions:
Patch names should use the following convention:
<jira_number>[<hbase_version_patch_applies_to>].patch
The jira_number is required. hbase_version_patch_applies_to is optional in two cases:
1. The patch is for trunk
2. The Jira only fixes one version
---
Jim Kellerman, Senior Engineer; Powerset
> -----Original Message-----
> From: stack [mailto:stack@duboce.net]
> Sent: Tuesday, July 29, 2008 9:18 PM
> To: hbase-dev@hadoop.apache.org
> Subject: Re: Naming patches
>
> Would suggest you add below to our 'how to contribute'.
>
> Other comments inline:
>
> Jim Kellerman wrote:
> > Several people, myself included, have become confused
> trying to decide which patch to test for an issue when
> multiple versions of the patch have been uploaded to Jira and
> each patch has a different name.
> >
> > Please try to follow the following naming conventions when
> uploading a patch:
> > hbase-<version_patch_applies_to>-<jira_number>.patch
> >
> >
> IMO, in above, 'hbase' is redundant so why not make it
> optional? If absent, the 'version patch applies to' can't it
> assumed to be trunk?
> JIRA number, I agree should be required.
> > For example the latest patch for HBASE-766 would be named:
> > hbase-0.2.0-766.patch
> >
> > If there is a subsequent revision to a patch, please name
> it the same thing. Jira will show the most recent one at the
> top of the list.
> >
> >
> IMO this is confusing (Do I pull from the top or from the
> bottom of the list of patches?). I like adding version to
> patch name. Something like v2, v3, etc.
>
> St.Ack
> > Finally, if you want your patch reviewed, mark the Jira
> issue as patch available. Then it will show up in the patch
> review queue:
> >
> >
> https://issues.apache.org/jira/secure/IssueNavigator.jspa?mode=hide&re
> > questId=12312392
> >
> > ---
> > Jim Kellerman, Senior Engineer; Powerset
> >
>
>
> No virus found in this incoming message.
> Checked by AVG - http://www.avg.com
> Version: 8.0.138 / Virus Database: 270.5.6/1577 - Release
> Date: 7/28/2008 6:55 AM
>
Re: Naming patches
Posted by stack <st...@duboce.net>.
Would suggest you add below to our 'how to contribute'.
Other comments inline:
Jim Kellerman wrote:
> Several people, myself included, have become confused trying to decide which patch to test for an issue when multiple versions of the patch have been uploaded to Jira and each patch has a different name.
>
> Please try to follow the following naming conventions when uploading a patch:
> hbase-<version_patch_applies_to>-<jira_number>.patch
>
>
IMO, in above, 'hbase' is redundant so why not make it optional? If
absent, the 'version patch applies to' can't it assumed to be trunk?
JIRA number, I agree should be required.
> For example the latest patch for HBASE-766 would be named:
> hbase-0.2.0-766.patch
>
> If there is a subsequent revision to a patch, please name it the same thing. Jira will show the most recent one at the top of the list.
>
>
IMO this is confusing (Do I pull from the top or from the bottom of the
list of patches?). I like adding version to patch name. Something like
v2, v3, etc.
St.Ack
> Finally, if you want your patch reviewed, mark the Jira issue as patch available. Then it will show up in the patch review queue:
>
> https://issues.apache.org/jira/secure/IssueNavigator.jspa?mode=hide&requestId=12312392
>
> ---
> Jim Kellerman, Senior Engineer; Powerset
>