You are viewing a plain text version of this content. The canonical link for it is here.
Posted to yarn-issues@hadoop.apache.org by "Kai Sasaki (JIRA)" <ji...@apache.org> on 2016/02/14 07:25:18 UTC
[jira] [Updated] (YARN-4689) FairScheduler: Cleanup
preemptContainer to be more readable
[ https://issues.apache.org/jira/browse/YARN-4689?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Kai Sasaki updated YARN-4689:
-----------------------------
Attachment: YARN-4689.01.patch
> FairScheduler: Cleanup preemptContainer to be more readable
> -----------------------------------------------------------
>
> Key: YARN-4689
> URL: https://issues.apache.org/jira/browse/YARN-4689
> Project: Hadoop YARN
> Issue Type: Bug
> Components: fairscheduler
> Reporter: Karthik Kambatla
> Priority: Trivial
> Labels: newbie
> Attachments: YARN-4689.01.patch
>
>
> In FairScheduler#preemptContainer, we check if a queue is preemptable. The code there could be cleaner if we don't use continue, but just the plain old if-else.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)