You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@hbase.apache.org by "Todd Lipcon (JIRA)" <ji...@apache.org> on 2011/08/18 23:20:27 UTC
[jira] [Commented] (HBASE-4226) HFileBlock.java style cleanup.
[ https://issues.apache.org/jira/browse/HBASE-4226?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13087298#comment-13087298 ]
Todd Lipcon commented on HBASE-4226:
------------------------------------
A lot of these changes actually make it harder to read. I'm all for fixing places where we have incorrect style (eg braces on the wrong line) but I don't think it's worth rewrapping existing code that fits the style guidelines. (eg a lot of the javadoc changes are just re-justifying)
some examples:
- if (uncompressedSizeWithoutHeader !=
- uncompressedBytesWithHeader.length - HEADER_SIZE) {
+ if (uncompressedSizeWithoutHeader != uncompressedBytesWithHeader.length
+ - HEADER_SIZE) {
(harder to read after)
- InputStream bufferedBoundedStream = createBufferedBoundedStream(
- offset, onDiskSize, pread);
+ InputStream bufferedBoundedStream = createBufferedBoundedStream(offset,
+ onDiskSize, pread);
IMO I think the original was better
- ByteBuffer headerBuf = prefetchedHeader.offset == offset ?
- prefetchedHeader.buf : null;
+ ByteBuffer headerBuf = prefetchedHeader.offset == offset ? prefetchedHeader.buf
+ : null;
same
> HFileBlock.java style cleanup.
> ------------------------------
>
> Key: HBASE-4226
> URL: https://issues.apache.org/jira/browse/HBASE-4226
> Project: HBase
> Issue Type: Improvement
> Reporter: Li Pi
> Assignee: Li Pi
> Priority: Trivial
> Attachments: hbase-4226.diff
>
>
> Just a simple style cleanup of HFileBlock.java.
--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira