You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "Konstantin Knauf (Jira)" <ji...@apache.org> on 2021/07/29 07:36:11 UTC
[jira] [Updated] (FLINK-13200) Improve the generated code for if
statements
[ https://issues.apache.org/jira/browse/FLINK-13200?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Konstantin Knauf updated FLINK-13200:
-------------------------------------
Labels: pull-request-available stale-assigned (was: auto-closed pull-request-available stale-assigned)
Priority: Not a Priority (was: Minor)
> Improve the generated code for if statements
> --------------------------------------------
>
> Key: FLINK-13200
> URL: https://issues.apache.org/jira/browse/FLINK-13200
> Project: Flink
> Issue Type: Improvement
> Components: Table SQL / Runtime
> Reporter: Liya Fan
> Assignee: Liya Fan
> Priority: Not a Priority
> Labels: pull-request-available, stale-assigned
> Time Spent: 10m
> Remaining Estimate: 0h
>
> In the generated code, we often code snippet like this:
>
> if (true) {
> acc$6.setNullAt(1);
> } else {
> acc$6.setField(1, ((int) -1));;
> }
> Such code impacts the code readability, and increases the code size, making it more costly for compiling and transferring through network.
>
> In this issue, we remove such useless if conditions.
--
This message was sent by Atlassian Jira
(v8.3.4#803005)