You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@nifi.apache.org by "Daniel Stieglitz (Jira)" <ji...@apache.org> on 2025/11/21 19:29:00 UTC

[jira] [Updated] (NIFI-15242) Remove redundant name and display name in the VAULT_URI property descriptor found in HashiCorpVaultClientService and revert renaming of all vault related properties

     [ https://issues.apache.org/jira/browse/NIFI-15242?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Daniel Stieglitz updated NIFI-15242:
------------------------------------
    Summary: Remove redundant name and display name in the VAULT_URI property descriptor found in HashiCorpVaultClientService and revert renaming of all vault related properties  (was: Remove redundant name and display name in the VAULT_URI property descriptor found in HashiCorpVaultClientService)

> Remove redundant name and display name in the VAULT_URI property descriptor found in HashiCorpVaultClientService and revert renaming of all vault related properties
> --------------------------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: NIFI-15242
>                 URL: https://issues.apache.org/jira/browse/NIFI-15242
>             Project: Apache NiFi
>          Issue Type: Bug
>            Reporter: Daniel Stieglitz
>            Assignee: Daniel Stieglitz
>            Priority: Minor
>             Fix For: 2.7.0
>
>          Time Spent: 40m
>  Remaining Estimate: 0h
>
> Currently the property descriptor has 
> {code:java}
> PropertyDescriptor VAULT_URI = new PropertyDescriptor.Builder()
>             .name("Vault URI")
>             .name("vault.uri")
>             .displayName("Vault URI"){code}
> and it should look like
> {code:java}
> PropertyDescriptor VAULT_URI = new PropertyDescriptor.Builder()             
>             .name("vault.uri")
>             .displayName("Vault URI"){code}
> in addition this line in the migrateProperties method should be removed as it is unnecessary (since its redundant):
> {code:java}
> config.renameProperty("vault.uri", VAULT_URI.getName());{code}



--
This message was sent by Atlassian Jira
(v8.20.10#820010)