You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@tinkerpop.apache.org by "Stephen Mallette (Jira)" <ji...@apache.org> on 2020/11/26 12:06:00 UTC

[jira] [Created] (TINKERPOP-2481) IdentityRemovalStrategy not installed

Stephen Mallette created TINKERPOP-2481:
-------------------------------------------

             Summary: IdentityRemovalStrategy not installed
                 Key: TINKERPOP-2481
                 URL: https://issues.apache.org/jira/browse/TINKERPOP-2481
             Project: TinkerPop
          Issue Type: Improvement
          Components: process
    Affects Versions: 3.4.8
            Reporter: Stephen Mallette


I'm not sure why but {{IdentityRemovalStrategy}} is not in play and almost looks like it never has been, yet I fairly certain we've gone about life thinking it was one of our standard strategies. Perhaps this issue title will shift once this is given more thought but I came to [notice this issue|https://groups.google.com/g/gremlin-users/c/HVtldzV0Xk8/m/saCBYsEQBgAJ] with this example:

{code}
gremlin> g.V().match(__.as("a").out("knows").as("b")).identity()
==>[]
==>[]
gremlin> g.withStrategies(IdentityRemovalStrategy.instance()).V().match(__.as("a").out("knows").as("b")).identity()
==>[a:v[1],b:v[2]]
==>[a:v[1],b:v[4]]
{code}

So if the strategy had been in play, {{PathRetractionStrategy}} wouldn't have trimmed the history. Or, perhaps {{PathRetractionStrategy}} should have been smarter....



--
This message was sent by Atlassian Jira
(v8.3.4#803005)