You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@commons.apache.org by gg...@apache.org on 2024/06/16 15:41:25 UTC
(commons-net) branch master updated (2208f032 -> 58c36f92)
This is an automated email from the ASF dual-hosted git repository.
ggregory pushed a change to branch master
in repository https://gitbox.apache.org/repos/asf/commons-net.git
from 2208f032 Javadoc
new 26b18bba Rename parameter to 'ignored' for PMD UnusedFormalParameter
new 13d1d365 Use an import instead of FQCN
new 0253a27b Rename parameter to 'ignored' for PMD UnusedFormalParameter
new 39d751cc Rename parameter to 'ignored' for PMD UnusedFormalParameter
new 743028e3 Rename parameter to 'ignored' for PMD UnusedFormalParameter
new 58c36f92 Fix PMD CollapsibleIfStatements in TelnetInputStream
The 6 revisions listed above as "new" are entirely new to this
repository and will be described in separate emails. The revisions
listed as "add" were already present in the repository and have only
been added to this reference.
Summary of changes:
src/main/java/org/apache/commons/net/ProtocolCommandSupport.java | 4 ++--
src/main/java/org/apache/commons/net/ftp/FTPFile.java | 6 ++++--
src/main/java/org/apache/commons/net/ntp/TimeStamp.java | 6 ++++--
src/main/java/org/apache/commons/net/telnet/TelnetInputStream.java | 7 +++----
src/main/java/org/apache/commons/net/util/ListenerList.java | 4 ++--
5 files changed, 15 insertions(+), 12 deletions(-)
(commons-net) 04/06: Rename parameter to 'ignored' for PMD UnusedFormalParameter
Posted by gg...@apache.org.
This is an automated email from the ASF dual-hosted git repository.
ggregory pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/commons-net.git
commit 39d751ccab0171db8f3274141cfb3eb425491613
Author: Gary Gregory <ga...@gmail.com>
AuthorDate: Sun Jun 16 11:26:13 2024 -0400
Rename parameter to 'ignored' for PMD UnusedFormalParameter
Use an import instead of FQCN
---
src/main/java/org/apache/commons/net/ntp/TimeStamp.java | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/src/main/java/org/apache/commons/net/ntp/TimeStamp.java b/src/main/java/org/apache/commons/net/ntp/TimeStamp.java
index 786e55b2..46275ed6 100644
--- a/src/main/java/org/apache/commons/net/ntp/TimeStamp.java
+++ b/src/main/java/org/apache/commons/net/ntp/TimeStamp.java
@@ -17,6 +17,8 @@
package org.apache.commons.net.ntp;
+import java.io.ObjectInputStream;
+import java.io.ObjectOutputStream;
import java.io.Serializable;
import java.text.DateFormat;
import java.text.SimpleDateFormat;
@@ -342,7 +344,7 @@ public class TimeStamp implements Serializable, Comparable<TimeStamp> {
return ntpTime;
}
- private void readObject(final java.io.ObjectInputStream in) {
+ private void readObject(final ObjectInputStream ignored) {
throw new UnsupportedOperationException("Serialization is not supported");
}
@@ -401,7 +403,7 @@ public class TimeStamp implements Serializable, Comparable<TimeStamp> {
return utcFormatter.format(ntpDate);
}
- private void writeObject(final java.io.ObjectOutputStream out) {
+ private void writeObject(final ObjectOutputStream ignored) {
throw new UnsupportedOperationException("Serialization is not supported");
}
(commons-net) 05/06: Rename parameter to 'ignored' for PMD UnusedFormalParameter
Posted by gg...@apache.org.
This is an automated email from the ASF dual-hosted git repository.
ggregory pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/commons-net.git
commit 743028e3b536bf619940ff41f2c1658c7775c457
Author: Gary Gregory <ga...@gmail.com>
AuthorDate: Sun Jun 16 11:26:39 2024 -0400
Rename parameter to 'ignored' for PMD UnusedFormalParameter
Use an import instead of FQCN
---
src/main/java/org/apache/commons/net/util/ListenerList.java | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/main/java/org/apache/commons/net/util/ListenerList.java b/src/main/java/org/apache/commons/net/util/ListenerList.java
index 15927975..96cc3e4d 100644
--- a/src/main/java/org/apache/commons/net/util/ListenerList.java
+++ b/src/main/java/org/apache/commons/net/util/ListenerList.java
@@ -55,7 +55,7 @@ public class ListenerList implements Serializable, Iterable<EventListener> {
return listeners.iterator();
}
- private void readObject(final ObjectInputStream in) {
+ private void readObject(final ObjectInputStream ignored) {
throw new UnsupportedOperationException("Serialization is not supported");
}
@@ -67,7 +67,7 @@ public class ListenerList implements Serializable, Iterable<EventListener> {
listeners.remove(listener);
}
- private void writeObject(final ObjectOutputStream out) {
+ private void writeObject(final ObjectOutputStream ignored) {
throw new UnsupportedOperationException("Serialization is not supported");
}
(commons-net) 03/06: Rename parameter to 'ignored' for PMD UnusedFormalParameter
Posted by gg...@apache.org.
This is an automated email from the ASF dual-hosted git repository.
ggregory pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/commons-net.git
commit 0253a27b26a0c68d9723be85c8d5f35487a8b83d
Author: Gary Gregory <ga...@gmail.com>
AuthorDate: Sun Jun 16 11:25:24 2024 -0400
Rename parameter to 'ignored' for PMD UnusedFormalParameter
---
src/main/java/org/apache/commons/net/ftp/FTPFile.java | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/src/main/java/org/apache/commons/net/ftp/FTPFile.java b/src/main/java/org/apache/commons/net/ftp/FTPFile.java
index 19d55634..9a3a0940 100644
--- a/src/main/java/org/apache/commons/net/ftp/FTPFile.java
+++ b/src/main/java/org/apache/commons/net/ftp/FTPFile.java
@@ -18,6 +18,7 @@
package org.apache.commons.net.ftp;
import java.io.ObjectInputStream;
+import java.io.ObjectOutputStream;
import java.io.Serializable;
import java.time.Instant;
import java.util.Calendar;
@@ -290,7 +291,7 @@ public class FTPFile implements Serializable {
return sb.toString();
}
- private void readObject(final ObjectInputStream in) {
+ private void readObject(final ObjectInputStream ignored) {
throw new UnsupportedOperationException("Serialization is not supported");
}
@@ -477,7 +478,7 @@ public class FTPFile implements Serializable {
return getRawListing();
}
- private void writeObject(final java.io.ObjectOutputStream out) {
+ private void writeObject(final ObjectOutputStream out) {
throw new UnsupportedOperationException("Serialization is not supported");
}
(commons-net) 01/06: Rename parameter to 'ignored' for PMD UnusedFormalParameter
Posted by gg...@apache.org.
This is an automated email from the ASF dual-hosted git repository.
ggregory pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/commons-net.git
commit 26b18bba48c0135694b8b7f19e3cc3660625556b
Author: Gary Gregory <ga...@gmail.com>
AuthorDate: Sun Jun 16 11:23:36 2024 -0400
Rename parameter to 'ignored' for PMD UnusedFormalParameter
---
src/main/java/org/apache/commons/net/ProtocolCommandSupport.java | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/main/java/org/apache/commons/net/ProtocolCommandSupport.java b/src/main/java/org/apache/commons/net/ProtocolCommandSupport.java
index 073533de..6d1dd30e 100644
--- a/src/main/java/org/apache/commons/net/ProtocolCommandSupport.java
+++ b/src/main/java/org/apache/commons/net/ProtocolCommandSupport.java
@@ -102,7 +102,7 @@ public class ProtocolCommandSupport implements Serializable {
return listeners.getListenerCount();
}
- private void readObject(final ObjectInputStream in) {
+ private void readObject(final ObjectInputStream ignored) {
throw new UnsupportedOperationException("Serialization is not supported");
}
@@ -119,7 +119,7 @@ public class ProtocolCommandSupport implements Serializable {
listeners.removeListener(listener);
}
- private void writeObject(final ObjectOutputStream out) {
+ private void writeObject(final ObjectOutputStream ignored) {
throw new UnsupportedOperationException("Serialization is not supported");
}
(commons-net) 02/06: Use an import instead of FQCN
Posted by gg...@apache.org.
This is an automated email from the ASF dual-hosted git repository.
ggregory pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/commons-net.git
commit 13d1d3657a2e9ae4d159737f7d63555aba1902f1
Author: Gary Gregory <ga...@gmail.com>
AuthorDate: Sun Jun 16 11:24:59 2024 -0400
Use an import instead of FQCN
---
src/main/java/org/apache/commons/net/ftp/FTPFile.java | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/src/main/java/org/apache/commons/net/ftp/FTPFile.java b/src/main/java/org/apache/commons/net/ftp/FTPFile.java
index 6b4dd968..19d55634 100644
--- a/src/main/java/org/apache/commons/net/ftp/FTPFile.java
+++ b/src/main/java/org/apache/commons/net/ftp/FTPFile.java
@@ -17,6 +17,7 @@
package org.apache.commons.net.ftp;
+import java.io.ObjectInputStream;
import java.io.Serializable;
import java.time.Instant;
import java.util.Calendar;
@@ -289,7 +290,7 @@ public class FTPFile implements Serializable {
return sb.toString();
}
- private void readObject(final java.io.ObjectInputStream in) {
+ private void readObject(final ObjectInputStream in) {
throw new UnsupportedOperationException("Serialization is not supported");
}
(commons-net) 06/06: Fix PMD CollapsibleIfStatements in TelnetInputStream
Posted by gg...@apache.org.
This is an automated email from the ASF dual-hosted git repository.
ggregory pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/commons-net.git
commit 58c36f92826c4a094fdd09348cf9075e721d2dc0
Author: Gary Gregory <ga...@gmail.com>
AuthorDate: Sun Jun 16 11:41:19 2024 -0400
Fix PMD CollapsibleIfStatements in TelnetInputStream
---
src/main/java/org/apache/commons/net/telnet/TelnetInputStream.java | 7 +++----
1 file changed, 3 insertions(+), 4 deletions(-)
diff --git a/src/main/java/org/apache/commons/net/telnet/TelnetInputStream.java b/src/main/java/org/apache/commons/net/telnet/TelnetInputStream.java
index 7656528e..372e66a5 100644
--- a/src/main/java/org/apache/commons/net/telnet/TelnetInputStream.java
+++ b/src/main/java/org/apache/commons/net/telnet/TelnetInputStream.java
@@ -196,10 +196,9 @@ final class TelnetInputStream extends BufferedInputStream implements Runnable {
do {
try {
- if ((ch = read(mayBlock)) < 0) { // must be EOF
- if (ch != WOULD_BLOCK) {
- return ch;
- }
+ if ((ch = read(mayBlock)) < 0 && ch != WOULD_BLOCK) {
+ // must be EOF
+ return ch;
}
} catch (final InterruptedIOException e) {
synchronized (queue) {