You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@forrest.apache.org by "Ross Gardler (JIRA)" <ji...@apache.org> on 2005/11/21 03:41:26 UTC
[jira] Created: (FOR-734) Document new forrest.properties.xml file
Document new forrest.properties.xml file
----------------------------------------
Key: FOR-734
URL: http://issues.apache.org/jira/browse/FOR-734
Project: Forrest
Type: Sub-task
Components: Documentation and website, Core operations
Versions: 0.8-dev
Reporter: Ross Gardler
Priority: Minor
Documentation for this issue should include:
- details gleaned from FOR-888
- an entry in status.xml
- notes in plugins docs
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
http://www.atlassian.com/software/jira
[jira] Updated: (FOR-734) Document new forrest.properties.xml file
Posted by "Ross Gardler (JIRA)" <ji...@apache.org>.
[ http://issues.apache.org/jira/browse/FOR-734?page=all ]
Ross Gardler updated FOR-734:
-----------------------------
Description:
Documentation for this issue should include:
- details gleaned from FOR-588
- an entry in status.xml
- notes in plugins docs
was:
Documentation for this issue should include:
- details gleaned from FOR-888
- an entry in status.xml
- notes in plugins docs
> Document new forrest.properties.xml file
> ----------------------------------------
>
> Key: FOR-734
> URL: http://issues.apache.org/jira/browse/FOR-734
> Project: Forrest
> Type: Sub-task
> Components: Documentation and website, Core operations
> Versions: 0.8-dev
> Reporter: Ross Gardler
> Priority: Minor
>
> Documentation for this issue should include:
> - details gleaned from FOR-588
> - an entry in status.xml
> - notes in plugins docs
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
http://www.atlassian.com/software/jira
[jira] Commented: (FOR-734) Document new forrest.properties.xml
file
Posted by "Ross Gardler (JIRA)" <ji...@apache.org>.
[ http://issues.apache.org/jira/browse/FOR-734?page=comments#action_12369183 ]
Ross Gardler commented on FOR-734:
----------------------------------
See description of how to parameterise plugins using forrest.properties.xml in http://marc.theaimsgroup.com/?l=forrest-dev&m=114170683324461&w=2
> Document new forrest.properties.xml file
> ----------------------------------------
>
> Key: FOR-734
> URL: http://issues.apache.org/jira/browse/FOR-734
> Project: Forrest
> Type: Sub-task
> Components: Documentation and website, Core operations
> Versions: 0.8-dev
> Reporter: Ross Gardler
> Priority: Minor
>
> Documentation for this issue should include:
> - details gleaned from FOR-888
> - an entry in status.xml
> - notes in plugins docs
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
http://www.atlassian.com/software/jira
[jira] Issue Comment Edited: (FOR-734) Document new
forrest.properties.xml file
Posted by "Ross Gardler (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/FOR-734?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12358266#action_12358266 ]
rgardler edited comment on FOR-734 at 7/5/08 1:39 PM:
----------------------------------------------------------
Naming Convention
================
The naming convention for properties is as follows:
COMPONENT.PROPERTY[.TYPE]
where:
COMPONENT is one of:
- 'core' for a core property exposed by Forrest
- the name of a project that exposes the property
- the name of the plugin that exposes the property (when it is a plugin it shoudl be of the form output.pdf or input.html or similar)
PROPERTY is a human readable name for the property
TYPE is an optional indicator of the type of property value. It does not restrict the values the property can accept and is only intended as an aid to the humans reading the property name.
was (Author: rgardler):
Naming Convention
================
The naming convention for properties is as follows:
COMPONENT.PROPERTY[.TYPE]
where:
COMPONENT is one of:
- 'core' for a core property exposed by Forrest
- the name of a project that exposes the property
- the name of the plugin that exposes the property
PROPERTY is a human readable name for the property
TYPE is an optional indicator of the type of property value. It does not restrict the values the property can accept and is only intended as an aid to the humans reading the property name.
> Document new forrest.properties.xml file
> ----------------------------------------
>
> Key: FOR-734
> URL: https://issues.apache.org/jira/browse/FOR-734
> Project: Forrest
> Issue Type: Sub-task
> Components: Core operations, Documentation and website
> Affects Versions: 0.8
> Reporter: Ross Gardler
> Priority: Minor
>
> Documentation for this issue should include:
> - details gleaned from FOR-588
> - an entry in status.xml
> - notes in plugins docs
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Commented: (FOR-734) Document new forrest.properties.xml file
Posted by "Ross Gardler (JIRA)" <ji...@apache.org>.
[ http://issues.apache.org/jira/browse/FOR-734?page=comments#action_12358266 ]
Ross Gardler commented on FOR-734:
----------------------------------
Naming Convention
================
The naming convention for properties is as follows:
COMPONENT.PROPERTY[.TYPE]
where:
COMPONENT is one of:
- 'core' for a core property exposed by Forrest
- the name of a project that exposes the property
- the name of the plugin that exposes the property
PROPERTY is a human readable name for the property
TYPE is an optional indicator of the type of property value. It does not restrict the values the property can accept and is only intended as an aid to the humans reading the property name.
> Document new forrest.properties.xml file
> ----------------------------------------
>
> Key: FOR-734
> URL: http://issues.apache.org/jira/browse/FOR-734
> Project: Forrest
> Type: Sub-task
> Components: Documentation and website, Core operations
> Versions: 0.8-dev
> Reporter: Ross Gardler
> Priority: Minor
>
> Documentation for this issue should include:
> - details gleaned from FOR-888
> - an entry in status.xml
> - notes in plugins docs
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
http://www.atlassian.com/software/jira