You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@phoenix.apache.org by "Ranganath Govardhanagiri (Jira)" <ji...@apache.org> on 2024/05/31 06:13:00 UTC

[jira] [Updated] (PHOENIX-7321) Rename PhoenixIndexBuilderHelper to something different as it seems to handle only onDupKey logic

     [ https://issues.apache.org/jira/browse/PHOENIX-7321?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Ranganath Govardhanagiri updated PHOENIX-7321:
----------------------------------------------
    Summary: Rename PhoenixIndexBuilderHelper to something different as it seems to handle only onDupKey logic  (was: Rename PhoenixIndexBuilderHelper to something different as it seems handle only onDupKey only)

> Rename PhoenixIndexBuilderHelper to something different as it seems to handle only onDupKey logic
> -------------------------------------------------------------------------------------------------
>
>                 Key: PHOENIX-7321
>                 URL: https://issues.apache.org/jira/browse/PHOENIX-7321
>             Project: Phoenix
>          Issue Type: Task
>          Components: core
>            Reporter: Ranganath Govardhanagiri
>            Assignee: Ranganath Govardhanagiri
>            Priority: Minor
>             Fix For: 5.3.0
>
>
> While looking at [PhoenixIndexBuilderHelper|[phoenix/phoenix-core-client/src/main/java/org/apache/phoenix/index/PhoenixIndexBuilderHelper.java at master ยท apache/phoenix (github.com)|https://github.com/apache/phoenix/blob/master/phoenix-core-client/src/main/java/org/apache/phoenix/index/PhoenixIndexBuilderHelper.java]] I see the class only deals with On Duplicate Key related functionality. May be we need to rename this to OnDuplicateKeyHelper or something of that sort as it currently doesn't deal with any Index help.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)