You are viewing a plain text version of this content. The canonical link for it is here.
Posted to mapreduce-issues@hadoop.apache.org by "Robert Joseph Evans (JIRA)" <ji...@apache.org> on 2011/08/24 22:54:30 UTC

[jira] [Updated] (MAPREDUCE-2864) Renaming of configuration property names in yarn

     [ https://issues.apache.org/jira/browse/MAPREDUCE-2864?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Robert Joseph Evans updated MAPREDUCE-2864:
-------------------------------------------

    Attachment: yarnConfigs.csv

Attached is a CSV file containing the changes to the configs that I would like to make.  I am going to start making a patch for these changes, but I would like a review or comments on the config changes as I work on the patch to try and speed things up.

> Renaming of configuration property names in yarn
> ------------------------------------------------
>
>                 Key: MAPREDUCE-2864
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-2864
>             Project: Hadoop Map/Reduce
>          Issue Type: Improvement
>          Components: jobhistoryserver, mrv2, nodemanager, resourcemanager
>    Affects Versions: 0.23.0
>            Reporter: Robert Joseph Evans
>            Assignee: Robert Joseph Evans
>             Fix For: 0.23.0
>
>         Attachments: yarnConfigs.csv
>
>
> Now that YARN has been put in to trunk we should do something similar to MAPREDUCE-849.  We should go back and look at all of the configurations that have been added in and rename them as needed to be consistent and subdivided by component.
> # We should use all lowercase in the config names. e.g., we should use appsmanager instead of appsManager etc.
> # history server config names should be prefixed with mapreduce instead of yarn.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira