You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@bookkeeper.apache.org by "Ivan Kelly (JIRA)" <ji...@apache.org> on 2014/05/28 12:35:02 UTC

[jira] [Comment Edited] (BOOKKEEPER-634) Provide admin tool to change bookie's identifier from IP to hostname

    [ https://issues.apache.org/jira/browse/BOOKKEEPER-634?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14010999#comment-14010999 ] 

Ivan Kelly edited comment on BOOKKEEPER-634 at 5/28/14 10:34 AM:
-----------------------------------------------------------------

1. The patch contains superfluous import movement. This is noise. 
2. metaupdate is too generic as a name. It should be something like rename-bookie-in-ledgers.
3. I wouldn't make updateMetadata iterate over all ledgers. Rather, I would have it take a ledger id, and do one ledger at a time (asynchronously so many can be done at a time). Also, the operation should be renamed to #renameBookieInLedger(long ledgerId, BookieSocketAddress from, BookieSocketAddress to, GenericCallback<Void> cb). BookieShell can then print progress information as ledgers are updated.

bq. I think writing clients will not get impacted because nowhere its comparing the bookieIds(ipaddress/hostname). I have checked LedgerMetadata#isConflictWith() implementation. Please 
point me if anything missing.
This is something that can be tested, so it should be tested.


was (Author: ikelly):
1. The patch contains superfluous import movement. This is noise. 
2. metaupdate is too generic as a name. It should be something like rename-bookie-in-ledgers.
3. I wouldn't make updateMetadata iterate over all ledgers. Rather, I would have it take a ledger id, and do one ledger at a time (asynchronously so many can be done at a time). Also, the operation should be renamed to #renameBookieInLedger(long ledgerId, BookieSocketAddress from, BookieSocketAddress to, GenericCallback<Void> cb). BookieShell can then print progress information as ledgers are updated.

> I think writing clients will not get impacted because nowhere its comparing the bookieIds(ipaddress/hostname). I have checked LedgerMetadata#isConflictWith() implementation. Please 
point me if anything missing.
This is something that can be tested, so it should be tested.

> Provide admin tool to change bookie's identifier from IP to hostname
> --------------------------------------------------------------------
>
>                 Key: BOOKKEEPER-634
>                 URL: https://issues.apache.org/jira/browse/BOOKKEEPER-634
>             Project: Bookkeeper
>          Issue Type: Sub-task
>          Components: bookkeeper-client, bookkeeper-server
>    Affects Versions: 4.2.1
>            Reporter: Rakesh R
>            Assignee: Rakesh R
>             Fix For: 4.3.0
>
>         Attachments: 0001-BOOKKEEPER-634-initial-draft-version.patch
>
>
> This JIRA to discuss about admin tool for changing the bookie's IP to hostname.



--
This message was sent by Atlassian JIRA
(v6.2#6252)