You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@camel.apache.org by "Alexis Kinsella (JIRA)" <ji...@apache.org> on 2012/06/18 14:39:42 UTC

[jira] [Created] (CAMEL-5376) Mail component disconnect in the wrong way

Alexis Kinsella created CAMEL-5376:
--------------------------------------

             Summary: Mail component disconnect in the wrong way
                 Key: CAMEL-5376
                 URL: https://issues.apache.org/jira/browse/CAMEL-5376
             Project: Camel
          Issue Type: Bug
          Components: camel-mail
    Affects Versions: 2.9.1
         Environment: Outlook 2010, but should happen with any mail server, since it is not directly related to (See above)
            Reporter: Alexis Kinsella


The way disconnect is implemented causes issues with some other options of the consumer. For instance "disconnect" option is not compatible with "delete" option.

The delete action is done in completion action (processCommit: line 185). On line 305, processCommit method checks if folder is open, but "disconnect" option force folder at null value at the end of poll method (Line 149).

I guess disconnect method should be called on completion after any other completion actions occured: It is not possible to make completion actions if connection to mail server is closed.

The result of the usage of disconnect option and delete option is a NullPointerException on test: "if (!folder.isOpen())" statement on line 308.

Issue should be always reproductible.

I let you fix the priority of the issue, but it is an annoying issue even if there is a workaround by disabling disconnect option ...

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (CAMEL-5376) Mail component disconnect in the wrong way

Posted by "Claus Ibsen (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/CAMEL-5376?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13396521#comment-13396521 ] 

Claus Ibsen commented on CAMEL-5376:
------------------------------------

Can you post more details, such as the route you use? And the stacktrace as well.
                
> Mail component disconnect in the wrong way
> ------------------------------------------
>
>                 Key: CAMEL-5376
>                 URL: https://issues.apache.org/jira/browse/CAMEL-5376
>             Project: Camel
>          Issue Type: Bug
>          Components: camel-mail
>    Affects Versions: 2.9.1
>         Environment: Outlook 2010, but should happen with any mail server, since it is not directly related to (See above)
>            Reporter: Alexis Kinsella
>
> The way disconnect is implemented causes issues with some other options of the consumer. For instance "disconnect" option is not compatible with "delete" option.
> The delete action is done in completion action (processCommit: line 185). On line 305, processCommit method checks if folder is open, but "disconnect" option force folder at null value at the end of poll method (Line 149).
> I guess disconnect method should be called on completion after any other completion actions occured: It is not possible to make completion actions if connection to mail server is closed.
> The result of the usage of disconnect option and delete option is a NullPointerException on test: "if (!folder.isOpen())" statement on line 308.
> Issue should be always reproductible.
> I let you fix the priority of the issue, but it is an annoying issue even if there is a workaround by disabling disconnect option ...

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (CAMEL-5376) Mail component disconnect in the wrong way

Posted by "Alexis Kinsella (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/CAMEL-5376?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13400131#comment-13400131 ] 

Alexis Kinsella commented on CAMEL-5376:
----------------------------------------

Hello, I will have some time this week to provide some basic example for this issue. In the meantime, I found some workaround by avoiding disconnection from mail server.
                
> Mail component disconnect in the wrong way
> ------------------------------------------
>
>                 Key: CAMEL-5376
>                 URL: https://issues.apache.org/jira/browse/CAMEL-5376
>             Project: Camel
>          Issue Type: Bug
>          Components: camel-mail
>    Affects Versions: 2.9.1
>         Environment: Outlook 2010, but should happen with any mail server, since it is not directly related to (See above)
>            Reporter: Alexis Kinsella
>
> The way disconnect is implemented causes issues with some other options of the consumer. For instance "disconnect" option is not compatible with "delete" option.
> The delete action is done in completion action (processCommit: line 185). On line 305, processCommit method checks if folder is open, but "disconnect" option force folder at null value at the end of poll method (Line 149).
> I guess disconnect method should be called on completion after any other completion actions occured: It is not possible to make completion actions if connection to mail server is closed.
> The result of the usage of disconnect option and delete option is a NullPointerException on test: "if (!folder.isOpen())" statement on line 308.
> Issue should be always reproductible.
> I let you fix the priority of the issue, but it is an annoying issue even if there is a workaround by disabling disconnect option ...

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (CAMEL-5376) Mail component disconnect in the wrong way

Posted by "Claus Ibsen (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/CAMEL-5376?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13400123#comment-13400123 ] 

Claus Ibsen commented on CAMEL-5376:
------------------------------------

Alexis, any update on this, so we can help you?
                
> Mail component disconnect in the wrong way
> ------------------------------------------
>
>                 Key: CAMEL-5376
>                 URL: https://issues.apache.org/jira/browse/CAMEL-5376
>             Project: Camel
>          Issue Type: Bug
>          Components: camel-mail
>    Affects Versions: 2.9.1
>         Environment: Outlook 2010, but should happen with any mail server, since it is not directly related to (See above)
>            Reporter: Alexis Kinsella
>
> The way disconnect is implemented causes issues with some other options of the consumer. For instance "disconnect" option is not compatible with "delete" option.
> The delete action is done in completion action (processCommit: line 185). On line 305, processCommit method checks if folder is open, but "disconnect" option force folder at null value at the end of poll method (Line 149).
> I guess disconnect method should be called on completion after any other completion actions occured: It is not possible to make completion actions if connection to mail server is closed.
> The result of the usage of disconnect option and delete option is a NullPointerException on test: "if (!folder.isOpen())" statement on line 308.
> Issue should be always reproductible.
> I let you fix the priority of the issue, but it is an annoying issue even if there is a workaround by disabling disconnect option ...

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira