You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@ambari.apache.org by Dmitro Lisnichenko <dl...@hortonworks.com> on 2014/06/05 16:03:24 UTC
Review Request 22264: structured_out should be a JSON object,
not stringified JSON
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/22264/
-----------------------------------------------------------
Review request for Ambari and Vitalyi Brodetskyi.
Bugs: AMBARI-6030
https://issues.apache.org/jira/browse/AMBARI-6030
Repository: ambari
Description
-------
Structured_out attribute from Custom Action API is now a stringified JSON. This should be changed to pure JSON.
Stringified JSON is really hard to read, does not format well, and also there's no reason for the FE to do JSON parse twice (once for the API response and then another to parse structured_out).
We should fix this for 1.6.1 before this becomes permanent.
Diffs
-----
ambari-server/src/main/java/org/apache/ambari/server/controller/internal/TaskResourceProvider.java f0d2c06
ambari-server/src/test/java/org/apache/ambari/server/controller/internal/TaskResourceProviderTest.java 7efd0f3
Diff: https://reviews.apache.org/r/22264/diff/
Testing
-------
mvn clean test
Thanks,
Dmitro Lisnichenko
Re: Review Request 22264: structured_out should be a JSON object,
not stringified JSON
Posted by Vitalyi Brodetskyi <vb...@hortonworks.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/22264/#review44820
-----------------------------------------------------------
Ship it!
Ship It!
- Vitalyi Brodetskyi
On June 5, 2014, 2:03 p.m., Dmitro Lisnichenko wrote:
>
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/22264/
> -----------------------------------------------------------
>
> (Updated June 5, 2014, 2:03 p.m.)
>
>
> Review request for Ambari and Vitalyi Brodetskyi.
>
>
> Bugs: AMBARI-6030
> https://issues.apache.org/jira/browse/AMBARI-6030
>
>
> Repository: ambari
>
>
> Description
> -------
>
> Structured_out attribute from Custom Action API is now a stringified JSON. This should be changed to pure JSON.
> Stringified JSON is really hard to read, does not format well, and also there's no reason for the FE to do JSON parse twice (once for the API response and then another to parse structured_out).
> We should fix this for 1.6.1 before this becomes permanent.
>
>
> Diffs
> -----
>
> ambari-server/src/main/java/org/apache/ambari/server/controller/internal/TaskResourceProvider.java f0d2c06
> ambari-server/src/test/java/org/apache/ambari/server/controller/internal/TaskResourceProviderTest.java 7efd0f3
>
> Diff: https://reviews.apache.org/r/22264/diff/
>
>
> Testing
> -------
>
> mvn clean test
>
>
> Thanks,
>
> Dmitro Lisnichenko
>
>