You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@hc.apache.org by sv...@apache.org on 2024/09/20 15:24:23 UTC
svn commit: r1920810 [3/3] - in /httpcomponents/site: ./ httpcomponents-asyncclient-4.1.x/ httpcomponents-client-4.5.x/ httpcomponents-client-5.3.x/ httpcomponents-client-5.3.x/migration-guide/ httpcomponents-client-5.4.x/ httpcomponents-client-5.4.x/m...
Added: httpcomponents/site/httpcomponents-client-5.4.x/migration-guide/preparation.html
URL: http://svn.apache.org/viewvc/httpcomponents/site/httpcomponents-client-5.4.x/migration-guide/preparation.html?rev=1920810&view=auto
==============================================================================
--- httpcomponents/site/httpcomponents-client-5.4.x/migration-guide/preparation.html (added)
+++ httpcomponents/site/httpcomponents-client-5.4.x/migration-guide/preparation.html Fri Sep 20 15:24:22 2024
@@ -0,0 +1,249 @@
+<!DOCTYPE html>
+<!--
+ | Generated by Apache Maven Doxia Site Renderer 1.11.1 from src/site/markdown/httpcomponents-client-5.4.x/migration-guide/preparation.md
+ | Rendered using Apache Maven Fluido Skin 1.9
+-->
+<html xmlns="http://www.w3.org/1999/xhtml" lang="en">
+ <head>
+ <meta charset="UTF-8" />
+ <meta name="viewport" content="width=device-width, initial-scale=1" />
+ <meta name="generator" content="Apache Maven Doxia Site Renderer 1.11.1" />
+ <title>Apache HttpComponents – Migration from Apache HttpClient 4.x APIs</title>
+ <link rel="stylesheet" href="../../css/apache-maven-fluido-1.9.min.css" />
+ <link rel="stylesheet" href="../../css/site.css" />
+ <link rel="stylesheet" href="../../css/print.css" media="print" />
+ <script src="../../js/apache-maven-fluido-1.9.min.js"></script>
+ </head>
+ <body class="topBarDisabled">
+ <div class="container-fluid">
+ <header>
+ <div id="banner">
+ <div class="pull-left"><a href="https://www.apache.org/" id="bannerLeft"><img src="https://www.apache.org/images/asf_logo_wide.gif" alt="Apache"/></a></div>
+ <div class="pull-right"><a href="../.././" id="bannerRight"><img src="../../images/logos/httpcomponents.png" alt="HttpComponents"/></a></div>
+ <div class="clear"><hr/></div>
+ </div>
+
+ <div id="breadcrumbs">
+ <ul class="breadcrumb">
+ <li id="publishDate">Last Published: 2024-09-20<span class="divider">|</span>
+</li>
+ <li class=""><a href="../../index.html" title="HttpComponents">HttpComponents</a><span class="divider">/</span></li>
+ <li class="active ">Migration from Apache HttpClient 4.x APIs <a href="https://github.com/apache/httpcomponents-website/tree/master/src/site/markdown/httpcomponents-client-5.4.x/migration-guide/preparation.md"><img src="../../images/accessories-text-editor.png" title="Edit" /></a></li>
+ <li class="pull-right"><a href="https://www.apache.org/" class="externalLink" title="Apache">Apache</a></li>
+ </ul>
+ </div>
+ </header>
+ <div class="row-fluid">
+ <header id="leftColumn" class="span2">
+ <nav class="well sidebar-nav">
+ <ul class="nav nav-list">
+ <li class="nav-header">HttpComponents</li>
+ <li><a href="../../index.html" title="Home"><span class="none"></span>Home</a></li>
+ <li><a href="https://www.apache.org/licenses/" class="externalLink" title="License"><span class="none"></span>License</a></li>
+ <li><a href="../../downloads.cgi" title="Download"><span class="none"></span>Download</a></li>
+ <li><a href="../../mail.html" title="Mailing Lists"><span class="none"></span>Mailing Lists</a></li>
+ <li><a href="https://wiki.apache.org/HttpComponents/" class="externalLink" title="Wiki (external)"><span class="none"></span>Wiki (external)</a></li>
+ <li><a href="https://www.apache.org/security/" class="externalLink" title="Security"><span class="none"></span>Security</a></li>
+ <li class="nav-header">Overview</li>
+ <li><a href="../../index.html" title="About"><span class="none"></span>About</a></li>
+ <li><a href="../../news.html" title="News"><span class="none"></span>News</a></li>
+ <li><a href="../../status.html" title="Project Status"><span class="none"></span>Project Status</a></li>
+ <li><a href="../../charter.html" title="Project Charter"><span class="none"></span>Project Charter</a></li>
+ <li><a href="../../get-involved.html" title="Get Involved"><span class="none"></span>Get Involved</a></li>
+ <li class="nav-header">Components</li>
+ <li><a href="../../httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4"><span class="icon-chevron-down"></span>HttpClient 5.4</a>
+ <ul class="nav nav-list">
+ <li><a href="../../httpcomponents-client-5.4.x/quickstart.html" title="Quick Start"><span class="none"></span>Quick Start</a></li>
+ <li><a href="../../httpcomponents-client-5.4.x/migration-guide/index.html" title="Migration Guide"><span class="icon-chevron-down"></span>Migration Guide</a>
+ <ul class="nav nav-list">
+ <li class="active"><a href="#"><span class="none"></span>Preparation</a></li>
+ <li><a href="../../httpcomponents-client-5.4.x/migration-guide/migration-to-classic.html" title="Classic"><span class="none"></span>Classic</a></li>
+ <li><a href="../../httpcomponents-client-5.4.x/migration-guide/migration-to-async-simple.html" title="Async Simple"><span class="none"></span>Async Simple</a></li>
+ <li><a href="../../httpcomponents-client-5.4.x/migration-guide/migration-to-async-streaming.html" title="Async Streaming"><span class="none"></span>Async Streaming</a></li>
+ <li><a href="../../httpcomponents-client-5.4.x/migration-guide/migration-to-async-http2.html" title="Async HTTP/2 only"><span class="none"></span>Async HTTP/2 only</a></li>
+ </ul></li>
+ <li><a href="../../httpcomponents-client-5.4.x/examples.html" title="Examples (Classic)"><span class="none"></span>Examples (Classic)</a></li>
+ <li><a href="../../httpcomponents-client-5.4.x/examples-async.html" title="Examples (Async)"><span class="none"></span>Examples (Async)</a></li>
+ <li><a href="../../httpcomponents-client-5.4.x/examples-reactive.html" title="Examples (Reactive)"><span class="none"></span>Examples (Reactive)</a></li>
+ <li><a href="../../httpcomponents-client-5.4.x/logging.html" title="Logging Guide"><span class="none"></span>Logging Guide</a></li>
+ <li><a href="../../httpcomponents-client-5.4.x/android.html" title="Android"><span class="none"></span>Android</a></li>
+ <li><a href="../../httpcomponents-client-5.4.x/related-projects.html" title="Related"><span class="none"></span>Related</a></li>
+ <li><a href="../../httpcomponents-client-5.4.x/download.html" title="Download"><span class="none"></span>Download</a></li>
+ </ul></li>
+ <li><a href="../../httpcomponents-core-5.3.x/index.html" title="HttpCore 5.3"><span class="icon-chevron-right"></span>HttpCore 5.3</a></li>
+ <li><a href="../../httpcomponents-client-4.5.x/index.html" title="HttpClient 4.5"><span class="icon-chevron-right"></span>HttpClient 4.5</a></li>
+ <li class="nav-header">Legacy</li>
+ <li><a href="../../httpcomponents-asyncclient-4.1.x/index.html" title="HttpAsyncClient 4.1 (EOL)"><span class="icon-chevron-right"></span>HttpAsyncClient 4.1 (EOL)</a></li>
+ <li><a href="../../httpcomponents-core-4.4.x/index.html" title="HttpCore 4.4 (EOL)"><span class="icon-chevron-right"></span>HttpCore 4.4 (EOL)</a></li>
+ <li><a href="../../httpclient-legacy/index.html" title="Commons HttpClient (EOL)"><span class="none"></span>Commons HttpClient (EOL)</a></li>
+ <li class="nav-header">Project Documentation</li>
+ <li><a href="../../project-info.html" title="Project Information"><span class="icon-chevron-right"></span>Project Information</a></li>
+ <li class="nav-header">ASF</li>
+ <li><a href="https://www.apache.org" class="externalLink" title="ASF Home Page"><span class="none"></span>ASF Home Page</a></li>
+ <li><a href="https://www.apache.org/foundation/" class="externalLink" title="Foundation"><span class="none"></span>Foundation</a></li>
+ <li><a href="https://www.apache.org/foundation/sponsorship.html" class="externalLink" title="Sponsor Apache"><span class="none"></span>Sponsor Apache</a></li>
+ <li><a href="https://www.apache.org/foundation/thanks.html" class="externalLink" title="Thanks"><span class="none"></span>Thanks</a></li>
+ </ul>
+ </nav>
+ <div class="well sidebar-nav">
+ <hr />
+ <div id="poweredBy">
+ <div class="clear"></div>
+ <div class="clear"></div>
+ <div class="clear"></div>
+<a href="https://www.apache.org/events/current-event.html" title="ApacheCon" class="builtBy"><img class="builtBy" alt="ApacheCon" src="https://www.apache.org/events/current-event-125x125.png" /></a>
+<a href="https://maven.apache.org/" title="Maven" class="builtBy"><img class="builtBy" alt="Maven" src="https://maven.apache.org/images/logos/maven-feather.png" /></a>
+ </div>
+ </div>
+ </header>
+ <main id="bodyColumn" class="span10" >
+<h1>Migration from Apache HttpClient 4.x APIs</h1>
+<p>It is strongly encouraged to follow the best practices and common use patterns in programming with Apache HttpClient
+4.x. They remain largely unchanged between 4.x and 5.x release series. Correctly written code will be easier to port to
+5.x APIs and from the classic I/O model to the async I/O model.</p><section>
+<h2><a name="Preparation_steps"></a>Preparation steps</h2>
+<ol style="list-style-type: decimal">
+
+<li>
+
+<p>Make sure there are no references to deprecated functions or classes</p>
+</li>
+<li>
+
+<p>HttpClient uses tries to use sensible defaults but it is generally recommended to adjust SSL/TLS parameters and
+timeout settings for the specific application context.</p>
+</li>
+<li>
+
+<p>Explicitly specify TLSv1.2 in order to disable older, less secure versions of the SSL/TLS protocol. Please note
+HttpClient 4.5 disables all SSL versions by default.</p>
+</li>
+<li>
+
+<p>Set finite socket and connect timeouts.</p>
+</li>
+<li>
+
+<p>Set finite connection total time to live (TTL).</p>
+</li>
+<li>
+
+<p>Favor <code>standard</code> and <code>standard-strict</code> cookie policies.</p>
+</li>
+<li>
+
+<p>IMPORTANT: Always re-use <code>CloseableHttpClient</code> instances. They are expensive to create, but they are also fully
+thread safe, so multiple threads can use the same instance of <code>CloseableHttpClient</code> to execute multiple requests
+concurrently taking full advantage of persistent connection re-use and connection pooling.</p>
+
+<div class="source"><pre class="prettyprint"><code class="language-java">CloseableHttpClient client = HttpClients.custom()
+ .setSSLSocketFactory(new SSLConnectionSocketFactory(
+ SSLContexts.createSystemDefault(),
+ new String[] { "TLSv1.2" },
+ null,
+ SSLConnectionSocketFactory.getDefaultHostnameVerifier()))
+ .setConnectionTimeToLive(1, TimeUnit.MINUTES)
+ .setDefaultSocketConfig(SocketConfig.custom()
+ .setSoTimeout(60000)
+ .build())
+ .setDefaultRequestConfig(RequestConfig.custom()
+ .setConnectTimeout(60000)
+ .setSocketTimeout(60000)
+ .setCookieSpec(CookieSpecs.STANDARD_STRICT)
+ .build())
+ .build();
+</code></pre></div>
+</li>
+<li>
+
+<p>Cookie store and credentials providers can be shared by multiple execution threads. They can still be shared by
+multiple message exchnages without being set at
+<code>CloseableHttpClient</code> construction time.</p>
+
+<div class="source"><pre class="prettyprint"><code class="language-java">CookieStore cookieStore = new BasicCookieStore();
+CredentialsProvider credentialsProvider = new BasicCredentialsProvider();
+</code></pre></div>
+</li>
+<li>
+
+<p>While <code>CloseableHttpClient</code> should have the default configuration applicable to all all messages exchanges one can
+use <code>HttpContext</code> to customize individual request execution parameters.</p>
+
+<div class="source"><pre class="prettyprint"><code class="language-java">HttpClientContext clientContext = HttpClientContext.create();
+clientContext.setCookieStore(cookieStore);
+clientContext.setCredentialsProvider(credentialsProvider);
+clientContext.setRequestConfig(RequestConfig.custom()
+ .setConnectTimeout(60000)
+ .setSocketTimeout(60000)
+ .setCookieSpec(CookieSpecs.STANDARD)
+ .build());
+</code></pre></div>
+</li>
+<li>
+
+<p>Always set content type and content encoding on the entity and let HttpClient generate request headers automatically.</p>
+
+<div class="source"><pre class="prettyprint"><code class="language-java">JsonFactory jsonFactory = new JsonFactory();
+ObjectMapper objectMapper = new ObjectMapper(jsonFactory);
+
+HttpPost httpPost = new HttpPost("https://httpbin.org/post");
+List<NameValuePair> requestData = Arrays.asList(
+ new BasicNameValuePair("name1", "value1"),
+ new BasicNameValuePair("name2", "value2"));
+
+EntityTemplate requestEntity = new EntityTemplate(outstream -> {
+ objectMapper.writeValue(outstream, requestData);
+ outstream.flush();
+
+});
+requestEntity.setContentType(ContentType.APPLICATION_JSON.toString());
+httpPost.setEntity(requestEntity);
+</code></pre></div>
+</li>
+<li>
+
+<p>Consume response content directly from the content stream and convert it to a higher level object without converting
+it to an intermediate string or byte array.</p>
+</li>
+<li>
+
+<p>Favor HTTP response handlers for response processing, thus making connection release automatic.</p>
+
+<div class="source"><pre class="prettyprint"><code class="language-java">JsonNode responseData = client.execute(httpPost, response -> {
+ if (response.getStatusLine().getStatusCode() >= 300) {
+ throw new ClientProtocolException(Objects.toString(response.getStatusLine()));
+ }
+ final HttpEntity responseEntity = response.getEntity();
+ if (responseEntity == null) {
+ return null;
+ }
+ try (InputStream inputStream = responseEntity.getContent()) {
+ return objectMapper.readTree(inputStream);
+ }
+});
+System.out.println(responseData);
+</code></pre></div>
+</li>
+<li>
+
+<p><code>CloseableHttpClient</code> instances should be closed when no longer needed or about to go out of score.</p>
+
+<div class="source"><pre class="prettyprint"><code class="language-java">client.close();
+</code></pre></div>
+</li>
+</ol></section>
+ </main>
+ </div>
+ </div>
+ <hr/>
+ <footer>
+ <div class="container-fluid">
+ <div class="row-fluid">
+ <p>© 2005–2024
+<a href="https://www.apache.org/">The Apache Software Foundation</a>
+</p>
+ </div>
+ </div>
+ </footer>
+ </body>
+</html>
\ No newline at end of file
Modified: httpcomponents/site/httpcomponents-client-5.4.x/quickstart.html
URL: http://svn.apache.org/viewvc/httpcomponents/site/httpcomponents-client-5.4.x/quickstart.html?rev=1920810&r1=1920809&r2=1920810&view=diff
==============================================================================
--- httpcomponents/site/httpcomponents-client-5.4.x/quickstart.html (original)
+++ httpcomponents/site/httpcomponents-client-5.4.x/quickstart.html Fri Sep 20 15:24:22 2024
@@ -25,7 +25,7 @@
<div id="breadcrumbs">
<ul class="breadcrumb">
- <li id="publishDate">Last Published: 2024-09-18<span class="divider">|</span>
+ <li id="publishDate">Last Published: 2024-09-20<span class="divider">|</span>
</li>
<li class=""><a href="../index.html" title="HttpComponents">HttpComponents</a><span class="divider">/</span></li>
<li class="active ">HttpClient Quick Start <a href="https://github.com/apache/httpcomponents-website/tree/master/src/site/markdown/httpcomponents-client-5.4.x/quickstart.md"><img src="../images/accessories-text-editor.png" title="Edit" /></a></li>
@@ -51,19 +51,18 @@
<li><a href="../charter.html" title="Project Charter"><span class="none"></span>Project Charter</a></li>
<li><a href="../get-involved.html" title="Get Involved"><span class="none"></span>Get Involved</a></li>
<li class="nav-header">Components</li>
- <li><a href="../httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4 BETA"><span class="icon-chevron-down"></span>HttpClient 5.4 BETA</a>
+ <li><a href="../httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4"><span class="icon-chevron-down"></span>HttpClient 5.4</a>
<ul class="nav nav-list">
<li class="active"><a href="#"><span class="none"></span>Quick Start</a></li>
- <li><a href="../httpcomponents-client-5.3.x/migration-guide/index.html" title="Migration Guide"><span class="icon-chevron-right"></span>Migration Guide</a></li>
+ <li><a href="../httpcomponents-client-5.4.x/migration-guide/index.html" title="Migration Guide"><span class="icon-chevron-right"></span>Migration Guide</a></li>
<li><a href="../httpcomponents-client-5.4.x/examples.html" title="Examples (Classic)"><span class="none"></span>Examples (Classic)</a></li>
<li><a href="../httpcomponents-client-5.4.x/examples-async.html" title="Examples (Async)"><span class="none"></span>Examples (Async)</a></li>
<li><a href="../httpcomponents-client-5.4.x/examples-reactive.html" title="Examples (Reactive)"><span class="none"></span>Examples (Reactive)</a></li>
- <li><a href="../httpcomponents-client-5.3.x/logging.html" title="Logging Guide"><span class="none"></span>Logging Guide</a></li>
- <li><a href="../httpcomponents-client-5.3.x/android.html" title="Android"><span class="none"></span>Android</a></li>
- <li><a href="../httpcomponents-client-5.3.x/related-projects.html" title="Related"><span class="none"></span>Related</a></li>
+ <li><a href="../httpcomponents-client-5.4.x/logging.html" title="Logging Guide"><span class="none"></span>Logging Guide</a></li>
+ <li><a href="../httpcomponents-client-5.4.x/android.html" title="Android"><span class="none"></span>Android</a></li>
+ <li><a href="../httpcomponents-client-5.4.x/related-projects.html" title="Related"><span class="none"></span>Related</a></li>
<li><a href="../httpcomponents-client-5.4.x/download.html" title="Download"><span class="none"></span>Download</a></li>
</ul></li>
- <li><a href="../httpcomponents-client-5.3.x/index.html" title="HttpClient 5.3"><span class="icon-chevron-right"></span>HttpClient 5.3</a></li>
<li><a href="../httpcomponents-core-5.3.x/index.html" title="HttpCore 5.3"><span class="icon-chevron-right"></span>HttpCore 5.3</a></li>
<li><a href="../httpcomponents-client-4.5.x/index.html" title="HttpClient 4.5"><span class="icon-chevron-right"></span>HttpClient 4.5</a></li>
<li class="nav-header">Legacy</li>
Added: httpcomponents/site/httpcomponents-client-5.4.x/related-projects.html
URL: http://svn.apache.org/viewvc/httpcomponents/site/httpcomponents-client-5.4.x/related-projects.html?rev=1920810&view=auto
==============================================================================
--- httpcomponents/site/httpcomponents-client-5.4.x/related-projects.html (added)
+++ httpcomponents/site/httpcomponents-client-5.4.x/related-projects.html Fri Sep 20 15:24:22 2024
@@ -0,0 +1,134 @@
+<!DOCTYPE html>
+<!--
+ | Generated by Apache Maven Doxia Site Renderer 1.11.1 from src/site/markdown/httpcomponents-client-5.4.x/related-projects.md
+ | Rendered using Apache Maven Fluido Skin 1.9
+-->
+<html xmlns="http://www.w3.org/1999/xhtml" lang="en">
+ <head>
+ <meta charset="UTF-8" />
+ <meta name="viewport" content="width=device-width, initial-scale=1" />
+ <meta name="generator" content="Apache Maven Doxia Site Renderer 1.11.1" />
+ <title>Apache HttpComponents – Related projects</title>
+ <link rel="stylesheet" href="../css/apache-maven-fluido-1.9.min.css" />
+ <link rel="stylesheet" href="../css/site.css" />
+ <link rel="stylesheet" href="../css/print.css" media="print" />
+ <script src="../js/apache-maven-fluido-1.9.min.js"></script>
+ </head>
+ <body class="topBarDisabled">
+ <div class="container-fluid">
+ <header>
+ <div id="banner">
+ <div class="pull-left"><a href="https://www.apache.org/" id="bannerLeft"><img src="https://www.apache.org/images/asf_logo_wide.gif" alt="Apache"/></a></div>
+ <div class="pull-right"><a href=".././" id="bannerRight"><img src="../images/logos/httpcomponents.png" alt="HttpComponents"/></a></div>
+ <div class="clear"><hr/></div>
+ </div>
+
+ <div id="breadcrumbs">
+ <ul class="breadcrumb">
+ <li id="publishDate">Last Published: 2024-09-20<span class="divider">|</span>
+</li>
+ <li class=""><a href="../index.html" title="HttpComponents">HttpComponents</a><span class="divider">/</span></li>
+ <li class="active ">Related projects <a href="https://github.com/apache/httpcomponents-website/tree/master/src/site/markdown/httpcomponents-client-5.4.x/related-projects.md"><img src="../images/accessories-text-editor.png" title="Edit" /></a></li>
+ <li class="pull-right"><a href="https://www.apache.org/" class="externalLink" title="Apache">Apache</a></li>
+ </ul>
+ </div>
+ </header>
+ <div class="row-fluid">
+ <header id="leftColumn" class="span2">
+ <nav class="well sidebar-nav">
+ <ul class="nav nav-list">
+ <li class="nav-header">HttpComponents</li>
+ <li><a href="../index.html" title="Home"><span class="none"></span>Home</a></li>
+ <li><a href="https://www.apache.org/licenses/" class="externalLink" title="License"><span class="none"></span>License</a></li>
+ <li><a href="../downloads.cgi" title="Download"><span class="none"></span>Download</a></li>
+ <li><a href="../mail.html" title="Mailing Lists"><span class="none"></span>Mailing Lists</a></li>
+ <li><a href="https://wiki.apache.org/HttpComponents/" class="externalLink" title="Wiki (external)"><span class="none"></span>Wiki (external)</a></li>
+ <li><a href="https://www.apache.org/security/" class="externalLink" title="Security"><span class="none"></span>Security</a></li>
+ <li class="nav-header">Overview</li>
+ <li><a href="../index.html" title="About"><span class="none"></span>About</a></li>
+ <li><a href="../news.html" title="News"><span class="none"></span>News</a></li>
+ <li><a href="../status.html" title="Project Status"><span class="none"></span>Project Status</a></li>
+ <li><a href="../charter.html" title="Project Charter"><span class="none"></span>Project Charter</a></li>
+ <li><a href="../get-involved.html" title="Get Involved"><span class="none"></span>Get Involved</a></li>
+ <li class="nav-header">Components</li>
+ <li><a href="../httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4"><span class="icon-chevron-down"></span>HttpClient 5.4</a>
+ <ul class="nav nav-list">
+ <li><a href="../httpcomponents-client-5.4.x/quickstart.html" title="Quick Start"><span class="none"></span>Quick Start</a></li>
+ <li><a href="../httpcomponents-client-5.4.x/migration-guide/index.html" title="Migration Guide"><span class="icon-chevron-right"></span>Migration Guide</a></li>
+ <li><a href="../httpcomponents-client-5.4.x/examples.html" title="Examples (Classic)"><span class="none"></span>Examples (Classic)</a></li>
+ <li><a href="../httpcomponents-client-5.4.x/examples-async.html" title="Examples (Async)"><span class="none"></span>Examples (Async)</a></li>
+ <li><a href="../httpcomponents-client-5.4.x/examples-reactive.html" title="Examples (Reactive)"><span class="none"></span>Examples (Reactive)</a></li>
+ <li><a href="../httpcomponents-client-5.4.x/logging.html" title="Logging Guide"><span class="none"></span>Logging Guide</a></li>
+ <li><a href="../httpcomponents-client-5.4.x/android.html" title="Android"><span class="none"></span>Android</a></li>
+ <li class="active"><a href="#"><span class="none"></span>Related</a></li>
+ <li><a href="../httpcomponents-client-5.4.x/download.html" title="Download"><span class="none"></span>Download</a></li>
+ </ul></li>
+ <li><a href="../httpcomponents-core-5.3.x/index.html" title="HttpCore 5.3"><span class="icon-chevron-right"></span>HttpCore 5.3</a></li>
+ <li><a href="../httpcomponents-client-4.5.x/index.html" title="HttpClient 4.5"><span class="icon-chevron-right"></span>HttpClient 4.5</a></li>
+ <li class="nav-header">Legacy</li>
+ <li><a href="../httpcomponents-asyncclient-4.1.x/index.html" title="HttpAsyncClient 4.1 (EOL)"><span class="icon-chevron-right"></span>HttpAsyncClient 4.1 (EOL)</a></li>
+ <li><a href="../httpcomponents-core-4.4.x/index.html" title="HttpCore 4.4 (EOL)"><span class="icon-chevron-right"></span>HttpCore 4.4 (EOL)</a></li>
+ <li><a href="../httpclient-legacy/index.html" title="Commons HttpClient (EOL)"><span class="none"></span>Commons HttpClient (EOL)</a></li>
+ <li class="nav-header">Project Documentation</li>
+ <li><a href="../project-info.html" title="Project Information"><span class="icon-chevron-right"></span>Project Information</a></li>
+ <li class="nav-header">ASF</li>
+ <li><a href="https://www.apache.org" class="externalLink" title="ASF Home Page"><span class="none"></span>ASF Home Page</a></li>
+ <li><a href="https://www.apache.org/foundation/" class="externalLink" title="Foundation"><span class="none"></span>Foundation</a></li>
+ <li><a href="https://www.apache.org/foundation/sponsorship.html" class="externalLink" title="Sponsor Apache"><span class="none"></span>Sponsor Apache</a></li>
+ <li><a href="https://www.apache.org/foundation/thanks.html" class="externalLink" title="Thanks"><span class="none"></span>Thanks</a></li>
+ </ul>
+ </nav>
+ <div class="well sidebar-nav">
+ <hr />
+ <div id="poweredBy">
+ <div class="clear"></div>
+ <div class="clear"></div>
+ <div class="clear"></div>
+<a href="https://www.apache.org/events/current-event.html" title="ApacheCon" class="builtBy"><img class="builtBy" alt="ApacheCon" src="https://www.apache.org/events/current-event-125x125.png" /></a>
+<a href="https://maven.apache.org/" title="Maven" class="builtBy"><img class="builtBy" alt="Maven" src="https://maven.apache.org/images/logos/maven-feather.png" /></a>
+ </div>
+ </div>
+ </header>
+ <main id="bodyColumn" class="span10" >
+<!--
+ Licensed to the Apache Software Foundation (ASF) under one
+ or more contributor license agreements. See the NOTICE file
+ distributed with this work for additional information
+ regarding copyright ownership. The ASF licenses this file
+ to you under the Apache License, Version 2.0 (the
+ "License"); you may not use this file except in compliance
+ with the License. You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing,
+ software distributed under the License is distributed on an
+ "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+ KIND, either express or implied. See the License for the
+ specific language governing permissions and limitations
+ under the License.
+-->
+<h1>Related projects</h1><section>
+<h2><a name="Asynchronous_JSON_message_processors"></a>Asynchronous JSON message processors</h2>
+<p><a class="externalLink" href="https://ok2c.github.io/httpcomponents-jackson/">Asynchronous JSON message processors</a> library is a companion project
+for HttpClient 5.0 developed outside the Apache Software Foundation.</p>
+<p>The library provides a number of asynchronous message consumers and producers for efficient, reactive processing of HTTP
+messages with enclosed JSON content using <a class="externalLink" href="https://github.com/FasterXML/jackson">Jackson JSON processor</a>.</p></section><section>
+<h2><a name="Android_extensions"></a>Android extensions</h2>
+<p><a class="externalLink" href="https://ok2c.github.io/httpclient-android-ext/">Android extensions for Apache HttpClient 5.x</a> is a third party library
+that provides extra functionality simplifying application of Apache HttpClient on Google Android platform.</p></section>
+ </main>
+ </div>
+ </div>
+ <hr/>
+ <footer>
+ <div class="container-fluid">
+ <div class="row-fluid">
+ <p>© 2005–2024
+<a href="https://www.apache.org/">The Apache Software Foundation</a>
+</p>
+ </div>
+ </div>
+ </footer>
+ </body>
+</html>
\ No newline at end of file
Modified: httpcomponents/site/httpcomponents-core-4.4.x/download.html
URL: http://svn.apache.org/viewvc/httpcomponents/site/httpcomponents-core-4.4.x/download.html?rev=1920810&r1=1920809&r2=1920810&view=diff
==============================================================================
--- httpcomponents/site/httpcomponents-core-4.4.x/download.html (original)
+++ httpcomponents/site/httpcomponents-core-4.4.x/download.html Fri Sep 20 15:24:22 2024
@@ -25,7 +25,7 @@
<div id="breadcrumbs">
<ul class="breadcrumb">
- <li id="publishDate">Last Published: 2024-09-18<span class="divider">|</span>
+ <li id="publishDate">Last Published: 2024-09-20<span class="divider">|</span>
</li>
<li class=""><a href="../index.html" title="HttpComponents">HttpComponents</a><span class="divider">/</span></li>
<li class="active ">HttpCore Downloads <a href="https://github.com/apache/httpcomponents-website/tree/master/src/site/markdown/httpcomponents-core-4.4.x/download.md"><img src="../images/accessories-text-editor.png" title="Edit" /></a></li>
@@ -51,8 +51,7 @@
<li><a href="../charter.html" title="Project Charter"><span class="none"></span>Project Charter</a></li>
<li><a href="../get-involved.html" title="Get Involved"><span class="none"></span>Get Involved</a></li>
<li class="nav-header">Components</li>
- <li><a href="../httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4 BETA"><span class="icon-chevron-right"></span>HttpClient 5.4 BETA</a></li>
- <li><a href="../httpcomponents-client-5.3.x/index.html" title="HttpClient 5.3"><span class="icon-chevron-right"></span>HttpClient 5.3</a></li>
+ <li><a href="../httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4"><span class="icon-chevron-right"></span>HttpClient 5.4</a></li>
<li><a href="../httpcomponents-core-5.3.x/index.html" title="HttpCore 5.3"><span class="icon-chevron-right"></span>HttpCore 5.3</a></li>
<li><a href="../httpcomponents-client-4.5.x/index.html" title="HttpClient 4.5"><span class="icon-chevron-right"></span>HttpClient 4.5</a></li>
<li class="nav-header">Legacy</li>
Modified: httpcomponents/site/httpcomponents-core-4.4.x/examples.html
URL: http://svn.apache.org/viewvc/httpcomponents/site/httpcomponents-core-4.4.x/examples.html?rev=1920810&r1=1920809&r2=1920810&view=diff
==============================================================================
--- httpcomponents/site/httpcomponents-core-4.4.x/examples.html (original)
+++ httpcomponents/site/httpcomponents-core-4.4.x/examples.html Fri Sep 20 15:24:22 2024
@@ -25,7 +25,7 @@
<div id="breadcrumbs">
<ul class="breadcrumb">
- <li id="publishDate">Last Published: 2024-09-18<span class="divider">|</span>
+ <li id="publishDate">Last Published: 2024-09-20<span class="divider">|</span>
</li>
<li class=""><a href="../index.html" title="HttpComponents">HttpComponents</a><span class="divider">/</span></li>
<li class="active ">HttpCore Examples <a href="https://github.com/apache/httpcomponents-website/tree/master/src/site/markdown/httpcomponents-core-4.4.x/examples.md"><img src="../images/accessories-text-editor.png" title="Edit" /></a></li>
@@ -51,8 +51,7 @@
<li><a href="../charter.html" title="Project Charter"><span class="none"></span>Project Charter</a></li>
<li><a href="../get-involved.html" title="Get Involved"><span class="none"></span>Get Involved</a></li>
<li class="nav-header">Components</li>
- <li><a href="../httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4 BETA"><span class="icon-chevron-right"></span>HttpClient 5.4 BETA</a></li>
- <li><a href="../httpcomponents-client-5.3.x/index.html" title="HttpClient 5.3"><span class="icon-chevron-right"></span>HttpClient 5.3</a></li>
+ <li><a href="../httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4"><span class="icon-chevron-right"></span>HttpClient 5.4</a></li>
<li><a href="../httpcomponents-core-5.3.x/index.html" title="HttpCore 5.3"><span class="icon-chevron-right"></span>HttpCore 5.3</a></li>
<li><a href="../httpcomponents-client-4.5.x/index.html" title="HttpClient 4.5"><span class="icon-chevron-right"></span>HttpClient 4.5</a></li>
<li class="nav-header">Legacy</li>
Modified: httpcomponents/site/httpcomponents-core-4.4.x/index.html
URL: http://svn.apache.org/viewvc/httpcomponents/site/httpcomponents-core-4.4.x/index.html?rev=1920810&r1=1920809&r2=1920810&view=diff
==============================================================================
--- httpcomponents/site/httpcomponents-core-4.4.x/index.html (original)
+++ httpcomponents/site/httpcomponents-core-4.4.x/index.html Fri Sep 20 15:24:22 2024
@@ -25,7 +25,7 @@
<div id="breadcrumbs">
<ul class="breadcrumb">
- <li id="publishDate">Last Published: 2024-09-18<span class="divider">|</span>
+ <li id="publishDate">Last Published: 2024-09-20<span class="divider">|</span>
</li>
<li class=""><a href="../index.html" title="HttpComponents">HttpComponents</a><span class="divider">/</span></li>
<li class="active ">HttpCore Overview <a href="https://github.com/apache/httpcomponents-website/tree/master/src/site/markdown/httpcomponents-core-4.4.x/index.md"><img src="../images/accessories-text-editor.png" title="Edit" /></a></li>
@@ -51,8 +51,7 @@
<li><a href="../charter.html" title="Project Charter"><span class="none"></span>Project Charter</a></li>
<li><a href="../get-involved.html" title="Get Involved"><span class="none"></span>Get Involved</a></li>
<li class="nav-header">Components</li>
- <li><a href="../httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4 BETA"><span class="icon-chevron-right"></span>HttpClient 5.4 BETA</a></li>
- <li><a href="../httpcomponents-client-5.3.x/index.html" title="HttpClient 5.3"><span class="icon-chevron-right"></span>HttpClient 5.3</a></li>
+ <li><a href="../httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4"><span class="icon-chevron-right"></span>HttpClient 5.4</a></li>
<li><a href="../httpcomponents-core-5.3.x/index.html" title="HttpCore 5.3"><span class="icon-chevron-right"></span>HttpCore 5.3</a></li>
<li><a href="../httpcomponents-client-4.5.x/index.html" title="HttpClient 4.5"><span class="icon-chevron-right"></span>HttpClient 4.5</a></li>
<li class="nav-header">Legacy</li>
Modified: httpcomponents/site/httpcomponents-core-5.3.x/download.html
URL: http://svn.apache.org/viewvc/httpcomponents/site/httpcomponents-core-5.3.x/download.html?rev=1920810&r1=1920809&r2=1920810&view=diff
==============================================================================
--- httpcomponents/site/httpcomponents-core-5.3.x/download.html (original)
+++ httpcomponents/site/httpcomponents-core-5.3.x/download.html Fri Sep 20 15:24:22 2024
@@ -25,7 +25,7 @@
<div id="breadcrumbs">
<ul class="breadcrumb">
- <li id="publishDate">Last Published: 2024-09-18<span class="divider">|</span>
+ <li id="publishDate">Last Published: 2024-09-20<span class="divider">|</span>
</li>
<li class=""><a href="../index.html" title="HttpComponents">HttpComponents</a><span class="divider">/</span></li>
<li class="active ">HttpCore Downloads <a href="https://github.com/apache/httpcomponents-website/tree/master/src/site/markdown/httpcomponents-core-5.3.x/download.md"><img src="../images/accessories-text-editor.png" title="Edit" /></a></li>
@@ -51,8 +51,7 @@
<li><a href="../charter.html" title="Project Charter"><span class="none"></span>Project Charter</a></li>
<li><a href="../get-involved.html" title="Get Involved"><span class="none"></span>Get Involved</a></li>
<li class="nav-header">Components</li>
- <li><a href="../httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4 BETA"><span class="icon-chevron-right"></span>HttpClient 5.4 BETA</a></li>
- <li><a href="../httpcomponents-client-5.3.x/index.html" title="HttpClient 5.3"><span class="icon-chevron-right"></span>HttpClient 5.3</a></li>
+ <li><a href="../httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4"><span class="icon-chevron-right"></span>HttpClient 5.4</a></li>
<li><a href="../httpcomponents-core-5.3.x/index.html" title="HttpCore 5.3"><span class="icon-chevron-down"></span>HttpCore 5.3</a>
<ul class="nav nav-list">
<li><a href="../httpcomponents-core-5.3.x/examples.html" title="Examples"><span class="none"></span>Examples</a></li>
Modified: httpcomponents/site/httpcomponents-core-5.3.x/examples.html
URL: http://svn.apache.org/viewvc/httpcomponents/site/httpcomponents-core-5.3.x/examples.html?rev=1920810&r1=1920809&r2=1920810&view=diff
==============================================================================
--- httpcomponents/site/httpcomponents-core-5.3.x/examples.html (original)
+++ httpcomponents/site/httpcomponents-core-5.3.x/examples.html Fri Sep 20 15:24:22 2024
@@ -25,7 +25,7 @@
<div id="breadcrumbs">
<ul class="breadcrumb">
- <li id="publishDate">Last Published: 2024-09-18<span class="divider">|</span>
+ <li id="publishDate">Last Published: 2024-09-20<span class="divider">|</span>
</li>
<li class=""><a href="../index.html" title="HttpComponents">HttpComponents</a><span class="divider">/</span></li>
<li class="active ">HttpCore Examples <a href="https://github.com/apache/httpcomponents-website/tree/master/src/site/markdown/httpcomponents-core-5.3.x/examples.md"><img src="../images/accessories-text-editor.png" title="Edit" /></a></li>
@@ -51,8 +51,7 @@
<li><a href="../charter.html" title="Project Charter"><span class="none"></span>Project Charter</a></li>
<li><a href="../get-involved.html" title="Get Involved"><span class="none"></span>Get Involved</a></li>
<li class="nav-header">Components</li>
- <li><a href="../httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4 BETA"><span class="icon-chevron-right"></span>HttpClient 5.4 BETA</a></li>
- <li><a href="../httpcomponents-client-5.3.x/index.html" title="HttpClient 5.3"><span class="icon-chevron-right"></span>HttpClient 5.3</a></li>
+ <li><a href="../httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4"><span class="icon-chevron-right"></span>HttpClient 5.4</a></li>
<li><a href="../httpcomponents-core-5.3.x/index.html" title="HttpCore 5.3"><span class="icon-chevron-down"></span>HttpCore 5.3</a>
<ul class="nav nav-list">
<li class="active"><a href="#"><span class="none"></span>Examples</a></li>
Modified: httpcomponents/site/httpcomponents-core-5.3.x/index.html
URL: http://svn.apache.org/viewvc/httpcomponents/site/httpcomponents-core-5.3.x/index.html?rev=1920810&r1=1920809&r2=1920810&view=diff
==============================================================================
--- httpcomponents/site/httpcomponents-core-5.3.x/index.html (original)
+++ httpcomponents/site/httpcomponents-core-5.3.x/index.html Fri Sep 20 15:24:22 2024
@@ -25,7 +25,7 @@
<div id="breadcrumbs">
<ul class="breadcrumb">
- <li id="publishDate">Last Published: 2024-09-18<span class="divider">|</span>
+ <li id="publishDate">Last Published: 2024-09-20<span class="divider">|</span>
</li>
<li class=""><a href="../index.html" title="HttpComponents">HttpComponents</a><span class="divider">/</span></li>
<li class="active ">HttpCore Overview <a href="https://github.com/apache/httpcomponents-website/tree/master/src/site/markdown/httpcomponents-core-5.3.x/index.md"><img src="../images/accessories-text-editor.png" title="Edit" /></a></li>
@@ -51,8 +51,7 @@
<li><a href="../charter.html" title="Project Charter"><span class="none"></span>Project Charter</a></li>
<li><a href="../get-involved.html" title="Get Involved"><span class="none"></span>Get Involved</a></li>
<li class="nav-header">Components</li>
- <li><a href="../httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4 BETA"><span class="icon-chevron-right"></span>HttpClient 5.4 BETA</a></li>
- <li><a href="../httpcomponents-client-5.3.x/index.html" title="HttpClient 5.3"><span class="icon-chevron-right"></span>HttpClient 5.3</a></li>
+ <li><a href="../httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4"><span class="icon-chevron-right"></span>HttpClient 5.4</a></li>
<li class="active"><a href="#"><span class="icon-chevron-down"></span>HttpCore 5.3</a>
<ul class="nav nav-list">
<li><a href="../httpcomponents-core-5.3.x/examples.html" title="Examples"><span class="none"></span>Examples</a></li>
Modified: httpcomponents/site/httpcomponents-core-5.3.x/related-projects.html
URL: http://svn.apache.org/viewvc/httpcomponents/site/httpcomponents-core-5.3.x/related-projects.html?rev=1920810&r1=1920809&r2=1920810&view=diff
==============================================================================
--- httpcomponents/site/httpcomponents-core-5.3.x/related-projects.html (original)
+++ httpcomponents/site/httpcomponents-core-5.3.x/related-projects.html Fri Sep 20 15:24:22 2024
@@ -25,7 +25,7 @@
<div id="breadcrumbs">
<ul class="breadcrumb">
- <li id="publishDate">Last Published: 2024-09-18<span class="divider">|</span>
+ <li id="publishDate">Last Published: 2024-09-20<span class="divider">|</span>
</li>
<li class=""><a href="../index.html" title="HttpComponents">HttpComponents</a><span class="divider">/</span></li>
<li class="active ">Related projects <a href="https://github.com/apache/httpcomponents-website/tree/master/src/site/markdown/httpcomponents-core-5.3.x/related-projects.md"><img src="../images/accessories-text-editor.png" title="Edit" /></a></li>
@@ -51,8 +51,7 @@
<li><a href="../charter.html" title="Project Charter"><span class="none"></span>Project Charter</a></li>
<li><a href="../get-involved.html" title="Get Involved"><span class="none"></span>Get Involved</a></li>
<li class="nav-header">Components</li>
- <li><a href="../httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4 BETA"><span class="icon-chevron-right"></span>HttpClient 5.4 BETA</a></li>
- <li><a href="../httpcomponents-client-5.3.x/index.html" title="HttpClient 5.3"><span class="icon-chevron-right"></span>HttpClient 5.3</a></li>
+ <li><a href="../httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4"><span class="icon-chevron-right"></span>HttpClient 5.4</a></li>
<li><a href="../httpcomponents-core-5.3.x/index.html" title="HttpCore 5.3"><span class="icon-chevron-down"></span>HttpCore 5.3</a>
<ul class="nav nav-list">
<li><a href="../httpcomponents-core-5.3.x/examples.html" title="Examples"><span class="none"></span>Examples</a></li>
Modified: httpcomponents/site/index.html
URL: http://svn.apache.org/viewvc/httpcomponents/site/index.html?rev=1920810&r1=1920809&r2=1920810&view=diff
==============================================================================
--- httpcomponents/site/index.html (original)
+++ httpcomponents/site/index.html Fri Sep 20 15:24:22 2024
@@ -25,7 +25,7 @@
<div id="breadcrumbs">
<ul class="breadcrumb">
- <li id="publishDate">Last Published: 2024-09-18<span class="divider">|</span>
+ <li id="publishDate">Last Published: 2024-09-20<span class="divider">|</span>
</li>
<li class=""><a href="index.html" title="HttpComponents">HttpComponents</a><span class="divider">/</span></li>
<li class="active ">Apache HttpComponents <a href="https://github.com/apache/httpcomponents-website/tree/master/src/site/markdown/index.md"><img src="./images/accessories-text-editor.png" title="Edit" /></a></li>
@@ -51,8 +51,7 @@
<li><a href="charter.html" title="Project Charter"><span class="none"></span>Project Charter</a></li>
<li><a href="get-involved.html" title="Get Involved"><span class="none"></span>Get Involved</a></li>
<li class="nav-header">Components</li>
- <li><a href="httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4 BETA"><span class="icon-chevron-right"></span>HttpClient 5.4 BETA</a></li>
- <li><a href="httpcomponents-client-5.3.x/index.html" title="HttpClient 5.3"><span class="icon-chevron-right"></span>HttpClient 5.3</a></li>
+ <li><a href="httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4"><span class="icon-chevron-right"></span>HttpClient 5.4</a></li>
<li><a href="httpcomponents-core-5.3.x/index.html" title="HttpCore 5.3"><span class="icon-chevron-right"></span>HttpCore 5.3</a></li>
<li><a href="httpcomponents-client-4.5.x/index.html" title="HttpClient 4.5"><span class="icon-chevron-right"></span>HttpClient 4.5</a></li>
<li class="nav-header">Legacy</li>
Modified: httpcomponents/site/licenses.html
URL: http://svn.apache.org/viewvc/httpcomponents/site/licenses.html?rev=1920810&r1=1920809&r2=1920810&view=diff
==============================================================================
--- httpcomponents/site/licenses.html (original)
+++ httpcomponents/site/licenses.html Fri Sep 20 15:24:22 2024
@@ -25,7 +25,7 @@
<div id="breadcrumbs">
<ul class="breadcrumb">
- <li id="publishDate">Last Published: 2024-09-18<span class="divider">|</span>
+ <li id="publishDate">Last Published: 2024-09-20<span class="divider">|</span>
</li>
<li class=""><a href="index.html" title="HttpComponents">HttpComponents</a><span class="divider">/</span></li>
<li class="active ">Project Licenses</li>
@@ -51,8 +51,7 @@
<li><a href="charter.html" title="Project Charter"><span class="none"></span>Project Charter</a></li>
<li><a href="get-involved.html" title="Get Involved"><span class="none"></span>Get Involved</a></li>
<li class="nav-header">Components</li>
- <li><a href="httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4 BETA"><span class="icon-chevron-right"></span>HttpClient 5.4 BETA</a></li>
- <li><a href="httpcomponents-client-5.3.x/index.html" title="HttpClient 5.3"><span class="icon-chevron-right"></span>HttpClient 5.3</a></li>
+ <li><a href="httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4"><span class="icon-chevron-right"></span>HttpClient 5.4</a></li>
<li><a href="httpcomponents-core-5.3.x/index.html" title="HttpCore 5.3"><span class="icon-chevron-right"></span>HttpCore 5.3</a></li>
<li><a href="httpcomponents-client-4.5.x/index.html" title="HttpClient 4.5"><span class="icon-chevron-right"></span>HttpClient 4.5</a></li>
<li class="nav-header">Legacy</li>
Modified: httpcomponents/site/mail.html
URL: http://svn.apache.org/viewvc/httpcomponents/site/mail.html?rev=1920810&r1=1920809&r2=1920810&view=diff
==============================================================================
--- httpcomponents/site/mail.html (original)
+++ httpcomponents/site/mail.html Fri Sep 20 15:24:22 2024
@@ -25,7 +25,7 @@
<div id="breadcrumbs">
<ul class="breadcrumb">
- <li id="publishDate">Last Published: 2024-09-18<span class="divider">|</span>
+ <li id="publishDate">Last Published: 2024-09-20<span class="divider">|</span>
</li>
<li class=""><a href="index.html" title="HttpComponents">HttpComponents</a><span class="divider">/</span></li>
<li class="active ">HttpComponents Mailing Lists <a href="https://github.com/apache/httpcomponents-website/tree/master/src/site/markdown/mail.md"><img src="./images/accessories-text-editor.png" title="Edit" /></a></li>
@@ -51,8 +51,7 @@
<li><a href="charter.html" title="Project Charter"><span class="none"></span>Project Charter</a></li>
<li><a href="get-involved.html" title="Get Involved"><span class="none"></span>Get Involved</a></li>
<li class="nav-header">Components</li>
- <li><a href="httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4 BETA"><span class="icon-chevron-right"></span>HttpClient 5.4 BETA</a></li>
- <li><a href="httpcomponents-client-5.3.x/index.html" title="HttpClient 5.3"><span class="icon-chevron-right"></span>HttpClient 5.3</a></li>
+ <li><a href="httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4"><span class="icon-chevron-right"></span>HttpClient 5.4</a></li>
<li><a href="httpcomponents-core-5.3.x/index.html" title="HttpCore 5.3"><span class="icon-chevron-right"></span>HttpCore 5.3</a></li>
<li><a href="httpcomponents-client-4.5.x/index.html" title="HttpClient 4.5"><span class="icon-chevron-right"></span>HttpClient 4.5</a></li>
<li class="nav-header">Legacy</li>
Modified: httpcomponents/site/mailing-lists.html
URL: http://svn.apache.org/viewvc/httpcomponents/site/mailing-lists.html?rev=1920810&r1=1920809&r2=1920810&view=diff
==============================================================================
--- httpcomponents/site/mailing-lists.html (original)
+++ httpcomponents/site/mailing-lists.html Fri Sep 20 15:24:22 2024
@@ -25,7 +25,7 @@
<div id="breadcrumbs">
<ul class="breadcrumb">
- <li id="publishDate">Last Published: 2024-09-18<span class="divider">|</span>
+ <li id="publishDate">Last Published: 2024-09-20<span class="divider">|</span>
</li>
<li class=""><a href="index.html" title="HttpComponents">HttpComponents</a><span class="divider">/</span></li>
<li class="active ">Project Mailing Lists</li>
@@ -51,8 +51,7 @@
<li><a href="charter.html" title="Project Charter"><span class="none"></span>Project Charter</a></li>
<li><a href="get-involved.html" title="Get Involved"><span class="none"></span>Get Involved</a></li>
<li class="nav-header">Components</li>
- <li><a href="httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4 BETA"><span class="icon-chevron-right"></span>HttpClient 5.4 BETA</a></li>
- <li><a href="httpcomponents-client-5.3.x/index.html" title="HttpClient 5.3"><span class="icon-chevron-right"></span>HttpClient 5.3</a></li>
+ <li><a href="httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4"><span class="icon-chevron-right"></span>HttpClient 5.4</a></li>
<li><a href="httpcomponents-core-5.3.x/index.html" title="HttpCore 5.3"><span class="icon-chevron-right"></span>HttpCore 5.3</a></li>
<li><a href="httpcomponents-client-4.5.x/index.html" title="HttpClient 4.5"><span class="icon-chevron-right"></span>HttpClient 4.5</a></li>
<li class="nav-header">Legacy</li>
Modified: httpcomponents/site/news.html
URL: http://svn.apache.org/viewvc/httpcomponents/site/news.html?rev=1920810&r1=1920809&r2=1920810&view=diff
==============================================================================
--- httpcomponents/site/news.html (original)
+++ httpcomponents/site/news.html Fri Sep 20 15:24:22 2024
@@ -25,7 +25,7 @@
<div id="breadcrumbs">
<ul class="breadcrumb">
- <li id="publishDate">Last Published: 2024-09-18<span class="divider">|</span>
+ <li id="publishDate">Last Published: 2024-09-20<span class="divider">|</span>
</li>
<li class=""><a href="index.html" title="HttpComponents">HttpComponents</a><span class="divider">/</span></li>
<li class="active ">HttpComponents Project News <a href="https://github.com/apache/httpcomponents-website/tree/master/src/site/markdown/news.md"><img src="./images/accessories-text-editor.png" title="Edit" /></a></li>
@@ -51,8 +51,7 @@
<li><a href="charter.html" title="Project Charter"><span class="none"></span>Project Charter</a></li>
<li><a href="get-involved.html" title="Get Involved"><span class="none"></span>Get Involved</a></li>
<li class="nav-header">Components</li>
- <li><a href="httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4 BETA"><span class="icon-chevron-right"></span>HttpClient 5.4 BETA</a></li>
- <li><a href="httpcomponents-client-5.3.x/index.html" title="HttpClient 5.3"><span class="icon-chevron-right"></span>HttpClient 5.3</a></li>
+ <li><a href="httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4"><span class="icon-chevron-right"></span>HttpClient 5.4</a></li>
<li><a href="httpcomponents-core-5.3.x/index.html" title="HttpCore 5.3"><span class="icon-chevron-right"></span>HttpCore 5.3</a></li>
<li><a href="httpcomponents-client-4.5.x/index.html" title="HttpClient 4.5"><span class="icon-chevron-right"></span>HttpClient 4.5</a></li>
<li class="nav-header">Legacy</li>
@@ -99,19 +98,20 @@
under the License.
-->
<h1>HttpComponents Project News</h1><section><section><section><section><section>
-<h6><a name="a12_September_2024_-_HttpComponents_Core_5.3_GA_released"></a>12 September 2024 - HttpComponents Core 5.3 GA released</h6>
-<p>This is the first GA release in the 5.3 release series. This release finalizes the 5.3 APIs
-and improves integration test configuration APIs along with many test code improvements</p>
-<p>Notable changes and features included in the 5.3 series:</p>
+<h6><a name="a23_September_2024_-_HttpComponents_Client_5.4_GA_released"></a>23 September 2024 - HttpComponents Client 5.4 GA released</h6>
+<p>This is the first GA release in the 5.4 release series. This release finalizes the 5.4 APIs,
+upgrades HttpCore to version 5.3 and improves the Public Suffix matching algorithm implementation.</p>
+<p>Notable changes and features included in the 5.4 series:</p>
<ul>
<li>
-<p>Improved conformance to RFC 9110 and RFC 9112.</p>
+<p>Improved conformance to RFC 9110 (HTTP Semantics), RFC 7616 (HTTP Digest Access
+Authentication), RFC 2617 (’Basic’ HTTP Authentication Scheme).</p>
</li>
<li>
-<p>UTF-8 encoding to be used by default for text where appropriate.</p>
+<p>UTF-8 encoding is used by default for text where appropriate.</p>
</li>
<li>
@@ -119,77 +119,83 @@ and improves integration test configurat
</li>
<li>
-<p>Message parsing API improvements and performance optimization</p>
+<p>Redesign and rewrite of the HTTP caching protocol layer for better efficiency
+and improved conformance to RFC 9111 (HTTP Caching).</p>
</li>
<li>
-<p>TLS client endpoints to make use of JSSE Endpoint Identification by default.</p>
+<p>Cache control and context APIs.</p>
</li>
<li>
-<p>Redesign of server-side request routing API.</p>
+<p>ETag APIs.</p>
</li>
<li>
-<p>Redesign of TLS session handling by classic (blocking) connections.</p>
+<p>TLS SNI and endpoint identification improvements.</p>
</li>
-</ul></section><section>
-<h6><a name="a3_July_2024_-_HttpComponents_Core_5.2.5_GA_released"></a>3 July 2024 - HttpComponents Core 5.2.5 GA released</h6>
-<p>This is a maintenance release that corrects several minor defects discovered since
-release 5.2.4.</p></section><section>
-<h6><a name="a27_June_2024_-_HttpComponents_Client_5.4-beta1_released"></a>27 June 2024 - HttpComponents Client 5.4-beta1 released</h6>
-<p>This is the first BETA release in the 5.4 release series. It upgrades HttpCore to version
-5.3-beta1 and adds a few minor improvements and fixes.</p>
-<p>Notable changes and features included in the 5.4 series:</p>
-<ul>
+<li>
+<p>Support for RFC 2817 (Upgrading to TLS Within HTTP/1.1).</p>
+</li>
<li>
-<p>Improved conformance to RFC 9110 (HTTP Semantics), RFC 7616 (HTTP Digest Access
-Authentication), RFC 2617 (’Basic’ HTTP Authentication Scheme).</p>
+<p>Auth cache no longer makes use of Java serialization.</p>
</li>
<li>
-<p>UTF-8 encoding is used by default for text where appropriate.</p>
+<p>Deprecation of ConnectionSocketFactory and LayeredConnectionSocketFactory.</p>
</li>
<li>
-<p>Compatibility with Java Virtual Threads and Java 21 Runtime.</p>
+<p>HttpContext optimization and performance improvement.</p>
</li>
<li>
-<p>Redesign and rewrite of the HTTP caching protocol layer for better efficiency
-and improved conformance to RFC 9111 (HTTP Caching).</p>
+<p>Async cache is no longer considered experimental.</p>
</li>
+</ul></section><section>
+<h6><a name="a12_September_2024_-_HttpComponents_Core_5.3_GA_released"></a>12 September 2024 - HttpComponents Core 5.3 GA released</h6>
+<p>This is the first GA release in the 5.3 release series. This release finalizes the 5.3 APIs
+and improves integration test configuration APIs along with many test code improvements</p>
+<p>Notable changes and features included in the 5.3 series:</p>
+<ul>
+
<li>
-<p>Cache control and context APIs.</p>
+<p>Improved conformance to RFC 9110 and RFC 9112.</p>
</li>
<li>
-<p>ETag APIs.</p>
+<p>UTF-8 encoding to be used by default for text where appropriate.</p>
</li>
<li>
-<p>TLS SNI and endpoint identification improvements.</p>
+<p>Compatibility with Java Virtual Threads and Java 21 Runtime.</p>
</li>
<li>
-<p>Support for RFC 2817 (Upgrading to TLS Within HTTP/1.1).</p>
+<p>Message parsing API improvements and performance optimization</p>
</li>
<li>
-<p>Auth cache no longer makes use of Java serialization.</p>
+<p>TLS client endpoints to make use of JSSE Endpoint Identification by default.</p>
</li>
<li>
-<p>Deprecation of ConnectionSocketFactory and LayeredConnectionSocketFactory.</p>
+<p>Redesign of server-side request routing API.</p>
</li>
<li>
-<p>HttpContext optimization and performance improvement.</p>
+<p>Redesign of TLS session handling by classic (blocking) connections.</p>
</li>
</ul></section><section>
+<h6><a name="a3_July_2024_-_HttpComponents_Core_5.2.5_GA_released"></a>3 July 2024 - HttpComponents Core 5.2.5 GA released</h6>
+<p>This is a maintenance release that corrects several minor defects discovered since
+release 5.2.4.</p></section><section>
+<h6><a name="a27_June_2024_-_HttpComponents_Client_5.4-beta1_released"></a>27 June 2024 - HttpComponents Client 5.4-beta1 released</h6>
+<p>This is the first BETA release in the 5.4 release series. It upgrades HttpCore to version
+5.3-beta1 and adds a few minor improvements and fixes.</p></section><section>
<h6><a name="a26_June_2024_-_HttpComponents_Core_5.3-beta1_released"></a>26 June 2024 - HttpComponents Core 5.3-beta1 released</h6>
<p>This is the first BETA release in the 5.3 release series. It features a re-designed
classic (blocking) TLS session management and server-side request routing APIs.
Modified: httpcomponents/site/project-info.html
URL: http://svn.apache.org/viewvc/httpcomponents/site/project-info.html?rev=1920810&r1=1920809&r2=1920810&view=diff
==============================================================================
--- httpcomponents/site/project-info.html (original)
+++ httpcomponents/site/project-info.html Fri Sep 20 15:24:22 2024
@@ -25,7 +25,7 @@
<div id="breadcrumbs">
<ul class="breadcrumb">
- <li id="publishDate">Last Published: 2024-09-18<span class="divider">|</span>
+ <li id="publishDate">Last Published: 2024-09-20<span class="divider">|</span>
</li>
<li class=""><a href="index.html" title="HttpComponents">HttpComponents</a><span class="divider">/</span></li>
<li class="active ">Project Information</li>
@@ -51,8 +51,7 @@
<li><a href="charter.html" title="Project Charter"><span class="none"></span>Project Charter</a></li>
<li><a href="get-involved.html" title="Get Involved"><span class="none"></span>Get Involved</a></li>
<li class="nav-header">Components</li>
- <li><a href="httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4 BETA"><span class="icon-chevron-right"></span>HttpClient 5.4 BETA</a></li>
- <li><a href="httpcomponents-client-5.3.x/index.html" title="HttpClient 5.3"><span class="icon-chevron-right"></span>HttpClient 5.3</a></li>
+ <li><a href="httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4"><span class="icon-chevron-right"></span>HttpClient 5.4</a></li>
<li><a href="httpcomponents-core-5.3.x/index.html" title="HttpCore 5.3"><span class="icon-chevron-right"></span>HttpCore 5.3</a></li>
<li><a href="httpcomponents-client-4.5.x/index.html" title="HttpClient 4.5"><span class="icon-chevron-right"></span>HttpClient 4.5</a></li>
<li class="nav-header">Legacy</li>
Modified: httpcomponents/site/status.html
URL: http://svn.apache.org/viewvc/httpcomponents/site/status.html?rev=1920810&r1=1920809&r2=1920810&view=diff
==============================================================================
--- httpcomponents/site/status.html (original)
+++ httpcomponents/site/status.html Fri Sep 20 15:24:22 2024
@@ -25,7 +25,7 @@
<div id="breadcrumbs">
<ul class="breadcrumb">
- <li id="publishDate">Last Published: 2024-09-18<span class="divider">|</span>
+ <li id="publishDate">Last Published: 2024-09-20<span class="divider">|</span>
</li>
<li class=""><a href="index.html" title="HttpComponents">HttpComponents</a><span class="divider">/</span></li>
<li class="active ">HttpComponents Project Status <a href="https://github.com/apache/httpcomponents-website/tree/master/src/site/markdown/status.md"><img src="./images/accessories-text-editor.png" title="Edit" /></a></li>
@@ -51,8 +51,7 @@
<li><a href="charter.html" title="Project Charter"><span class="none"></span>Project Charter</a></li>
<li><a href="get-involved.html" title="Get Involved"><span class="none"></span>Get Involved</a></li>
<li class="nav-header">Components</li>
- <li><a href="httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4 BETA"><span class="icon-chevron-right"></span>HttpClient 5.4 BETA</a></li>
- <li><a href="httpcomponents-client-5.3.x/index.html" title="HttpClient 5.3"><span class="icon-chevron-right"></span>HttpClient 5.3</a></li>
+ <li><a href="httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4"><span class="icon-chevron-right"></span>HttpClient 5.4</a></li>
<li><a href="httpcomponents-core-5.3.x/index.html" title="HttpCore 5.3"><span class="icon-chevron-right"></span>HttpCore 5.3</a></li>
<li><a href="httpcomponents-client-4.5.x/index.html" title="HttpClient 4.5"><span class="icon-chevron-right"></span>HttpClient 4.5</a></li>
<li class="nav-header">Legacy</li>
@@ -100,23 +99,16 @@
-->
<h1>HttpComponents Project Status</h1><section>
<h2><a name="HttpComponents_HttpClient_5.4.x"></a>HttpComponents HttpClient 5.4.x</h2>
-<p>HttpClient 5.4.x branch is the current development branch. The 5.4.x release series upgrades HTTP protocol
-conformance level to RFC 9110, replaces <code>synchronized</code> blocks with lock primitives, redesigns the HTTP caching
-protocol layer for better efficiency and improved conformance to RFC 9111, introduces support for RFC 2817
-(Upgrading to TLS Within HTTP/1.1), and provides a number of other API enhancements. This branch also seeks
-to optimize common HTTP context operations that should translate in a better performance of HTTP message
-exchanges.</p></section><section>
-<h2><a name="HttpComponents_HttpClient_5.3.x"></a>HttpComponents HttpClient 5.3.x</h2>
-<p>HttpClient 5.2.x branch is considered stable and production ready. It is being actively maintained and supported.
-The 5.3.x release series introduces support for the Bearer authentication scheme (RFC 6750) and will deprecate
-NTLM and GSS based experimental authentication schemes in favor of Basic / Bearer authentication with TLS.</p></section><section>
+<p>HttpClient 5.4.x branch is considered stable and production ready. It is being actively maintained and supported.
+The 5.4.x release series upgrades HTTP protocol conformance level to RFC 9110, replaces <code>synchronized</code> blocks
+with lock primitives, redesigns the HTTP caching protocol layer for better efficiency and improved conformance
+to RFC 9111, introduces support for RFC 2817 (Upgrading to TLS Within HTTP/1.1), and provides a number of
+other API enhancements. This branch also seeks to optimize common HTTP context operations that should translate
+in a better performance of HTTP message exchanges.</p></section><section>
<h2><a name="HttpComponents_HttpCore_5.3.x"></a>HttpComponents HttpCore 5.3.x</h2>
-<p>HttpClient 5.3.x branch is the current development branch. The 5.3.x release series will upgrade HTTP protocol
-conformance level to RFC 9110 and will replace <code>synchronized</code> blocks with lock primitives.</p></section><section>
-<h2><a name="HttpComponents_HttpCore_5.2.x"></a>HttpComponents HttpCore 5.2.x</h2>
-<p>HttpCore 5.2.x branch is considered stable and production ready. It is being actively maintained and supported. The
-5.2.x release series provides comprehensive support for HTTP/1.1 and HTTP/2 protocol, full conformance with mandatory
-requirements of RFC 7230, RFC 7231, RFC 7540 and RFC 7541 and conditional conformance to RFC 3986.</p></section><section>
+<p>HttpCore 5.2.x branch is considered stable and production ready. It is being actively maintained and supported.
+The 5.3.x release series upgrades HTTP protocol conformance level to RFC 9110 and replaces <code>synchronized</code>
+blocks with lock primitives.</p></section><section>
<h2><a name="HttpComponents_HttpClient_4.5.x"></a>HttpComponents HttpClient 4.5.x</h2>
<p>HttpClient 4.5.x branch is considered stable and production ready. Please note the 4.x release series will be receiving
fixes for major defects and security issues only.</p>
Modified: httpcomponents/site/team.html
URL: http://svn.apache.org/viewvc/httpcomponents/site/team.html?rev=1920810&r1=1920809&r2=1920810&view=diff
==============================================================================
--- httpcomponents/site/team.html (original)
+++ httpcomponents/site/team.html Fri Sep 20 15:24:22 2024
@@ -25,7 +25,7 @@
<div id="breadcrumbs">
<ul class="breadcrumb">
- <li id="publishDate">Last Published: 2024-09-18<span class="divider">|</span>
+ <li id="publishDate">Last Published: 2024-09-20<span class="divider">|</span>
</li>
<li class=""><a href="index.html" title="HttpComponents">HttpComponents</a><span class="divider">/</span></li>
<li class="active ">Project Team</li>
@@ -51,8 +51,7 @@
<li><a href="charter.html" title="Project Charter"><span class="none"></span>Project Charter</a></li>
<li><a href="get-involved.html" title="Get Involved"><span class="none"></span>Get Involved</a></li>
<li class="nav-header">Components</li>
- <li><a href="httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4 BETA"><span class="icon-chevron-right"></span>HttpClient 5.4 BETA</a></li>
- <li><a href="httpcomponents-client-5.3.x/index.html" title="HttpClient 5.3"><span class="icon-chevron-right"></span>HttpClient 5.3</a></li>
+ <li><a href="httpcomponents-client-5.4.x/index.html" title="HttpClient 5.4"><span class="icon-chevron-right"></span>HttpClient 5.4</a></li>
<li><a href="httpcomponents-core-5.3.x/index.html" title="HttpCore 5.3"><span class="icon-chevron-right"></span>HttpCore 5.3</a></li>
<li><a href="httpcomponents-client-4.5.x/index.html" title="HttpClient 4.5"><span class="icon-chevron-right"></span>HttpClient 4.5</a></li>
<li class="nav-header">Legacy</li>