You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Andrew Wang (JIRA)" <ji...@apache.org> on 2013/11/20 00:21:27 UTC

[jira] [Assigned] (HDFS-5473) Consistent naming of user-visible caching classes and methods

     [ https://issues.apache.org/jira/browse/HDFS-5473?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Andrew Wang reassigned HDFS-5473:
---------------------------------

    Assignee: Colin Patrick McCabe  (was: Andrew Wang)

> Consistent naming of user-visible caching classes and methods
> -------------------------------------------------------------
>
>                 Key: HDFS-5473
>                 URL: https://issues.apache.org/jira/browse/HDFS-5473
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: datanode, namenode
>    Affects Versions: 3.0.0
>            Reporter: Andrew Wang
>            Assignee: Colin Patrick McCabe
>
> It's kind of warty that (after HDFS-5326 goes in) DistributedFileSystem has {{*CachePool}} methods take a {{CachePoolInfo}} and {{*PathBasedCacheDirective}} methods that thake a {{PathBasedCacheDirective}}. We should consider renaming {{CachePoolInfo}} to {{CachePool}} for consistency.



--
This message was sent by Atlassian JIRA
(v6.1#6144)