You are viewing a plain text version of this content. The canonical link for it is here.
Posted to ivy-commits@incubator.apache.org by "Stephane Bailliez (JIRA)" <ji...@apache.org> on 2006/12/27 13:59:20 UTC

[jira] Created: (IVY-362) StatusManager needs to be rewritten for clarity

StatusManager needs to be rewritten for clarity
-----------------------------------------------

                 Key: IVY-362
                 URL: http://issues.apache.org/jira/browse/IVY-362
             Project: Ivy
          Issue Type: Bug
          Components: Core
    Affects Versions: 1.4.1
            Reporter: Stephane Bailliez
            Priority: Minor


StatusManager has comments which are not reflecting the implementation.

addStatus could be called as well after creating it with the non-bean ctor, it would make it as useless as the map is already precomputed.

There are subtleties in this class that needs to be eliminated or make more clear.
It either need to be simplified and/or needs to fail on update methods when the maps have already been precomputed.


-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] Updated: (IVY-362) StatusManager needs to be rewritten for clarity

Posted by "Gilles Scokart (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/IVY-362?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Gilles Scokart updated IVY-362:
-------------------------------

    Fix Version/s: 2.0

> StatusManager needs to be rewritten for clarity
> -----------------------------------------------
>
>                 Key: IVY-362
>                 URL: https://issues.apache.org/jira/browse/IVY-362
>             Project: Ivy
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 1.4.1
>            Reporter: Stephane Bailliez
>            Priority: Minor
>             Fix For: 2.0
>
>
> StatusManager has comments which are not reflecting the implementation.
> addStatus could be called as well after creating it with the non-bean ctor, it would make it as useless as the map is already precomputed.
> There are subtleties in this class that needs to be eliminated or make more clear.
> It either need to be simplified and/or needs to fail on update methods when the maps have already been precomputed.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (IVY-362) StatusManager needs to be rewritten for clarity

Posted by "Stephane Bailliez (JIRA)" <ji...@apache.org>.
    [ http://issues.apache.org/jira/browse/IVY-362?page=comments#action_12461012 ] 
            
Stephane Bailliez commented on IVY-362:
---------------------------------------

Code that needs to be removed as well are things like:

        Boolean isIntegration = (Boolean)_statusIntegrationMap.get(status);
        if (isIntegration == null) {
            Message.debug("unknown status "+status+": assuming integration");
            return true;
        }

It really adds more code than necessary.

The map initialization is done internally and based on a status which provides a boolean...
so unless things went dramatically wrong in the initialization code, it is better to have the code to blow up instantly because there is a mistake in the initialization code rather than silently continuing as assigning values by itself.

> StatusManager needs to be rewritten for clarity
> -----------------------------------------------
>
>                 Key: IVY-362
>                 URL: http://issues.apache.org/jira/browse/IVY-362
>             Project: Ivy
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 1.4.1
>            Reporter: Stephane Bailliez
>            Priority: Minor
>
> StatusManager has comments which are not reflecting the implementation.
> addStatus could be called as well after creating it with the non-bean ctor, it would make it as useless as the map is already precomputed.
> There are subtleties in this class that needs to be eliminated or make more clear.
> It either need to be simplified and/or needs to fail on update methods when the maps have already been precomputed.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira