You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@bigtop.apache.org by "Evans Ye (JIRA)" <ji...@apache.org> on 2015/02/11 15:17:12 UTC

[jira] [Commented] (BIGTOP-1662) puppet: Fix configuration file incompleteness due to hiera conversion

    [ https://issues.apache.org/jira/browse/BIGTOP-1662?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14316235#comment-14316235 ] 

Evans Ye commented on BIGTOP-1662:
----------------------------------

Hey [~michaelweiser], I've tested the patch. In general, this is a great work. We're getting the kerberos feature almost fixed.
There's a realm configuration missing in cluster.yaml that causing all the principal in hdfs-site.xml not having realm, hence namenode startup fail.
Here's a quick and dirty fix I added into cluster.yaml:
{code}
hadoop::kerberos_realm: "%{hiera('kerberos::site::realm')}"
{code}
This will propagate realm setting to hadoop's init.pp. After adding this I can successfully provision a kerberos cluster.

Here's the kerberos setting I added in site.yaml FYR (copied from cluster.yaml):
{code}
hadoop::hadoop_security_authentication: "kerberos"
kerberos::site::domain: "do.main"
kerberos::site::realm: "DO.MAIN"
kerberos::site::kdc_server: "bigtop1.docker"
kerberos::site::kdc_port: "88"
kerberos::site::admin_port: "749"
kerberos::site::keytab_export_dir: "/var/lib/bigtop_keytabs"
{code}

However, for an official fix, we shall use the naming convention introduced in BIGTOP-1634, that would be something like this: 
{code}
hadoop::common_hdfs::kerberos_realm: "%{hiera('kerberos::site::realm')}
{code}
and then updated $hadoop::kerberos_realm to $hadoop::common_hdfs::kerberos_realm in hadoop init.pp.

Are you planning to fix one component each time? We've solr, zookeeper, oozie, hue, and hbase, which are also need to be fixed as well. I'm ok to fix it one by one. But how about rename the title to specific to hadoop, so that we can do other components in separated JIRA.

> puppet: Fix configuration file incompleteness due to hiera conversion
> ---------------------------------------------------------------------
>
>                 Key: BIGTOP-1662
>                 URL: https://issues.apache.org/jira/browse/BIGTOP-1662
>             Project: Bigtop
>          Issue Type: Bug
>          Components: deployment
>    Affects Versions: backlog
>            Reporter: Michael Weiser
>         Attachments: 0001-BIGTOP-1662-puppet-Fix-configuration-file-incomplete.patch
>
>
> The changes from BIGTOP-1634 omit kerberos_realm and hadoop_security_authentication variables from some classes so that they're not correctly entered in the generated configuration files. Also, a hasty "fix" to hadoop-env.sh causes all variables to remain unset always.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)