You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@commons.apache.org by "Julien Ruiz (JIRA)" <ji...@apache.org> on 2010/07/29 16:07:16 UTC

[jira] Created: (MATH-399) Incorrect javadoc for RealVector subtract method

Incorrect javadoc for RealVector subtract method
------------------------------------------------

                 Key: MATH-399
                 URL: https://issues.apache.org/jira/browse/MATH-399
             Project: Commons Math
          Issue Type: Bug
            Reporter: Julien Ruiz
            Priority: Minor


subtract method decription is :

069         * Compute this minus v.
070         * @param v vector to be subtracted
071         * @return this + v
072         * @throws IllegalArgumentException if v is not the same size as this
073         */
(...)
080         * @return this + v

Should be : return this - v

Besides, method might be renamed to substract .

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Resolved: (MATH-399) Incorrect javadoc for RealVector subtract method

Posted by "Luc Maisonobe (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/MATH-399?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Luc Maisonobe resolved MATH-399.
--------------------------------

    Resolution: Fixed

fixed in subversion repository as of r980544.
thanks for reporting this.

On a side note, it really seems subtract is the proper spelling whereas substract is a common misspelling. I am not a native english speaker, so I checked several references.

> Incorrect javadoc for RealVector subtract method
> ------------------------------------------------
>
>                 Key: MATH-399
>                 URL: https://issues.apache.org/jira/browse/MATH-399
>             Project: Commons Math
>          Issue Type: Bug
>            Reporter: Julien Ruiz
>            Priority: Minor
>   Original Estimate: 4h
>  Remaining Estimate: 4h
>
> subtract method decription is :
> 069         * Compute this minus v.
> 070         * @param v vector to be subtracted
> 071         * @return this + v
> 072         * @throws IllegalArgumentException if v is not the same size as this
> 073         */
> (...)
> 080         * @return this + v
> Should be : return this - v
> Besides, method might be renamed to substract .

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (MATH-399) Incorrect javadoc for RealVector subtract method

Posted by "Julien Ruiz (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/MATH-399?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12893963#action_12893963 ] 

Julien Ruiz commented on MATH-399:
----------------------------------

Thanks for solving it.

I really would have bet for substract. But I double checked and it seems I
was wrong indeed (french speaking mistake maybe).

I hope my next contributions will be more valuable...

Julien
2010/7/29 Luc Maisonobe (JIRA) <ji...@apache.org>



> Incorrect javadoc for RealVector subtract method
> ------------------------------------------------
>
>                 Key: MATH-399
>                 URL: https://issues.apache.org/jira/browse/MATH-399
>             Project: Commons Math
>          Issue Type: Bug
>            Reporter: Julien Ruiz
>            Priority: Minor
>   Original Estimate: 4h
>  Remaining Estimate: 4h
>
> subtract method decription is :
> 069         * Compute this minus v.
> 070         * @param v vector to be subtracted
> 071         * @return this + v
> 072         * @throws IllegalArgumentException if v is not the same size as this
> 073         */
> (...)
> 080         * @return this + v
> Should be : return this - v
> Besides, method might be renamed to substract .

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.