You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@pivot.apache.org by "Greg Brown (JIRA)" <ji...@apache.org> on 2010/08/27 18:45:55 UTC

[jira] Updated: (PIVOT-616) TextInput API improvements

     [ https://issues.apache.org/jira/browse/PIVOT-616?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Greg Brown updated PIVOT-616:
-----------------------------

    Description: 
Make the following updates to the TextInput API, to improve performance and to align API with that of new TextArea:

- Add a getCharacters() method that returns a CharSequence representing the text input's content.

- Rename insert()/delete() to insertText()/removeText(), and change insert behavior such that the caller is responsible for performing the delete rather than the insertion method.

- Rename TextInputTextListener to TextInputContentListener.

- Change charactersInserted() to textInserted() and charactersRemoved() to textRemoved(); replace characters argument in textRemoved() with a character count to optimize performance (eliminate unnecessary string copy).

- Make text insert/remove events vetoable; re-implement "strictValidation" using these events.

- Remove getTextLength(); superseded by getCharacters().length().


  was:
Make the following updates to the TextInput API, to improve performance and to align API with that of new TextArea:

- Add a getCharacters() method that returns a CharSequence representing the text input's content.

- Rename insert()/delete() to insertText()/removeText(), and change insert behavior such that the caller is responsible for performing the delete rather than the insertion method.

- Rename TextInputTextListener to TextInputContentListener.

- Change charactersInserted() to textInserted() and charactersRemoved() to textRemoved(); replace characters argument in textRemoved() with a character count to optimize performance (eliminate unnecessary string copy).

- Make text insert/remove events vetoable, replacing "strictValidation" style in TerraTextInputSkin.

- Remove getTextLength(); superseded by getCharacters().length().



> TextInput API improvements
> --------------------------
>
>                 Key: PIVOT-616
>                 URL: https://issues.apache.org/jira/browse/PIVOT-616
>             Project: Pivot
>          Issue Type: Improvement
>          Components: wtk
>            Reporter: Greg Brown
>             Fix For: 2.0
>
>
> Make the following updates to the TextInput API, to improve performance and to align API with that of new TextArea:
> - Add a getCharacters() method that returns a CharSequence representing the text input's content.
> - Rename insert()/delete() to insertText()/removeText(), and change insert behavior such that the caller is responsible for performing the delete rather than the insertion method.
> - Rename TextInputTextListener to TextInputContentListener.
> - Change charactersInserted() to textInserted() and charactersRemoved() to textRemoved(); replace characters argument in textRemoved() with a character count to optimize performance (eliminate unnecessary string copy).
> - Make text insert/remove events vetoable; re-implement "strictValidation" using these events.
> - Remove getTextLength(); superseded by getCharacters().length().

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.