You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@ambari.apache.org by "Newton Alex (JIRA)" <ji...@apache.org> on 2014/10/25 02:31:33 UTC

[jira] [Commented] (AMBARI-7967) Make Ganglia references Stack neutral

    [ https://issues.apache.org/jira/browse/AMBARI-7967?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14183793#comment-14183793 ] 

Newton Alex commented on AMBARI-7967:
-------------------------------------


Thinking of two approaches:

1. Set the Ganglia names dynamically during run time
----------------
    GANGLIA_CLUSTER_NAME_MAP.put("NAMENODE", Collections.singletonList(stackName + "NameNode"));
    GANGLIA_CLUSTER_NAME_MAP.put("JOBTRACKER", Collections.singletonList(stackName + "JobTracker"));
-----------
In the first approach, existing stacks needs minimal change but every stack has to define its own Ganglia metric files

2. Rename the exiting names to generic names
-------
    GANGLIA_CLUSTER_NAME_MAP.put("NAMENODE", Collections.singletonList("NameNode"));
    GANGLIA_CLUSTER_NAME_MAP.put("JOBTRACKER", Collections.singletonList("JobTracker"));
-------
The second approach will impact the current HDP stack definitions but will help in defining the common services as it would be uniform across stacks.



> Make Ganglia references Stack neutral
> -------------------------------------
>
>                 Key: AMBARI-7967
>                 URL: https://issues.apache.org/jira/browse/AMBARI-7967
>             Project: Ambari
>          Issue Type: Bug
>            Reporter: Newton Alex
>            Assignee: Newton Alex
>
> Make Ganglia references Stack neutral in the core Ambari code. There are specific HDP references like "HDPJobTracker" in the Ambari Ganglia code. Few examples are below:
> >>org/apache/ambari/server/controller/ganglia/GangliaPropertyProvider.java
> ---------------
>     GANGLIA_CLUSTER_NAME_MAP.put("NAMENODE",           Collections.singletonList("HDPNameNode"));
>     GANGLIA_CLUSTER_NAME_MAP.put("DATANODE",           Arrays.asList("HDPDataNode", "HDPSlaves"));
> ----------------------
> >>org/apache/ambari/server/controller/ganglia/GangliaHostPropertyProvider.java
> -----------------
>   GANGLIA_CLUSTER_NAMES.add("HDPResourceManager");
>     GANGLIA_CLUSTER_NAMES.add("HDPHBaseMaster");
> -------------------
> >>stacks/BIGTOP/0.8/services/GANGLIA/package/files/gmond.init
> --------------------
> HDP_GANLIA_GMOND_STARTER=${HDP_GANGLIA_RUNTIME_COMPONENTS_DIR}/startGmond.sh
> HDP_GANLIA_GMOND_STOPPER=${HDP_GANGLIA_RUNTIME_COMPONENTS_DIR}/stopGmond.sh
> ------------------



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)