You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@cassandra.apache.org by "Jonathan Ellis (JIRA)" <ji...@apache.org> on 2009/04/25 17:45:31 UTC

[jira] Resolved: (CASSANDRA-95) clean up ReadCommand and related stuff for read repairs

     [ https://issues.apache.org/jira/browse/CASSANDRA-95?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Jonathan Ellis resolved CASSANDRA-95.
-------------------------------------

    Resolution: Fixed

you're right; it's definitely an improvement in maintainability.  i just wish we could be concise as well.

committed, with one minor change to v3: dropped the Get prefix from the ReadCommand subclasses.


> clean up ReadCommand and related stuff for read repairs
> -------------------------------------------------------
>
>                 Key: CASSANDRA-95
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-95
>             Project: Cassandra
>          Issue Type: Improvement
>            Reporter: Jun Rao
>            Assignee: Jun Rao
>         Attachments: issue95.patchv1, issue95.patchv2, issue95.patchv3
>
>
> Today, ReadCommand doesn't have an explicit type attribute. A specific type of ReadCommand is determined based on subtle difference in parameters set.  For example:
>         if (start > 0 || (count > 0 && count < Integer.MAX_VALUE))
>         {
>             return table.getRow(key, columnFamilyColumn, start, count);
>         }
> A get_slice ReadCommand is determined based on start and count values. This is very hard to understand. Also, code like that is duplicated in ReadCommand and ConsistencyManager.
> We need to make it easier to determine the type of a ReadCommand. This is necessary for code maintenance as well as supporting new APIs in the future.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.