You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@kafka.apache.org by "Chia-Ping Tsai (Jira)" <ji...@apache.org> on 2026/04/04 13:37:00 UTC

[jira] [Resolved] (KAFKA-20375) Unify method signature for retrieving config names across config classes

     [ https://issues.apache.org/jira/browse/KAFKA-20375?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Chia-Ping Tsai resolved KAFKA-20375.
------------------------------------
    Fix Version/s: 4.4.0
       Resolution: Fixed

> Unify method signature for retrieving config names across config classes
> ------------------------------------------------------------------------
>
>                 Key: KAFKA-20375
>                 URL: https://issues.apache.org/jira/browse/KAFKA-20375
>             Project: Kafka
>          Issue Type: Improvement
>            Reporter: Chia-Ping Tsai
>            Assignee: Lan Ding
>            Priority: Minor
>             Fix For: 4.4.0
>
>
> GroupConfig#configNames() returns Set<String>
> ClientMetricsConfigs#names() returns Set<String>
> LogConfig#configNames() returns List<String> (sorted)
> we should rename names() to configNames(). Additionally, we should standardise their implementations to directly return `CONFIG.names()`



--
This message was sent by Atlassian Jira
(v8.20.10#820010)