You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@jena.apache.org by "Andy Seaborne (JIRA)" <ji...@apache.org> on 2015/07/13 10:27:04 UTC
[jira] [Created] (JENA-986) Separate use of AnonId : keepin RDf
API, introduce BlankNodeId for Graph SPI
Andy Seaborne created JENA-986:
----------------------------------
Summary: Separate use of AnonId : keepin RDf API, introduce BlankNodeId for Graph SPI
Key: JENA-986
URL: https://issues.apache.org/jira/browse/JENA-986
Project: Apache Jena
Issue Type: Improvement
Components: Core
Affects Versions: Jena 3.0.0
Reporter: Andy Seaborne
Assignee: Andy Seaborne
{{AnonId}} is a classed used in both the RDF API and the Graph SPI. It resides in the RDF API package which blocks separating of the Graph SPI from the RDF API.
The proposal is to
# introduce {{BlankNodeId}} as the Graph SPI concept and keep {{AnonId}} as the application-visible class.
# Introduce a factory operation to create from a string label as the vast majority of uses of {{NodeFactory.createAnon}} do in fact wrap a string in an AnonId to pass it to {{NodeFactory.createAnon}}. The use case is parsers and related persistent data to java object construction.
# Rename {{NodeFactory.createAnon}} as {{NodeFactory.createBlankNode}} for consistent naming (leaving deprecated versions in place).
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)